#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 14:44:26 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 14:44:45)
    1. Attendees -- Ondrej, Aman, Arthur, Dave (dwallacelf, 14:45:39)

  2. Action Items (dwallacelf, 14:46:55)
    1. Mohsin Kazmi to maintain libmemif in VPP repo (dwallacelf, 14:48:23)
    2. Isues related to GoMemif have been addressed in PRs which were merged (dwallacelf, 14:49:40)
    3. ACTION: Dave to talk to Mohsin about maintaining GoMemif implementation as well as VPP/libmemif (dwallacelf, 14:59:54)
    4. ACTION: Arthur investigate any know consumers of GoVPP/libmemif and/or gomemif (dwallacelf, 15:14:09)
    5. ACTION: Dave reach out to CSIT to add interoperability testing for VPP/libmemif, VPP/memif plugin, GoVPP/libmemif, GoVPP/gomemif, and DPDK/memif PMD (dwallacelf, 15:16:34)
    6. Vlado rebased PR#116 and Nathan added comments (dwallacelf, 15:22:36)
    7. ACTION: Ondrej to review/merge PR#116 (dwallacelf, 15:22:52)

  3. Inputs From Projects (dwallacelf, 15:23:24)
    1. VPP Release Plan 24.02 is published, RC1 is Jan 24, 2024 (dwallacelf, 15:24:24)
    2. https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_24.02 (dwallacelf, 15:24:35)
    3. Calico/VPP is now GA as of Calico Release 3.27 (dwallacelf, 15:27:43)

  4. Technical Discussion (dwallacelf, 15:28:32)
    1. Discussion of VPP API cleanup (dwallacelf, 15:29:36)
    2. ACTION: Ondrej to review current state of GoVPP CLI linting output (dwallacelf, 15:33:36)
    3. Ondrej added PR#183 to address lack of synchronization of VPPApiError enum & descriptions. (dwallacelf, 15:42:05)
    4. Ondrej investigating a mechanism to add an app or extenstion to GoVPP/cli to send api messages directly. Discussion about possibility of using such an app in VPP make test refactoring plan. (dwallacelf, 15:43:52)


Meeting ended at 15:43:56 UTC (full logs).

Action items

  1. Dave to talk to Mohsin about maintaining GoMemif implementation as well as VPP/libmemif
  2. Arthur investigate any know consumers of GoVPP/libmemif and/or gomemif
  3. Dave reach out to CSIT to add interoperability testing for VPP/libmemif, VPP/memif plugin, GoVPP/libmemif, GoVPP/gomemif, and DPDK/memif PMD
  4. Ondrej to review/merge PR#116
  5. Ondrej to review current state of GoVPP CLI linting output


People present (lines said)

  1. dwallacelf (21)
  2. collab-meetbot` (3)


Generated by MeetBot 0.1.4.