#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 14:30:34 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 14:32:32)
  2. Action Items (dwallacelf, 14:39:46)
    1. Arthur confirmed that Calico/VPP does not use gomemif (dwallacelf, 14:40:12)
    2. ACTION: Dave to talk to Mohsin about maintaining GoMemif implementation as well as VPP/libmemif (dwallacelf, 14:40:35)
    3. ACTION: Dave reach out to CSIT to add interoperability testing for VPP/libmemif, VPP/memif plugin, GoVPP/libmemif, GoVPP/gomemif, and DPDK/memif PMD (dwallacelf, 14:40:54)
    4. ACTION: Ondrej to review/merge PR#116 (dwallacelf, 14:41:40)
    5. ACTION: Ondrej to review current state of GoVPP CLI linting output (dwallacelf, 14:42:01)

  3. Inputs From Projects (dwallacelf, 14:42:25)
    1. VPP Release 24.02 RC1 happened yesterday (dwallacelf, 14:42:45)

  4. Technical Discussion (dwallacelf, 14:51:35)
    1. Discussion of memory leak bug fixed by PR#184 (dwallacelf, 14:52:29)
    2. https://github.com/FDio/govpp/pull/184 (dwallacelf, 14:52:34)
    3. Vlado is proposing a VPP release to deploy the memory leak fix sooner rather than later (dwallacelf, 14:56:41)
    4. ACTION: Ondrej to schedule a point release for downstream consumers to deploy the fix via a release (dwallacelf, 15:00:26)
    5. Discussion of Memory leak test PR#186 (dwallacelf, 15:00:46)
    6. https://github.com/FDio/govpp/pull/186 (dwallacelf, 15:00:57)
    7. ACTION: Ondrej to review/merge PR#186 Memory Benchmark test (dwallacelf, 15:02:21)
    8. Discussion of adding PR#186 to CI (dwallacelf, 15:04:05)
    9. This test is not applicable to per-patch CI. It would be best to run before each release.  Does not currently pass when run in CI. (dwallacelf, 15:05:32)
    10. ACTION: Vlado to open issue describing proposal to automate execution of PR#186 in the CI (dwallacelf, 15:09:26)
    11.   Issue#176 closed as completed by Release 0.9.0 (dwallacelf, 15:17:19)


Meeting ended at 15:47:16 UTC (full logs).

Action items

  1. Dave to talk to Mohsin about maintaining GoMemif implementation as well as VPP/libmemif
  2. Dave reach out to CSIT to add interoperability testing for VPP/libmemif, VPP/memif plugin, GoVPP/libmemif, GoVPP/gomemif, and DPDK/memif PMD
  3. Ondrej to review/merge PR#116
  4. Ondrej to review current state of GoVPP CLI linting output
  5. Ondrej to schedule a point release for downstream consumers to deploy the fix via a release
  6. Ondrej to review/merge PR#186 Memory Benchmark test
  7. Vlado to open issue describing proposal to automate execution of PR#186 in the CI


People present (lines said)

  1. dwallacelf (23)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.