#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 13:36:39 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 13:38:14)
    1. Attendees: Dave, Ondrej, Vlado, Arthur, Nathan (dwallacelf, 13:41:13)

  2. Action Items (dwallacelf, 13:44:01)
    1. Ondrej generated GoVPP Release 0.10 \o/ (dwallacelf, 13:44:20)
    2. Ondrej suggested automating release process with go-releaser (dwallacelf, 13:44:49)
    3. ACTION: Ondrej to automate release process and include SBOM generation with the release and update release document accordingly (dwallacelf, 13:46:15)
    4. https://github.com/FDio/govpp/blob/master/docs/RELEASE.md (dwallacelf, 13:46:45)
    5. ACTION: Mohsin to investigate libmemif known use cases and put forth a proposal for interoerability testing with GoVPP memif libraries (dwallacelf, 13:47:11)
    6. ACTION: Ondrej to review current state of GoVPP CLI linting output (dwallacelf, 13:47:37)
    7. ACTION: Ondrej to review/merge PR#186 Memory Benchmark test (dwallacelf, 13:48:26)
    8. ACTION: Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community (dwallacelf, 13:48:51)
    9. Discussion of using Github for Docker container storage vs docker hub (dwallacelf, 13:59:43)
    10. VPP Docker runtime containers are generated by ligato/vpp-base project (not really related to ligato per se) (dwallacelf, 14:09:46)
    11. https://github.com/ligato/vpp-base?tab=readme-ov-file (dwallacelf, 14:09:50)

  3. Inputs From Projects (dwallacelf, 14:14:00)
    1. Calico/VPP user raised GoVPP Issue#192 (dwallacelf, 14:17:24)
    2. No DTF sessions have been proposed for FD.io so Dave cancelling travel plans (dwallacelf, 14:19:19)

  4. Technical Discussion (dwallacelf, 14:19:32)
    1. ACTION: Moshin to respond to Issue#196 about gomemif (dwallacelf, 14:21:26)


Meeting ended at 14:25:19 UTC (full logs).

Action items

  1. Ondrej to automate release process and include SBOM generation with the release and update release document accordingly
  2. Mohsin to investigate libmemif known use cases and put forth a proposal for interoerability testing with GoVPP memif libraries
  3. Ondrej to review current state of GoVPP CLI linting output
  4. Ondrej to review/merge PR#186 Memory Benchmark test
  5. Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
  6. Moshin to respond to Issue#196 about gomemif


People present (lines said)

  1. dwallacelf (21)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.