#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 13:49:01 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 13:49:56)
    1. Attendees Dave, Ondrej, Nathan, Vlado (dwallacelf, 13:50:10)

  2. Action Items (dwallacelf, 13:50:44)
    1. ACTION: Ondrej to check the go.mod import for govpp/extras (Issue# 207 / Issue#111) (dwallacelf, 13:53:10)
    2. ACTION: Ondrej to add extras/gomemif examples to CI tests (dwallacelf, 13:53:24)
    3. ACTION: Ondrej to set up a daily vpp-api-report repo in github.com/vpp-dev to run the CLI api report tool daily (dwallacelf, 13:53:36)
    4. Ondrej made some progress on setting up vpp-api-report (dwallacelf, 13:53:47)
    5. ACTION: Ondrej to investigate adding memory leak test to CI (dwallacelf, 13:54:04)
    6. ACTION: Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community (dwallacelf, 13:54:26)
    7. ACTION: Dave to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions (dwallacelf, 13:54:40)

  3. Inputs From Projects (dwallacelf, 13:55:48)
    1. VPP 24.06 Release completed yesterday \o/ (dwallacelf, 13:56:24)
    2. ACTION: Ondrej to generate a new GoVPP release (dwallacelf, 13:57:01)

  4. Technical Discussion (dwallacelf, 14:04:31)
    1. Discussion of testing PR#216 gomemif library improvements.  Ondrej working on adding gomemif examples to CI. Then Mohsin can add new examples/ testcases moving forward (dwallacelf, 14:05:34)
    2. Ondrej working on Issue#215 (dwallacelf, 14:11:50)
    3. Ondrej suggesting transitioning meeting minutes / action item tracking to GitHub native infra.  Dave currently prefers IRC chatbot based logs since he uses it for other FD.io meetings. (dwallacelf, 14:15:47)


Meeting ended at 14:16:45 UTC (full logs).

Action items

  1. Ondrej to check the go.mod import for govpp/extras (Issue# 207 / Issue#111)
  2. Ondrej to add extras/gomemif examples to CI tests
  3. Ondrej to set up a daily vpp-api-report repo in github.com/vpp-dev to run the CLI api report tool daily
  4. Ondrej to investigate adding memory leak test to CI
  5. Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
  6. Dave to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions
  7. Ondrej to generate a new GoVPP release


People present (lines said)

  1. dwallacelf (20)
  2. collab-meetbot (7)
  3. edwarnicke (0)
  4. sknat (0)


Generated by MeetBot 0.1.4.