#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 13:42:02 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 13:42:17)
  2. Action Items (dwallacelf, 13:42:54)
    1. ACTION: Ondrej to check the go.mod import for govpp/extras (Issue# 207 / Issue#111) (dwallacelf, 13:43:52)
    2. ACTION: Ondrej to add extras/gomemif examples to CI tests (dwallacelf, 13:44:06)
    3. ACTION: Ondrej to set up a daily vpp-api-report repo in github.com/vpp-dev to run the CLI api report tool daily (dwallacelf, 13:44:18)
    4. ACTION: Ondrej to investigate adding memory leak test to CI (dwallacelf, 13:44:29)
    5. ACTION: Ondrej to generate a new GoVPP release (dwallacelf, 13:44:41)
    6. ACTION: Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community (dwallacelf, 13:44:56)
    7. ACTION: Dave to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions (dwallacelf, 13:45:15)

  3. Inputs From Projects (dwallacelf, 13:45:30)
    1. CSIT VPP 24.06 Release Report was compelted (dwallacelf, 13:45:56)
    2. Dave working on adding VPP Ubuntu 24.04 jobs, currently working on upgrading scapy to 2.4.5 (dwallacelf, 13:47:08)
    3. Discussion of use of GitHub pages for a wiki. Not needed for GoVPP due to coverage in documentation in the repo. (dwallacelf, 13:49:59)

  4. Technical Discussion (dwallacelf, 13:50:41)
    1. No new issues to discuss (dwallacelf, 13:52:52)
    2. Mohsin has one PR in flight.  Ondrej to review/merge (dwallacelf, 14:18:04)
    3. ACTION: Mohsin to create 'test-gomemif' infrastructure (patterned after 'test-integration') to run gomemif examples locally, then Ondrej to add to github workflows. (dwallacelf, 14:19:01)
    4. Attendees Ondrej, Vlado, Mohsin, Dave (dwallacelf, 14:20:00)


Meeting ended at 14:20:06 UTC (full logs).

Action items

  1. Ondrej to check the go.mod import for govpp/extras (Issue# 207 / Issue#111)
  2. Ondrej to add extras/gomemif examples to CI tests
  3. Ondrej to set up a daily vpp-api-report repo in github.com/vpp-dev to run the CLI api report tool daily
  4. Ondrej to investigate adding memory leak test to CI
  5. Ondrej to generate a new GoVPP release
  6. Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
  7. Dave to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions
  8. Mohsin to create 'test-gomemif' infrastructure (patterned after 'test-integration') to run gomemif examples locally, then Ondrej to add to github workflows.


People present (lines said)

  1. dwallacelf (20)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.