#fdio-meeting: FD.io TSC

Meeting started by dwallacelf at 16:00:14 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 16:00:29)
    1. valderrv (valderrv, 16:00:40)
    2. Joel Halpern (JoelHalpern, 16:00:41)
    3. Fan Zhang (fan_zhang, 16:00:48)
    4. Vratko Polak proxying for Maciek Konstantynowicz. (vrpolak, 16:01:43)
    5. Matt Smith (mgsmith, 16:02:19)
    6. Next week's meeting is cancelled due to US Holiday (dwallacelf, 16:03:19)
    7. Jeff Shaw (JeffShaw, 16:03:32)

  2. Action Items (dwallacelf, 16:04:14)
    1. ACTION: Dave to discuss VPP NIC support driver with VPP and CSIT communities and Kai Ji (DPDK) to ensure DPDK, VPP, and CSIT hardware support policies are in sync. (dwallacelf, 16:04:38)
    2. ACTION: Dave to post 25.10 Updates and any New Users to FD.io (dwallacelf, 16:05:20)
    3. Discussion of software driver support for old hardware (dwallacelf, 16:06:25)
    4. Input from DPDK community is that there is no good means of determining what drivers are supported.  It is up to the user to contact the hardware vendor directly to determine whether the driver is supported and/or verified to be working (dwallacelf, 16:28:18)
    5. Dave will discuss documenting the policy that drivers that have hardware in CSIT are by construct supported and verified to work, otherwise it is up to the consumer to verify the drivers work. (dwallacelf, 16:31:07)

  3. Infra (dwallacelf, 16:39:30)
    1. Some SuperMicro components shipment is stuck in customs, but the racking plan is all set avoiding any storage charges (dwallacelf, 16:41:35)
    2. jenkins outage last night.  Started working again without jenkins being restarted, but there still seems to be some issues.  Vanessa is investigating and will pick up the ticket. (dwallacelf, 16:42:39)
    3. Jenkins migration to GHA is progressing on schedule to go into production on Dec 15 or sooner.  CSIT timed jobs are running have been migrated to GHA. (dwallacelf, 16:43:58)
    4. Discussion of migration to zulip.  Casey has had requests for project specific channels from other projects and is working with LF-IT on a process to get them created. (dwallacelf, 16:45:11)
    5. FD.io adoption of zulip has been mostly non-existent and is not likely to occur without project specific channels (dwallacelf, 16:45:55)

  4. Events (dwallacelf, 16:46:16)
    1. Maciek submitted a talk for the main room. Networking devroom CFP is open through Dec 5, 2025 (dwallacelf, 16:47:35)
    2. Please encourage submissions to the Networking Devroom and DM Dave with any submissions (dwallacelf, 16:48:13)

  5. Website & PR (dwallacelf, 16:48:47)
    1. Discussion of FD.io Podcast series.  Dave will pick this up in early Dec to move it forward. (dwallacelf, 16:49:39)


Meeting ended at 16:50:17 UTC (full logs).

Action items

  1. Dave to discuss VPP NIC support driver with VPP and CSIT communities and Kai Ji (DPDK) to ensure DPDK, VPP, and CSIT hardware support policies are in sync.
  2. Dave to post 25.10 Updates and any New Users to FD.io


People present (lines said)

  1. dwallacelf (22)
  2. collab-meetbot (13)
  3. valderrv (1)
  4. JoelHalpern (1)
  5. mgsmith (1)
  6. vrpolak (1)
  7. fan_zhang (1)
  8. JeffShaw (1)
  9. edwarnicke (0)
  10. mackonstan (0)


Generated by MeetBot 0.1.4.