#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 14:41:09 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 14:42:15)
    1. ACTION: Ondrej to investigate adding memory leak test to CI (dwallacelf, 14:47:28)
    2. ACTION: Ondrej to generate a release (dwallacelf, 14:47:46)
    3. ACTION: Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community (dwallacelf, 14:48:02)
    4. ACTION: Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions (dwallacelf, 14:48:27)
    5. ACTION: Dave to notify VPP community of issue with socket client and GoVPP PR#248 (might have been done, will confirm) (dwallacelf, 14:50:17)

  2. Inputs From Projects (dwallacelf, 14:50:35)
    1. VPP Release 25.02 schedule starts with branch pull on Jan 22, follows regular cadence (dwallacelf, 14:51:15)

  3. Technical Discussion (dwallacelf, 14:53:09)
    1. Attendees: Ondrej, Dave, Nathan, Vlado, Mohsin (dwallacelf, 14:53:26)
    2. Mohsin encountered some performance issues discussed in Issue#254 (dwallacelf, 14:55:18)
    3. https://github.com/FDio/govpp/issues/254 (dwallacelf, 14:55:36)
    4. Discussion of Issue#254 (dwallacelf, 14:58:28)
    5. ACTION: Ondrej to investigate Issue#254, Mohsin to post C test results and benchmark code (dwallacelf, 15:06:31)
    6. Vlado pointed out old performance stats on wiki (dwallacelf, 15:06:33)
    7. https://wiki.fd.io/view/GoVPP/Performance (dwallacelf, 15:06:34)
    8. Mohsin's vpp benchmark used vat2 which uses shared memory transport, govpp uses socket transport (dwallacelf, 15:08:47)
    9. ACTION: Mohsin to update C benchmark test with socket api and report results (dwallacelf, 15:11:09)
    10. Discussed PR#255, Ondrej to follow up with questions on use case specifics. (dwallacelf, 15:27:53)


Meeting ended at 15:28:06 UTC (full logs).

Action items

  1. Ondrej to investigate adding memory leak test to CI
  2. Ondrej to generate a release
  3. Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
  4. Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions
  5. Dave to notify VPP community of issue with socket client and GoVPP PR#248 (might have been done, will confirm)
  6. Ondrej to investigate Issue#254, Mohsin to post C test results and benchmark code
  7. Mohsin to update C benchmark test with socket api and report results


People present (lines said)

  1. dwallacelf (21)
  2. collab-meetbot` (3)


Generated by MeetBot 0.1.4.