#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 14:35:53 UTC (full logs).

Meeting summary

  1. Roll Call / Agenda Bashing (dwallacelf, 14:38:26)
    1. Attendees: Ondrej, Dave, Vlado, Nathan (dwallacelf, 14:40:23)

  2. Action Items (dwallacelf, 14:40:36)
    1. ACTION: Ondrej to investigate adding memory leak test to CI (dwallacelf, 14:41:08)
    2. ACTION: Ondrej to generate a release (dwallacelf, 14:41:26)
    3. ACTION: Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community (dwallacelf, 14:41:47)
    4. Attendees: +Mohsin (dwallacelf, 14:42:01)
    5. ACTION: Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions (dwallacelf, 14:42:43)
    6. ACTION: VLado/Ondrej to investigate Issue#254, Mohsin to post C test results and benchmark code (dwallacelf, 14:44:37)
    7. ACTION: Mohsin to update C benchmark test with socket api and report results (dwallacelf, 14:44:51)

  3. Technical Discussion (dwallacelf, 14:45:40)
    1. Vlado doing performance testing for Issue #254 and pushed PR #262 to address memory footprint (dwallacelf, 14:46:58)
    2. Vlado/Ondrej/Mohsin to collaborate on addressing Issue #254 (dwallacelf, 14:47:35)
    3. ACTION: Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue (dwallacelf, 14:58:20)

  4. Inputs From Projects (dwallacelf, 15:04:06)
    1. FD.io Marketing Committee is working on a series of video recordings of FD.io community leaders. (dwallacelf, 15:16:33)
    2. VPP Release 25.02 RC1 was completed yesterday. Release date is Feb 26, 2025 (dwallacelf, 15:17:35)
    3. https://wiki.fd.io/view/Projects/vpp/Release_Plans/Release_Plan_25.02 (dwallacelf, 15:17:59)


Meeting ended at 15:18:05 UTC (full logs).

Action items

  1. Ondrej to investigate adding memory leak test to CI
  2. Ondrej to generate a release
  3. Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
  4. Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions
  5. VLado/Ondrej to investigate Issue#254, Mohsin to post C test results and benchmark code
  6. Mohsin to update C benchmark test with socket api and report results
  7. Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue


People present (lines said)

  1. dwallacelf (20)
  2. collab-meetbot` (3)


Generated by MeetBot 0.1.4.