#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 14:33:07 UTC (full logs).

Meeting summary

    1. ACTION: Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue (dwallacelf, 14:49:09)

  1. Inputs From Projects (dwallacelf, 14:49:31)
    1. VPP Release 25.02 RC1 milestone in progress, no major issues to date (dwallacelf, 14:49:58)

  2. Technical Discussion (dwallacelf, 14:50:52)
    1. No new issues (dwallacelf, 14:51:43)
    2. Design Improvements discussion (dwallacelf, 14:52:29)
    3. Optimize writing to socket in the message request (use the request buffer and handle the actual write from the #fdio-meeting (dwallacelf, 14:53:07)
    4. ^^^ from the API) (dwallacelf, 14:53:30)
    5. Remove the unnecessary message callback goroutine (dwallacelf, 14:53:42)
    6. Decrease the number of allocated objects (Issue#254 / PR#253) (dwallacelf, 14:54:05)
    7. Vlado working on the last item in the list (dwallacelf, 14:54:25)
    8. Ondrej doesn't have the cycles to address the other items in the list currently. (dwallacelf, 14:55:39)
    9. Ondrej to consult with Mohsin/Vlado to help get the other improvements implemented (dwallacelf, 14:56:45)
    10. Mohsin has done some benchmarking and has identified some potential API usage patterns to improve the performance (dwallacelf, 14:58:16)
    11. Discussion of benchmarking methodology (dwallacelf, 15:12:58)
    12. Mohsin on PTO for the rest of Feb. starting next week. (dwallacelf, 15:13:47)


Meeting ended at 15:18:22 UTC (full logs).

Action items

  1. Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue


People present (lines said)

  1. dwallacelf (20)
  2. collab-meetbot (7)
  3. edwarnicke (0)
  4. sknat (0)


Generated by MeetBot 0.1.4.