#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 14:43:36 UTC (full logs).

Meeting summary

  1. Action Items (dwallacelf, 14:44:00)
    1. Vlado refactored the MessageID handling in stream api to address part of Issue#254 (dwallacelf, 14:46:39)
    2. ACTION: Mohsin to verify whether Vlado's PR fixes Issue #254 (dwallacelf, 14:47:17)
    3. ACTION: Ondrej to investigate adding memory leak test to CI (dwallacelf, 14:47:35)
    4. ACTION: Ondrej to generate a release (dwallacelf, 14:48:22)
    5. ACTION: Mohsin to update C benchmark test with socket api and report results (dwallacelf, 14:48:42)
    6. ACTION: Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue (dwallacelf, 14:48:56)
    7. ACTION: Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community (dwallacelf, 14:49:20)
    8. ACTION: Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions (dwallacelf, 14:49:51)

  2. Inputs From Projects (dwallacelf, 14:53:13)
    1. Naveen working on experiments to validate the best way to transition VPP/CSIT from Jenkins to Github Actions (dwallacelf, 14:55:49)

  3. Technical Discussion (dwallacelf, 14:57:07)
    1. VPP Release 25.02 RC2 happened last week, Release is scheuled for next Wednesday (dwallacelf, 14:58:20)
    2. No new Issues to discuss (dwallacelf, 14:58:43)
    3. Vlado to review Ondrej's PR#266 (dwallacelf, 14:59:30)
    4. All PR#s appear to be failing "CI / GolangCI (1.22)" check (dwallacelf, 15:01:40)
    5. https://github.com/FDio/govpp/actions/runs/13433747296/job/37531242733?pr=268 (dwallacelf, 15:01:45)
    6.   All PR#s appear to be failing "CI / GolangCI (1.22)" check (dwallacelf, 15:02:44)
    7. https://github.com/FDio/govpp/actions/runs/13433747296/job/37531242733?pr=268 (dwallacelf, 15:03:03)
    8. Attendees  Dave, Vlado, Arthur (dwallacelf, 15:04:17)


Meeting ended at 15:04:23 UTC (full logs).

Action items

  1. Mohsin to verify whether Vlado's PR fixes Issue #254
  2. Ondrej to investigate adding memory leak test to CI
  3. Ondrej to generate a release
  4. Mohsin to update C benchmark test with socket api and report results
  5. Nathan to discuss Issue #255 with Mohammed respond with details how to reproduce the issue
  6. Dave to open a ticket with LF-IT to claim ownership of dockerhub fdio community
  7. Mohit to relocate ligato/vpp-base to fdio/vpp repo as part of the move of VPP CI to Github Actions


People present (lines said)

  1. dwallacelf (23)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.