#fdio-meeting: GoVPP Community Meeting

Meeting started by dwallacelf at 13:32:21 UTC (full logs).

Meeting summary

    1. Attendees:  Dave, Mohsin, Vlado (dwallacelf, 13:58:52)

  1. Action Items (dwallacelf, 13:59:02)
    1. ACTION: Ondrej to investigate adding memory leak test to CI (dwallacelf, 13:59:33)
    2. ACTION: Ondrej to investigate migrating up GitHub notifications to zulip chat which is replacing slack by LF (dwallacelf, 13:59:47)
    3. ACTION: Dave to relocate ligato/vpp-base to fdio/vpp repo after move of VPP CI to Github Actions (dwallacelf, 13:59:59)
    4. ACTION: Ondrej to generate next GoVPP release now that Calico 3.30 is complete (dwallacelf, 14:00:43)
    5. ACTION: Mohsin to review/fix gomemif Issues #296, #280 (dwallacelf, 14:00:56)
    6. Requests to add FD.io project specific channels to zulip have been denied at the current time by Casey Cain (LFN PM).  Casey is advocating that communities use topics in zulip in place of slack channels. (dwallacelf, 14:02:28)

  2. Inputs From Projects (dwallacelf, 14:02:51)
    1. VPP 25.10 RC2 happened yesterday.  Release to be completed on Wed Oct 29, 2026 (dwallacelf, 14:12:41)

  3. Technical Discussion (dwallacelf, 14:13:49)
    1. Vlado/Ondrej to review new PRs (dwallacelf, 14:14:05)
    2. Discussion of Design Improvements list (dwallacelf, 14:17:37)
    3. Mohsin reported that the perf issue of configuring a large fib table (~ 2 million entries) was addressed by using async api calls for fib download, pre-allocating table memory in VPP via startup.conf configuration, and some other refactoring of the control plane app. (dwallacelf, 14:17:42)
    4. the remaining optimizations in the list should improve things as well, but are not critical at this point. (dwallacelf, 14:18:41)


Meeting ended at 14:18:53 UTC (full logs).

Action items

  1. Ondrej to investigate adding memory leak test to CI
  2. Ondrej to investigate migrating up GitHub notifications to zulip chat which is replacing slack by LF
  3. Dave to relocate ligato/vpp-base to fdio/vpp repo after move of VPP CI to Github Actions
  4. Ondrej to generate next GoVPP release now that Calico 3.30 is complete
  5. Mohsin to review/fix gomemif Issues #296, #280


People present (lines said)

  1. dwallacelf (17)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.