#fdio-meeting: FD.io TSC

Meeting started by dwallacelf at 15:00:32 UTC (full logs).

Meeting summary

    1. Vratko Polak proxying for Maciek Konstantynowicz. (vrpolak, 15:01:52)
    2. valderrv (valderrv, 15:02:01)

  1. Roll Call / Agenda Bashing (dwallacelf, 15:02:03)
    1. Matt Smith (mgsmith, 15:02:07)

  2. Meeting Cancellation (dwallacelf, 15:02:58)
    1. Jeff Shaw (JeffShaw, 15:22:33)
    2. next week's meeting is cancelled (dwallacelf, 15:22:52)

  3. Budget Approval (dwallacelf, 15:22:59)
    1. Discussion of budget asks (dwallacelf, 15:23:07)
    2. VOTE: Voted on "FD.io TSC approves CY2027 budget proposal?" Results are, 0: 1, +1: 4 (dwallacelf, 15:29:23)
    3. AGREED: FD.io TSC approves CY2027 budget proposal (dwallacelf, 15:29:53)

  4. Action Items (dwallacelf, 15:35:11)
    1. ACTION: Casey/Dave to finalize review of mediawiki content migrated to Confluence (dwallacelf, 15:35:36)
    2. ACTION: Dave to send email to VPP community encouraging all submitters to rebase their gerrit changes on a weekly bases to help alleviate the issues by including fixes committed in GitHub Actions, test infrastructure, and vpp code itself. (dwallacelf, 15:36:11)
    3. Server migration is complete. Peter Mikus continues to work with Vexxhost to ensure re-installation is correct. (dwallacelf, 15:37:32)
    4. Many thanks to Peter Mikus for his excellence in overseeing the move.  Well done Peter! (dwallacelf, 15:38:52)
    5. The VPP coverity build/upload has been migrated to a daily GHA in the VPP repo. (dwallacelf, 15:39:59)
    6. Many thanks to Chris Luke for creating and hosting the job for the past 10 years! (dwallacelf, 15:40:46)
    7. Two new VPP GHA workflows are being created to build/run ASAN tests on 'make test' and 'Host Stack Test' daily for additional static analysis coverage of the VPP codebase (dwallacelf, 15:42:34)
    8. Numerous outages have occurred over the past week as a side effect of the move.  Thanks to all community members for their patience during the move. (dwallacelf, 15:43:32)


Meeting ended at 15:43:37 UTC (full logs).

Action items

  1. Casey/Dave to finalize review of mediawiki content migrated to Confluence
  2. Dave to send email to VPP community encouraging all submitters to rebase their gerrit changes on a weekly bases to help alleviate the issues by including fixes committed in GitHub Actions, test infrastructure, and vpp code itself.


People present (lines said)

  1. dwallacelf (23)
  2. collab-meetbot (19)
  3. vrpolak (3)
  4. mgsmith (2)
  5. JeffShaw (2)
  6. valderrv (1)
  7. fan_zhang (1)
  8. edwarnicke (0)
  9. JoelHalpern (0)
  10. mackonstan (0)


Generated by MeetBot 0.1.4.