#fdio-vpp: fdio vpp
Meeting started by DaveBarach at 14:28:38 UTC
(full logs).
Meeting summary
- 
  - very light turnout due to annoying meeting
    reschedule... (DaveBarach,
    14:36:02)
 
 
- Marek Gradzki on Honeycomb (DaveBarach, 14:36:23)
  - I thought meeting was at 11:00? (tfherbert,
    14:36:24)
 
  - HC RC1 released last week (DaveBarach,
    14:36:31)
 
  - RC2 to be released next week, after vpp
    16.09 (DaveBarach,
    14:36:44)
 
  - feature requests to the HC team for 16.12
    solicited (DaveBarach,
    14:37:04)
 
 
- NSH / SFC Keith Burns reporting (DaveBarach, 14:38:12)
  - Hongjun declared victory on lists (DaveBarach,
    14:38:31)
 
  - jvpp refactor complete (DaveBarach,
    14:38:45)
 
  - "everything is working" (DaveBarach,
    14:38:58)
 
  - committer vote to release w/out CSIT, doxygen
    complete. (DaveBarach,
    14:39:29)
 
  - ed reports doxygen infra ready for nsh/sfc
    project (DaveBarach,
    14:40:23)
 
  - https://gerrit.fd.io/r/#/c/2853/
    Thanks Ed for pointing out Doxy NSH patch (alagalah,
    14:40:49)
 
 
- Florin reports on ONE-LISP (DaveBarach, 14:41:13)
  - docs added for dataplane code (DaveBarach,
    14:41:20)
 
  - refactoring code on master for HC
    integration (DaveBarach,
    14:41:32)
 
 
- TLDK Ed reporting (DaveBarach, 14:42:15)
  - reminder meetings at 8am PDT Wednesdays
    (DaveBarach,
    14:42:27)
 
 
- Ed reporting on mini-summit (DaveBarach, 14:43:36)
  - https://fd.io/news/events/2016-09-26/fdio-mini-summit-open-daylight-summit
    <- minisummit agenda (edwarnicke,
    14:43:45)
 
  - http://events.linuxfoundation.org/events/opendaylight-summit/extend-the-experience/colocatedevents
    <- event page (edwarnicke,
    14:44:20)
 
  - representation across a bunch of
    projects (DaveBarach,
    14:44:50)
 
 
- 16.09 release (DaveBarach, 14:45:07)
  - release pull tomorrow, activitites start at
    2:00pm PDT. (DaveBarach,
    14:45:29)
 
  - draft patch for release notes on the way
    (DaveBarach,
    14:46:02)
 
  - cli guide -> doxygen docs (DaveBarach,
    14:46:47)
 
 
- Damjan on 16.12 release planning (DaveBarach, 14:55:07)
  - meeting next week, info in the interim by
    email (DaveBarach,
    14:55:17)
 
 
- Maciek reporting on CSIT (DaveBarach, 15:00:33)
  - on time / on target to release 16.09 perf
    reports (DaveBarach,
    15:00:50)
 
  - thank you to Pierre for working on
    non-repeatable vhost_user csit results (DaveBarach,
    15:01:16)
 
  - will call for help if repeatable results are
    not obtained in the CSIT environment (DaveBarach,
    15:01:58)
 
  - latency tests evaluating trex behavior, seems
    ok (DaveBarach,
    15:02:21)
 
  - hardware failures in perf testbeds (DaveBarach,
    15:03:07)
 
  - parallelizing some virl test to improve
    performance (DaveBarach,
    15:04:44)
 
  - "make test" report: offload anything that can
    be moved to this framework (DaveBarach,
    15:05:55)
 
  - need to review code, evaluate what we can move
    there (DaveBarach,
    15:06:06)
 
  - csit 16.09 draft report for review tomorrow /
    day after tomorrow (DaveBarach,
    15:06:49)
 
 
- Keith Wiles reporting on TLDK (DaveBarach, 15:08:51)
  - meeting tomorrow (DaveBarach,
    15:09:06)
 
  - Question about dpdk convergence? I don't know
    yet how much effort but can we get in the plan DPDK convergence for
    16.12 or 17.3? It would be nice to get it (from the RPM perspective)
    down to a package dependency with a manageably small amount of
    patches.. (tfherbert,
    15:09:21)
 
  - difficulties using Google docs w/ work email
    accounts (DaveBarach,
    15:09:26)
 
  - Ray K answering on dpdk integration
    (DaveBarach,
    15:10:45)
 
  - Ray K, do you need any help in terms of pushing
    patches up and etc...? (tfherbert,
    15:11:13)
 
  - ACTION: ray to follow
    up specific dpdk driver upstreaming issues (DaveBarach,
    15:11:29)
 
  - remider: dpdk user event in Dublin, in October;
    please attend / register (DaveBarach,
    15:12:22)
 
  - I will be at DPDK Dublin userspace. Will be
    happy to have side informal discussion at least with VPP
    folks. (tfherbert,
    15:12:29)
 
  - Dublin event October 20-21 2016 (DaveBarach,
    15:14:04)
 
  - Thomas Monjalon would like to have discussions
    at Dublin about VPP patches integration in DPDK (tmonjalo,
    15:15:34)
 
 
- Consumability (DaveBarach, 15:16:18)
  - disaster plan review (DaveBarach,
    15:16:44)
 
  - Thomas yes. We need to move toward package
    dependency for vpp release on upstream DPDK package. (tfherbert,
    15:17:03)
 
  - official 16.09 release PR offset by one week,
    to coincide w/ Honeycomb + NSH/SFC releases (DaveBarach,
    15:19:42)
 
  - Ed points out that from the POV of mechanics,
    it's easier to slip 16.12 to 17.01 (DaveBarach,
    15:21:52)
 
  - than it is to back up from 17.01 to
    16.12 (DaveBarach,
    15:22:13)
 
  - Which date is better to converge with DPDK
    release, would 17.01 be better? (tfherbert,
    15:22:42)
 
  - ACTION: damjan to
    close 16.12 vs. 17.01 by the end of next week (DaveBarach,
    15:24:05)
 
  - what does tmonjalo think? (tfherbert,
    15:24:23)
 
 
Meeting ended at 15:26:15 UTC
(full logs).
Action items
  - ray to follow up specific dpdk driver upstreaming issues
 
  - damjan to close 16.12 vs. 17.01 by the end of next week
 
People present (lines said)
  - DaveBarach (49)
 
  - tfherbert (12)
 
  - alagalah (6)
 
  - tmonjalo (5)
 
  - edwarnicke (5)
 
  - collabot` (3)
 
  - cpaelzer (3)
 
  - cj (1)
 
  - Chrisy (1)
 
Generated by MeetBot 0.1.4.