#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 15:01:57 UTC (full logs).

Meeting summary

    1. Dave Wallace (dwallacelf, 15:02:21)

  1. CSIT Maciek Reporting (DaveBarach, 15:02:31)
    1. infra upgrade: 16.04 migration complete (DaveBarach, 15:02:49)
    2. performance testbed results next week (DaveBarach, 15:03:32)
    3. still observing infra issues - critical csit test failures (DaveBarach, 15:04:31)
    4. Dave Wallace reports lf cleans out logs aggressively, which means lost info on test failures (DaveBarach, 15:05:19)
    5. switching to a scheme where logs stick around for 6 months (DaveBarach, 15:05:35)
    6. csit "setup" test fails - trivial test "is VPP running" - couldn't repro offline (DaveBarach, 15:06:10)
    7. setup test vpp start timeout appears not to be the definitive root cause (DaveBarach, 15:07:11)
    8. request for damjan to attend csit meetings (DaveBarach, 15:14:28)
    9. ACTION: Damjan signs up to attend the beginning of the csit meeting (DaveBarach, 15:15:18)

  2. Honeycomb, Marek reporting (DaveBarach, 15:15:39)
    1. working on infrastructure (DaveBarach, 15:15:47)
    2. vpe.api working on typeonly support for jvpp (DaveBarach, 15:16:17)
    3. working on Coverity warnings (DaveBarach, 15:16:37)
    4. considering whether to move jvpp to a separate project (DaveBarach, 15:22:46)
    5. +1 on Ed's comment. (tfherbert, 15:26:43)
    6. Ed W. suggests taking the language binding discussion to the mailing list (DaveBarach, 15:29:05)

  3. Keith Burns NSH/SFC report (DaveBarach, 15:30:27)
    1. merged nsh proxy patch (DaveBarach, 15:30:40)
    2. want to avoid hard-coding nsh data into e.g. buffer metadata (DaveBarach, 15:31:32)
    3. variations on the theme from Florin (DaveBarach, 15:36:13)
    4. ACTION: keith to set up call about policy imposition (DaveBarach, 15:40:59)

  4. Florin reports on ONE-LISP (DaveBarach, 15:44:00)
    1. policy-based LISP forwarding now in master (DaveBarach, 15:44:26)
    2. fixes to be merged into ODL (DaveBarach, 15:44:37)
    3. finishing control-plane, shout-out to Neale for dual-looping FIB innards (DaveBarach, 15:45:38)

  5. Sandbox (DaveBarach, 15:48:30)
    1. flowtable work at IETF in the sandbox (DaveBarach, 15:49:12)

  6. TLDK Keith Wiles reporting (DaveBarach, 15:49:41)
    1. meeting tomorrow (DaveBarach, 15:49:46)
    2. Keith / Ray discussing project goals (DaveBarach, 15:50:01)
    3. Ray was completely consumed last week w/ DPDK summit (DaveBarach, 15:50:21)
    4. https://gerrit.fd.io/r/#/c/3564/ floatable (alagalah, 15:50:44)
    5. Interesting approach to doing VPP work in the Sandbox i.e. a patch ratter than fork (alagalah, 15:50:44)
    6. tfherbert reports things for RPM packaging going well but... (alagalah, 15:51:11)

  7. Tom H on DPDK packaging (DaveBarach, 15:51:15)
    1. upstream DPDK spec file needs work .... (alagalah, 15:51:20)
    2. vpp spec file not suitable for upstreaming (DaveBarach, 15:51:31)
    3. might help to have Fedora Jenkins slaves (DaveBarach, 15:53:15)

  8. Ed on LF Infra status (DaveBarach, 15:53:52)
    1. Ed keeping a spreadsheet of issues, traceback to root causes (DaveBarach, 15:54:09)
    2. https://docs.google.com/spreadsheets/d/1b01KrMDSlXFkyBDbKd7a0ITvfPtwUWFbZHDJ9Zfc5ck/edit#gid=0 <- infra root cause spreadsheet (edwarnicke, 15:54:23)
    3. edwarnicke Can you add a reporter and LF HD owner field ? (alagalah, 15:55:22)
    4. gerrit server has been slow, pls add to tracking (DaveBarach, 15:55:35)
    5. ping Ed and report the times the slowness occurs (keith_wiles, 15:56:14)

  9. Damjan on 17.01 release planning (DaveBarach, 15:57:27)
    1. dpdk 16.11 RC1 available, Damjan in the middle of cranking it up (DaveBarach, 15:58:20)
    2. kni interface dpdk code. Want to clean up, or shall we remove it? (DaveBarach, 15:59:55)
    3. Ray mentions kni was historically used for slow-path cases (DaveBarach, 16:00:39)
    4. AGREED: to remove kni support in vpp 17.01 (DaveBarach, 16:01:02)
    5. looks like dpdk 16.11 RC1 working as of a few mins ago (DaveBarach, 16:03:15)
    6. will push patch to unify / reorg feature path support, enable SPAN support (DaveBarach, 16:04:25)


Meeting ended at 16:09:09 UTC (full logs).

Action items

  1. Damjan signs up to attend the beginning of the csit meeting
  2. keith to set up call about policy imposition


People present (lines said)

  1. DaveBarach (46)
  2. alagalah (8)
  3. collabot (3)
  4. edwarnicke (1)
  5. dwallacelf (1)
  6. keith_wiles (1)
  7. tfherbert (1)


Generated by MeetBot 0.1.4.