#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 15:59:10 UTC (full logs).

Meeting summary

    1. Good progress on Make Test. (Jong_, 16:02:22)
    2. test framework module documentation up and running (Jong_, 16:03:28)
    3. Damjan and Maciek agreed on how to run verify job (Jong_, 16:03:54)
    4. Next step is to publish the VPP Test Framework on FD.io wiki (Jong_, 16:04:36)
    5. ACTION: Ed needs to merge ci patch to enable "make test" (DaveBarach, 16:04:47)
    6. Performance test - ongoing efforts with vhost (Jong_, 16:05:44)
    7. CentOS - work in progress (Jong_, 16:05:58)
    8. CSIT infra problems - there have been intermitten connectivity issues (Jong_, 16:06:24)
    9. Infra issues keep coming back (Jong_, 16:07:07)
    10. csit on latest branch (11/13) (DaveBarach, 16:07:45)

  1. Jerome reporting on Honeycomb (DaveBarach, 16:08:21)
    1. Jerome trying to gather information whether request from SFC project (Jong_, 16:08:55)
    2. Awaiting java plugin APIs from iOAM project (Jong_, 16:09:44)
    3. Frank Brockners metadata type 2 required for ioam (DaveBarach, 16:10:58)
    4. Florin couldn't attend meeting.. expect busy as usual (Jong_, 16:11:41)
    5. meeting tomorrow w/ Ray (Jong_, 16:12:13)
    6. expect to look at VPP integration in December (Jong_, 16:13:06)
    7. looking at the performance.. expect rework on timer code (Jong_, 16:13:42)
    8. DB has experience in timer code (Jong_, 16:15:22)
    9. ACTION: DB will mail out timer code to Ray for potential leverage (Jong_, 16:17:46)
    10. two sets of conversation regarding TLDK... Keith Wiles working to merging into one (Jong_, 16:19:10)
    11. working on packaging 16.11 DPDK - main activity (Jong_, 16:19:59)
    12. 16.11 DPDK released now (Jong_, 16:20:08)
    13. expect to not affect this call... but will keep everyone informed (Jong_, 16:20:56)
    14. no reporting (Jong_, 16:21:20)
    15. Should VPP instance be restarted often, seldom, or never? (Jong_, 16:22:19)
    16. Cleaning up resources, doing the delete the resources need to be verified. Need to ensure the delete is successful. (Jong_, 16:23:04)
    17. All the resources that you create in the test case need to be removed. Not a big ask. (Jong_, 16:24:04)
    18. test cases need to be written in a way that it cleans-up after themselves (Jong_, 16:33:44)
    19. need to define 'what is nothing left' (Jong_, 16:34:05)
    20. ACTION: Neale took the action to do this method (Jong_, 16:35:56)
    21. DPDK won't build without this library (Jong_, 16:40:46)
    22. Damjan's question - Should we build DPDK in every single VPP build? (Jong_, 16:43:58)
    23. Thomas's question - Should it be in the DPDK RPM? Yes-Damjan (Jong_, 16:45:07)
    24. Damjan feels that this could be in the 17.01 release.. question is should we do it? (Jong_, 16:46:38)
    25. Damjan's proposal - for 17.01 - keep it diabled by default. Too short notice. For next release, 17.xx, re-evalate. (Jong_, 16:49:22)
    26. +1 (tfherbert1, 16:49:29)
    27. VPP 17.01 Release - Damjan (Jong_, 16:50:33)
    28. Verify jobs are fine, need to do some manual testing after getting results from CSIT (Jong_, 16:51:19)
    29. work-in-progess. can now run new api messages without having to do clients. (Jong_, 16:53:42)
    30. much more independence between language bindings and vpp (Jong_, 16:54:45)
    31. Expect some flux for couple of weeks. May impact Jerome's work. (Jong_, 16:57:01)
    32. Intent is to have much more robust language binding. Easier to get plug-ins. (Jong_, 16:58:02)
    33. Jerome to invite Ole to ML2 call to set expectations. (Jong_, 16:58:29)
    34. Need to decide whether to merge this into 17.01... need to minimize risk. (Jong_, 16:59:47)
    35. Please contact Ole if suggestions or improvements.. esp if you are the user (Jong_, 17:02:35)
    36. Looks like Coverity hasn't run in 4 days... any update? (Jong_, 17:02:59)


Meeting ended at 17:04:01 UTC (full logs).

Action items

  1. Ed needs to merge ci patch to enable "make test"
  2. DB will mail out timer code to Ray for potential leverage
  3. Neale took the action to do this method


People present (lines said)

  1. Jong_ (58)
  2. DaveBarach (6)
  3. collabot` (3)
  4. tfherbert1 (1)


Generated by MeetBot 0.1.4.