#fdio-vpp: fdio vpp

Meeting started by DaveBarach at 15:58:35 UTC (full logs).

Meeting summary

  1. agenda additions (DaveBarach, 16:01:28)
  2. CSIT Maciek K reporting (DaveBarach, 16:02:34)
    1. 18.01 work in process, plan on wiki being updated regularly (DaveBarach, 16:03:01)
    2. more vpp container topologies w/ memif, k8s, ligato (DaveBarach, 16:03:25)
    3. orchestration mostly done (DaveBarach, 16:03:59)
    4. looking to onboard vpp TCP host-stack testing (DaveBarach, 16:04:15)
    5. working with both WRK and Trex (DaveBarach, 16:04:33)
    6. srv6 perf testing (DaveBarach, 16:04:43)
    7. arm folks onboarding hardware (DaveBarach, 16:05:36)
    8. CSIT 1801 plan (mackonstan, 16:06:21)
    9. https://wiki.fd.io/view/CSIT/csit1801_plan (mackonstan, 16:06:24)

  3. NSH / SFC no news Ray K reporting (DaveBarach, 16:06:59)
    1. Maciek thanks Sergio for helping w/ IPSEC / crypto test integration into CSIT (DaveBarach, 16:07:33)

  4. host stack (Florin reporting) (DaveBarach, 16:08:05)
    1. lots of prep work for Kubecon demo / preso (DaveBarach, 16:08:26)
    2. Florin's preso on the website (DaveBarach, 16:08:38)
    3. one important patch to standardize session / transport APIs (DaveBarach, 16:08:57)
    4. transport leakage into session layer addressed (DaveBarach, 16:09:12)
    5. Keith on vppcom + ld_preload cleanups (DaveBarach, 16:09:45)
    6. keith adding event-log to vppcom, for integrated pictures with the vpp stack (DaveBarach, 16:10:30)
    7. dwallace refactoring vppcom to facilitate direct use by clients (DaveBarach, 16:10:54)
    8. Ray K asks about direct memif access from Golang (DaveBarach, 16:12:01)
    9. for vcl, configuration via a config file (heap size, etc) (DaveBarach, 16:13:27)
    10. a few environment variables also used (DaveBarach, 16:13:48)

  5. 18.01 release Dave Wallace reporting (DaveBarach, 16:16:01)
    1. please review the release plan (DaveBarach, 16:16:06)
    2. API changes by next Weds pls keep Dave Wallace in the loop (DaveBarach, 16:16:34)

  6. Infrastructure (DaveBarach, 16:18:01)
    1. container POC equipment finally cleared Canadian customs (DaveBarach, 16:18:19)
    2. installation next (DaveBarach, 16:18:25)
    3. ACTION: Ed Kern to work through splitting the make verify clang build so it can run in parallel (DaveBarach, 16:23:20)
    4. tina now audible, asks about CSIT whitepaper Maciek working w/ Intel about (DaveBarach, 16:25:27)
    5. current whitepaper not ARM-relevant (DaveBarach, 16:25:59)
    6. after equipment onboarded, expect to update whitepaper w/ arm data thereafter (DaveBarach, 16:26:43)

  7. Kubecon mini-summit report from Ed Warnicke (DaveBarach, 16:30:39)
    1. lots of interest (DaveBarach, 16:31:00)
    2. lots of social media (DaveBarach, 16:31:15)
    3. Florin's talk drew lots of questions, after talk and at the booth (DaveBarach, 16:31:59)
    4. showed vpp/contiv, nginx; something like 20K calls/sec (DaveBarach, 16:32:24)

  8. upcoming fd.io events (DaveBarach, 16:32:47)
    1. ray k: FOSDEM will have a strong fd.io set of topic (DaveBarach, 16:33:26)
    2. ed W: ONS call for papers open, CFP closes 1/14 (DaveBarach, 16:34:00)
    3. ray k: need to target ONS due to open-source networking consolidation (DaveBarach, 16:34:36)

  9. AWS integrations (Jerome) (DaveBarach, 16:35:15)
    1. ubuntu 16.04 w/ Elastic Network Arch: vpp + dpdk on interfaces (DaveBarach, 16:35:50)
    2. Jira ticket VPP-1093 (DaveBarach, 16:36:53)


Meeting ended at 16:41:09 UTC (full logs).

Action items

  1. Ed Kern to work through splitting the make verify clang build so it can run in parallel


People present (lines said)

  1. DaveBarach (46)
  2. collabot (3)
  3. mackonstan (2)
  4. florinc (1)


Generated by MeetBot 0.1.4.