#fdio-vpp: fdio vpp
Meeting started by DaveBarach at 16:00:57 UTC
(full logs).
Meeting summary
- CSIT (maciek reporting) (DaveBarach, 16:01:44)
  - performance regression commentary (DaveBarach,
    16:02:35)
 
  - fix in 18.01.01 (DaveBarach,
    16:02:48)
 
  - report to be issued beginning of next
    week (DaveBarach,
    16:03:02)
 
  - git bisect of release branch. Perf delta
    exactly at branch pull, not clear why 18.01 differs by about 5% from
    master (DaveBarach,
    16:04:49)
 
  - dpdk 17.11 artifacts posted in master / built
    out of 18.01 branch are different sizes (DaveBarach,
    16:05:15)
 
  - no obvious root-cause from that exercise
    (DaveBarach,
    16:05:54)
 
  - test indicates perf delta between POC and LF
    infra. When built on local haswell machine, 18.01 identical to
    master (DaveBarach,
    16:06:55)
 
  - DaveBarach - suggests disassembling code
    between perf/non-perf binaries (alagalah,
    16:08:24)
 
  - @dwallacelf did digging into ELF files etc and
    thought it might be a micro-architecture issue (alagalah,
    16:09:16)
 
  - Discussion about building locally (and building
    DPDK from source) or in LF infra. (alagalah,
    16:10:27)
 
  - @mackonstan2 believes main issue is in NAT
    eating 7k clocks ... mentioned the std dev is good (sic) but still
    have performance gap (@alagalah - editorial - trying to follow what
    @mackonstan2 is actually saying... if its where we are building it
    or if its just NAT) (alagalah,
    16:12:13)
 
  -  (alagalah,
    16:12:50)
 
  - @DaveBarach seems like NAT was enabling an
    input node that wasn't needed until feature was enabled.
    (alagalah,
    16:13:14)
 
 
- Honeycomb (Marek reporting) (DaveBarach, 16:14:30)
  - 18.01 released (DaveBarach,
    16:14:36)
 
 
- Host stack (DaveBarach, 16:15:26)
  - continuing integration w/ Envoy (DaveBarach,
    16:15:38)
 
  - compatibility w/ libevent2 (DaveBarach,
    16:16:31)
 
  - ACTION: @alagalah to
    update Wiki to reflect a) how to use VCL and LDPRELOAD b) by
    corollary of demonstrating that LDPRELOAD works with Envoy / Istio,
    which actually use glibc (socket, bind etc) and libevent (read,
    write) which uses epoll_ etc, its probably more accurate to say
    VCL/LDPRELOAD supports glibc calls and to a large extent, libevent
    (can list libevent calls that Envoy uses that we know we support
    etc) .... (alagalah,
    16:20:51)
 
  - @dwallacelf points out that there are a large
    number of set|getsockopts() we need to actually support which were
    implemented to a use-case (Envoy/Istio) rather than the full gamut
    of options (alagalah,
    16:22:04)
 
 
- aarch64 (Tina reporting) (DaveBarach, 16:22:46)
  - hoststack updates: refactor of builtin apps, rw
    lock implementation that replaces the custom implementation in the
    session layer, refactored segment manager and usage of valloc as a
    central segment base va manager (florinc,
    16:24:51)
 
  - DHL can't find well-known shipping
    address (DaveBarach,
    16:25:24)
 
 
- 18.01 release (DaveBarach, 16:27:15)
  - 18.01.01 release to deal e.g. w/ csit
    performance issues, 4 or 5 commits (DaveBarach,
    16:28:07)
 
  - pls edit wiki w/ 18.04 release
    deliverables (DaveBarach,
    16:30:24)
 
  - We should be putting these "new features" into
    JIRA and put a link to that into the Release Deliverables...
    (alagalah,
    16:31:33)
 
  - Ultimately thats the 18.04 RelMgr's call but
    generally seen as a positive. dwallacelf speaking on behalf of
    Chrisy (alagalah,
    16:32:32)
 
 
- container build POC (DaveBarach, 16:33:59)
  - hardware all set (DaveBarach,
    16:34:04)
 
  - no performance alarms in place (DaveBarach,
    16:34:46)
 
  - configure jobs to actually use the container
    minions (DaveBarach,
    16:35:39)
 
  - merged patch to avoid container-unfriendly
    manipulation of /proc (DaveBarach,
    16:36:40)
 
  - current JJB master either sends all streams to
    current infra OR to POC (DaveBarach,
    16:37:19)
 
  - reluctant to throw big switch (DaveBarach,
    16:37:47)
 
  - two restructurings of JJB pending, to send less
    than every job to container infra (DaveBarach,
    16:38:25)
 
  - ACTION: DaveW to
    email list w/ cut-over date (DaveBarach,
    16:44:36)
 
  - transition to groups.io (alagalah,
    16:45:20)
 
  - need to ping LF, et al to figure out
    status (DaveBarach,
    16:45:42)
 
  - DaveBarach : SCTP has a number of Coverity
    defects ... who would be contact? (alagalah,
    16:46:14)
 
  - ACTION: florinc to
    contact Marco (original submitter) (alagalah,
    16:46:26)
 
  - FOSDEM: Ray reports: (alagalah,
    16:46:43)
 
  - Jerome demo of vpp went great (DaveBarach,
    16:47:04)
 
  - full rooms for most presos, great feedback,
    Highlight was Jerome Tollet's impromptu demo of VPP (I think with
    TAPv2 40G ?) (alagalah,
    16:47:08)
 
  - interest in general for VPP + TCP (alagalah,
    16:47:30)
 
 
- Brian Brooks on __sync builtins (DaveBarach, 16:49:00)
 
Meeting ended at 16:58:02 UTC
(full logs).
Action items
  - @alagalah to update Wiki to reflect a) how to use VCL and LDPRELOAD b) by corollary of demonstrating that LDPRELOAD works with Envoy / Istio, which actually use glibc (socket, bind etc) and libevent (read, write) which uses epoll_ etc, its probably more accurate to say VCL/LDPRELOAD supports glibc calls and to a large extent, libevent (can list libevent calls that Envoy uses that we know we support etc) ....
 
  - DaveW to email list w/ cut-over date
 
  - florinc to contact Marco (original submitter)
 
Action items, by person
  -  alagalah 
    - @alagalah to update Wiki to reflect a) how to use VCL and LDPRELOAD b) by corollary of demonstrating that LDPRELOAD works with Envoy / Istio, which actually use glibc (socket, bind etc) and libevent (read, write) which uses epoll_ etc, its probably more accurate to say VCL/LDPRELOAD supports glibc calls and to a large extent, libevent (can list libevent calls that Envoy uses that we know we support etc) ....
 
  
 
  -  florinc 
    - florinc to contact Marco (original submitter)
 
  
 
People present (lines said)
  - DaveBarach (33)
 
  - alagalah (25)
 
  - florinc (6)
 
  - bbrian (4)
 
  - collabot` (4)
 
  - jdl (1)
 
  - BillyM (1)
 
Generated by MeetBot 0.1.4.