#fdio-vpp: fido-vpp

Meeting started by DaveBarach at 14:59:49 UTC (full logs).

Meeting summary

  1. Agenda Additions (DaveBarach, 15:03:16)
  2. CSIT (maciek reporting) (DaveBarach, 15:04:23)
    1. CSIT release milestones realigned to track vpp releases (DaveBarach, 15:05:03)
    2. https://wiki.fd.io/view/CSIT/csit1810_plan (mackonstan, 15:05:04)
    3. csit report release two weeks after vpp releases (DaveBarach, 15:05:54)
    4. Skylake perf test more complete (DaveBarach, 15:06:18)
    5. Switch to Ubuntu 18.04 for skylake, haswell testbeds (DaveBarach, 15:06:48)
    6. AGREED: to switch to 18.04 on haswell for csit (DaveBarach, 15:07:54)
    7. need to make sure "make test" actually works (DaveBarach, 15:09:02)
    8. ACTION: ed kern to check out make test on 18.04 (DaveBarach, 15:09:12)
    9. short performance tests about to be available, first by text trigger (DaveBarach, 15:10:11)
    10. looking at extended soak-testing for throughput - an hour or more - hopefully for 18.10 (DaveBarach, 15:11:43)
    11. container-based functional testing (DaveBarach, 15:12:11)
    12. some containter tests hopefully in 18.10 (DaveBarach, 15:12:26)

  3. Honeycomb (michal cmarada reporting) (DaveBarach, 15:13:55)
    1. nsh plugin moving to vpp tree, Honjun also moving jvpp code (DaveBarach, 15:14:30)
    2. ODL release this friday (DaveBarach, 15:14:50)

  4. Host Stack (Florin Coras reporting) (DaveBarach, 15:15:04)
    1. support for multiple application worker threads, both in session layer and in VCL (DaveBarach, 15:15:23)
    2. app can register (bind) multiple worker threads, multiple worker processes (fork cases) upcoming (DaveBarach, 15:16:11)
    3. SO_REUSE cases (DaveBarach, 15:16:41)
    4. refactored vcl tests to use multiple workers, aka multiple binds. App has multiple workers, needs vpp load balancing (DaveBarach, 15:17:29)
    5. round-robin load-balancing (DaveBarach, 15:17:40)

  5. Documentation (John DeNisco reporting) (DaveBarach, 15:18:18)
    1. release notes move to "new" doc format (DaveBarach, 15:18:29)
    2. ACTION: john to contact Marco offline to set up release notes (DaveBarach, 15:18:59)
    3. how to land documentation somewhere in the fd.io tree (DaveBarach, 15:19:47)
    4. Ed Warnicke mentions mechnical issues (DaveBarach, 15:20:14)
    5. ACTION: Ed and John to work out a good place to land the docs offline (DaveBarach, 15:20:30)

  6. cmake (DaveBarach, 15:25:16)
    1. centos has an old version (DaveBarach, 15:25:47)

  7. aarch64 (Tina T reporting) (DaveBarach, 15:26:53)
    1. mellanox issues resolved (DaveBarach, 15:27:01)
    2. make verify was failing, Huawei to validate (DaveBarach, 15:27:27)
    3. dual / quad loop: looking into dynamic (runtime) node function selection (DaveBarach, 15:27:59)

  8. Release 18.07 (Ed W. reporting) (DaveBarach, 15:28:26)
    1. looking at creating a dot release next week (DaveBarach, 15:28:41)
    2. csit interface up/down issue might be worth holding dot release (DaveBarach, 15:29:30)
    3. ACTION: maciek, Ed W to decide about holding 18.07 dot release (DaveBarach, 15:29:47)

  9. 18.10 (Marco V reporting) (DaveBarach, 15:30:00)
    1. schedule agreed last meeting (DaveBarach, 15:30:10)
    2. 7 days between milestones, Oct 24 release date (DaveBarach, 15:30:36)
    3. reminder: 4 weeks from API freeze (DaveBarach, 15:30:48)
    4. please add features to release page, or email Marco V (DaveBarach, 15:31:10)
    5. ACTION: dbarach to add 10.18 release dates to the vpp meeting agenda (DaveBarach, 15:31:49)
    6. cmake - In VPP, 'src/CMakeLists.txt' requires cmake 3.5. CentOS 7.5 base repo has cmake 2.8. I tried changing the required version in 'src/CMakeLists.txt' to 2.8 but hit a command that was introduced in cmake 3.1. Also, ninja-build is only in epel (can't use in downstream CentOS). epel looks to have cmake3 3.12. (BillyM, 15:32:37)

  10. cmake (Dave, Billy) (DaveBarach, 15:32:45)
    1. ACTION: Damjan to sync up with Billy / Tom Herbert to understand Centos cmake version issues (DaveBarach, 15:34:32)

  11. Infra (DaveBarach, 15:35:50)
    1. packagecloud much better at version tracking than nexus (DaveBarach, 15:36:10)
    2. moving the nsh plugin into vpp simplifies the transition (DaveBarach, 15:36:36)

  12. fd.io events (Ed W. reporting) (DaveBarach, 15:37:42)
    1. ed goes through the list (DaveBarach, 15:37:52)
    2. fd.io minisummit on December 10th (DaveBarach, 15:38:25)
    3. CFP open now (DaveBarach, 15:38:36)

  13. Hyperscan (Hongjun) (DaveBarach, 15:40:01)
    1. pattern matching algorithm (DaveBarach, 15:41:09)
    2. regex matching (DaveBarach, 15:41:22)
    3. C++ compiler w/ C API (DaveBarach, 15:43:03)
    4. basic technology to sit on multiple different feature arcs (DaveBarach, 15:52:38)

  14. LTS releases (Marco V) (DaveBarach, 15:54:23)
    1. vpp using short-term DPDK release strategy (DaveBarach, 15:54:53)
    2. dpdk 18.11 will be an LTS release (DaveBarach, 15:55:03)
    3. continue to support dpdk LTS release until next dpdk LTS release (DaveBarach, 15:55:59)
    4. Tom H: ovs uses dpdk LTS releases (DaveBarach, 15:56:51)
    5. Marco: perf fixes go into LTS releases (DaveBarach, 15:58:22)
    6. damjan needs to participate in this discussion (DaveBarach, 16:01:08)


Meeting ended at 16:07:55 UTC (full logs).

Action items

  1. ed kern to check out make test on 18.04
  2. john to contact Marco offline to set up release notes
  3. Ed and John to work out a good place to land the docs offline
  4. maciek, Ed W to decide about holding 18.07 dot release
  5. dbarach to add 10.18 release dates to the vpp meeting agenda
  6. Damjan to sync up with Billy / Tom Herbert to understand Centos cmake version issues


People present (lines said)

  1. DaveBarach (67)
  2. collabot (3)
  3. mackonstan (1)
  4. BillyM (1)


Generated by MeetBot 0.1.4.