#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:59:14 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 16:05:30)
    1. 18.10 report released on time (DaveBarach, 16:05:49)
    2. mackonstan (mackonstan, 16:07:39)
    3. VPP performance graphs (mackonstan, 16:08:01)
    4. http://bit.ly/2OwQPEn (DaveBarach, 16:08:35)
    5. http://bit.ly/2zztqgi (mackonstan, 16:08:56)
    6. better job on multicore (DaveBarach, 16:09:01)
    7. Latency: (mackonstan, 16:09:18)
    8. should be able to tell NIC/PCIe vs. software limitation (DaveBarach, 16:09:27)
    9. http://bit.ly/2F9j4K6 (mackonstan, 16:09:28)
    10. ip4/6 paths show near linear scaling, others not so much (DaveBarach, 16:10:03)
    11. VPP performance comparisons (mackonstan, 16:10:14)
    12. http://bit.ly/2RGBvXM (mackonstan, 16:10:24)
    13. imix better on vhost (DaveBarach, 16:10:48)

  2. Honeycomb (Michal Cmarada reporting) (DaveBarach, 16:12:16)
    1. HC released (DaveBarach, 16:12:25)
    2. nexus images OK, some issue w/ packagecloud (DaveBarach, 16:12:45)

  3. host stack (Florin reporting) (DaveBarach, 16:13:54)
    1. Cubic congestion control merged (DaveBarach, 16:14:21)
    2. Fast recovery improvements on the TCP path: improve ack traffic handling (DaveBarach, 16:14:48)
    3. able to saturate a 40gbit interface! (DaveBarach, 16:15:21)
    4. more cubic-related patches on the way (DaveBarach, 16:15:49)

  4. 18.10 release (Marco V reporting) (DaveBarach, 16:17:47)
    1. pretty painful, could use a post-mortem to learn about issues (DaveBarach, 16:18:14)
    2. a couple of patches merged on stable/18.10 (DaveBarach, 16:18:59)
    3. issues with Nexus server: permissions -> upload failures (DaveBarach, 16:19:39)
    4. jar files weren't right (DaveBarach, 16:20:05)
    5. not entirely clear where the (incorrect) jar files came from (DaveBarach, 16:20:26)
    6. ACTION: dbarach to set up call w/ Marco, Ed to document detailed issues (DaveBarach, 16:21:38)
    7. +florin on post-mortem call (DaveBarach, 16:23:11)

  5. python 3 transition discussion (Marco V) (DaveBarach, 16:23:42)
    1. end of 2019, python2 will be end-of-life; big deal for downstream distros (DaveBarach, 16:24:14)
    2. ACTION: dbarach to send email w.r.t. switching to python3 (DaveBarach, 16:26:40)

  6. old stats API discussion (DaveBarach, 16:29:22)
    1. ACTION: otroan email vpp-dev with stake in the ground as to when the old stats APIs will vanish (DaveBarach, 16:32:27)

  7. Nexus vs. packagecloud (DaveBarach, 16:33:21)
    1. Ed Kern: packages go to both places (DaveBarach, 16:33:40)
    2. Nexus causes O(99%) of the reported issues (DaveBarach, 16:34:04)
    3. ACTION: Ed K will look at jar file locations (DaveBarach, 16:35:16)
    4. release process for Nexus is about 90% script-based, 10% manual. Issues from the 10% manual portion (DaveBarach, 16:36:06)

  8. ed kern reports xenial memory spikes killing containers fixed and/or worked around... (DaveBarach, 16:49:42)


Meeting ended at 16:50:51 UTC (full logs).

Action items

  1. dbarach to set up call w/ Marco, Ed to document detailed issues
  2. dbarach to send email w.r.t. switching to python3
  3. otroan email vpp-dev with stake in the ground as to when the old stats APIs will vanish
  4. Ed K will look at jar file locations


People present (lines said)

  1. DaveBarach (36)
  2. mackonstan (10)
  3. collabot` (3)
  4. mortderire (1)


Generated by MeetBot 0.1.4.