#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:01:41 UTC (full logs).

Meeting summary

  1. CSIT deferred (DaveBarach, 15:02:21)
  2. host stack deferred (DaveBarach, 15:02:50)
  3. documentation (John D) (DaveBarach, 15:03:07)
    1. peter mikus will work on CSIT (DaveBarach, 15:03:21)
    2. interest waning with respect to the marketing guys (DaveBarach, 15:04:03)
    3. Current site technology page looks dated, summary / whitepaper update appreciated (DaveBarach, 15:05:07)
    4. one web pages' worth of high-level content (DaveBarach, 15:05:38)

  4. Host Stack (Florin reporting) (DaveBarach, 15:06:48)
    1. session layer new scheduler (more scalable) merged (DaveBarach, 15:07:07)
    2. tcp lots of little changes, including more per-connection stats (DaveBarach, 15:07:20)
    3. stats don't hurt performance on new machines, minor degradation on older hardware (DaveBarach, 15:07:54)

  5. aarch64 (Honnapa reporting) (DaveBarach, 15:08:24)
    1. bihash memory-ordering / atomics changes (DaveBarach, 15:09:11)

  6. release 19.04 (Dave W reporting) (DaveBarach, 15:11:15)
    1. maintenance release completed, no additional maint release schedule (DaveBarach, 15:11:33)
    2. 1904 maint release csit report should be out in a week or so (DaveBarach, 15:11:49)
    3. SPDK now using vpp 19.04.2 (DaveBarach, 15:12:11)

  7. release 19.08 (Andrew Y reporting) (DaveBarach, 15:12:35)
    1. last week API freeze tripped over some API CRC issues (DaveBarach, 15:12:54)
    2. The crc check job is very useful (DaveBarach, 15:13:27)
    3. proposal to reenable as master reopens (DaveBarach, 15:13:39)
    4. proposal to make job voting again as master reopens (DaveBarach, 15:14:08)
    5. AGREED: to reenable CRC check job voting as master reopens (DaveBarach, 15:14:58)

  8. Upcoming API changes (Dave W) (DaveBarach, 15:16:32)
  9. Infra (Ed K reporting) (DaveBarach, 15:17:28)
    1. gerrit server on the west coast and vexxhost latency issue (DaveBarach, 15:18:02)
    2. working with LF to monitor network latency (DaveBarach, 15:18:19)
    3. Andrew Y make-test improvements major reduction in wallclock time (DaveBarach, 15:19:23)
    4. Florin reports that private -> public patch transitions don't kick off merge jobs (DaveBarach, 15:21:37)


Meeting ended at 15:26:18 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. DaveBarach (31)
  2. collabot` (3)


Generated by MeetBot 0.1.4.