#fdio-vpp: FD.io VPP meeting

Meeting started by mackonstan at 15:01:14 UTC (full logs).

Meeting summary

    1. mackonstan (mackonstan, 15:01:44)

  1. CSIT project - Maciek updates (mackonstan, 15:02:03)
    1. Lots of infra work completed: (mackonstan, 15:02:11)
    2. - VPP API gating with CRC checks ./job/vpp-csit-verify-api-crc-master/ (mackonstan, 15:02:20)
    3. - VAT to PAPI migration, scale tests still require VAT (mackonstan, 15:03:14)
    4. - RF L2 Keywords alignment across 2-node and 3-node test topologies (mackonstan, 15:04:10)
    5. - migration of remaining VIRL functional tests to vpp_device container based test environment (mackonstan, 15:04:32)
    6. - Arm (Taishan) and Atom (Denverton) test environment CI/CD onboarding (mackonstan, 15:05:05)
    7. - Hardware failures: SSDs keep dying on us, but being replaced swiftly (mackonstan, 15:05:19)
    8. Quite a few new test cases: (mackonstan, 15:05:29)
    9. IPsec, dot1q+vxlan+vhost and http/tcp tests are back (mackonstan, 15:05:47)
    10. https://wiki.fd.io/view/CSIT/csit1908_plan (mackonstan, 15:05:54)
    11. vpp v19.08 rc1/rc2 dry runs, few issues spotted (mackonstan, 15:06:03)
    12. csit fixed: 3n-skx avf tests, 2link bonding, cleaning topology after avf tests (mackonstan, 15:06:16)
    13. open issues: (mackonstan, 15:06:28)
    14. - papi dump calls, remote socket connection not opening, intermittent, affects ~3% of tests (mackonstan, 15:06:36)
    15. - memif activation failures, intermittent (mackonstan, 15:06:52)
    16. - avf activation failures, intermittent (mackonstan, 15:07:01)
    17. vpp master trending issues: (mackonstan, 15:07:28)
    18. - all fib scale tests failing, tracked by: https://jira.fd.io/browse/VPP-1743, suspect: https://gerrit.fd.io/r/c/vpp/+/20004 (mackonstan, 15:07:37)
    19. bunch of host-stack cherry-picks into 19.08 (DaveBarach, 15:10:30)
    20. one more patch needed before 19.08 (DaveBarach, 15:10:48)
    21. meeting this afternoon w/ Ray (DaveBarach, 15:11:48)
    22. by the end of the week, goal: ready to go live (DaveBarach, 15:12:03)
    23. tap interface issue root-caused, need to test patch (DaveBarach, 15:13:54)
    24. dual-loop being tested (DaveBarach, 15:14:01)
    25. bihash writeup coming (DaveBarach, 15:15:31)
    26. no schedule maint release in the near future (DaveBarach, 15:16:05)
    27. on track for formal release tomorrow (DaveBarach, 15:16:34)
    28. discussion of release notes (DaveBarach, 15:17:22)
    29. John D to sync up w/ Andrew and decide what to do about release notes (DaveBarach, 15:19:07)
    30. ACTION: Andrew to construct automation to look for missing cherry-picks into 19.08 (DaveBarach, 15:21:00)
    31. api checker merged, problems to Dave Wallace and/or Andrew Yourtchenko (DaveBarach, 15:22:38)
    32. make-test parallelization has been a big improvement (DaveBarach, 15:31:52)
    33. ACTION: Ed Kern to turn on make-test parallelization in master/latest validation (DaveBarach, 15:32:46)
    34. some jobs hanging on log upload, mumble LF infra mumble (DaveBarach, 15:34:16)
    35. under investigation, if people notice pls ping Ed Kern (DaveBarach, 15:34:33)
    36. SSD errors causing individual machines to fail (DaveBarach, 15:35:18)
    37. ACTION: EJK to invent a functional equivalent for "recheck" for database query purposes (DaveBarach, 15:37:27)


Meeting ended at 16:10:10 UTC (full logs).

Action items

  1. Andrew to construct automation to look for missing cherry-picks into 19.08
  2. Ed Kern to turn on make-test parallelization in master/latest validation
  3. EJK to invent a functional equivalent for "recheck" for database query purposes


People present (lines said)

  1. DaveBarach (30)
  2. mackonstan (22)
  3. collabot` (3)


Generated by MeetBot 0.1.4.