#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:00:48 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:02:14)
    1. Daily perf tests - regular failures with artefacts upload and download to/from Nexus, issue worked by Vanessa/EdK (mackonstan, 15:02:47)
    2. CSIT-1908.1 maintenance release report published (mackonstan, 15:03:27)
    3. https://docs.fd.io/csit/rls1908_1/report/index.html (mackonstan, 15:03:34)
    4. CSIT-2001 plan - see highlights in minutes from last week csit project call (mackonstan, 15:03:51)
    5. http://ircbot.wl.linuxfoundation.org/meetings/fdio-csit/2019/fdio-csit.2019-10-09-14.04.html (mackonstan, 15:03:59)
    6. Will port to wiki shortly (mackonstan, 15:04:07)
    7. Current work areas: (mackonstan, 15:04:15)
    8. Infra/Framework: migration to Python 3.x, unprivileged VPP, higher latency resolution with HDRhistogram , auto-bisecting of perf regressions (mackonstan, 15:04:42)
    9. Testbeds: adding 100GE MLX5 NICs, Xeon CascadeLakes, more Arm ThunderX servers (mackonstan, 15:05:17)
    10. New tests: IPSec container tests, more coming (mackonstan, 15:05:36)

  2. host stack (Florin reporting) (DaveBarach, 15:06:05)
    1. TCP loss-recovery w/ lossy connections (DaveBarach, 15:06:35)
    2. Nathan patches to add app-layer certificate store (DaveBarach, 15:07:17)

  3. Documentation (John D reporting) (DaveBarach, 15:07:52)
    1. automate sphinx doc upload to netlify for auto inclusion in the main fd.io site (DaveBarach, 15:08:30)

  4. Release Management (Andrew, DaveW reporting) (DaveBarach, 15:10:41)
    1. 19.08 lagging master by a week-and-a-half (DaveBarach, 15:11:00)
    2. 19.04 has some cherry-picks above 19.04.2 (DaveBarach, 15:11:59)
    3. no obvious pressure to cut 19.04.3 (DaveBarach, 15:12:08)
    4. may need to recheck patches due to csit trigger malfunction (DaveBarach, 15:12:59)
    5. ACTION: dbarach to remove API check item from agenda (DaveBarach, 15:13:32)
    6. 20.01 release plan F0: 1/8/2020 (DaveBarach, 15:14:11)
    7. formal release 1/29/2020 (DaveBarach, 15:14:26)

  5. infra (DaveBarach, 15:16:13)
    1. AGREED: remove 16.04 validation job (DaveBarach, 15:16:24)
    2. discussion of LF outage since last meeting (DaveBarach, 15:17:01)
    3. difficult to root-cause, multiple symptoms (DaveBarach, 15:17:37)
    4. nexus timeout issues continue (DaveBarach, 15:18:50)
    5. more CentOS package changes (DaveBarach, 15:19:52)
    6. having to hand-build ruby, etc. etc. (DaveBarach, 15:20:16)
    7. drift between "stock" CentOS and our build environment (DaveBarach, 15:20:32)
    8. question: what's the maintenance story for CentOS (DaveBarach, 15:22:44)
    9. ACTION: dbarach to take CentOS EOL discussion to the TSC (DaveBarach, 15:23:55)

  6. make test/test-debug (Andrew) (DaveBarach, 15:29:04)
    1. improved test fails due to (DaveBarach, 15:31:21)

  7. py3 make test conversion (Dave W) (DaveBarach, 15:33:43)
    1. does the process have an owner? (DaveBarach, 15:33:54)
    2. hope to finish the transition in time for 20.01 (DaveBarach, 15:34:45)


Meeting ended at 15:38:57 UTC (full logs).

Action items

  1. dbarach to remove API check item from agenda
  2. dbarach to take CentOS EOL discussion to the TSC


People present (lines said)

  1. DaveBarach (31)
  2. mackonstan (10)
  3. collabot (3)
  4. alagalah (2)


Generated by MeetBot 0.1.4.