#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:59:21 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 16:03:00)
    1. infra - upgrades happening, minor issues (DaveBarach, 16:03:33)
    2. Migration to Python3 complete (DaveBarach, 16:03:47)
    3. Please report any Python3 anomalies (DaveBarach, 16:04:09)
    4. added packet latency stats (DaveBarach, 16:04:25)
    5. Mellanox-4 tests added to physical testbeds (DaveBarach, 16:04:38)
    6. ip4/ip6 fib scale tests added (DaveBarach, 16:04:48)
    7. Vratko has perf test bisection working (DaveBarach, 16:05:08)
    8. on target for 20.01 (DaveBarach, 16:05:13)
    9. TCP/Quicc test added, nsim added (DaveBarach, 16:05:57)

  2. Host Stack (Florin reporting) (DaveBarach, 16:07:03)
    1. tcp checksum offload config option added (DaveBarach, 16:07:17)
    2. will add APIs to request checksum offload on/off for specific connections (DaveBarach, 16:07:53)
    3. control useful when combined w/ ipsec (DaveBarach, 16:08:16)
    4. tcp timer handler issue: stop all timers, only afterwards call handlers (DaveBarach, 16:08:37)
    5. some improvements to the pacer (DaveBarach, 16:08:48)
    6. binary API improvements w/ Dave to support multiple binary API connections per process (DaveBarach, 16:09:40)
    7. need to merge one or two more patches to finish BinAPI threading work (DaveBarach, 16:10:21)

  3. Documentation (John D) (DaveBarach, 16:11:37)
    1. cleaning up commmand-line args documentation (DaveBarach, 16:11:58)
    2. maybe don't want to auto-push doc updates (DaveBarach, 16:13:06)
    3. script in doc/scripts, (DaveBarach, 16:13:16)

  4. Releases (Andrew, Dave W) (DaveBarach, 16:13:52)
    1. API freeze coming up (DaveBarach, 16:14:34)
    2. for 20.01 (DaveBarach, 16:14:41)
    3. 19.08.2 - csit add 19.08 (perf) trending jobs? (DaveBarach, 16:15:43)
    4. no plan, maybe we need one? (DaveBarach, 16:16:02)
    5. December shutdown, if we want to do a 19.08.2 release we need to do it in the next 2 weeks or postpone until February (DaveBarach, 16:16:44)
    6. 19.04.3 shipped, two patches since then, probably won't do a 19.04.4 (DaveBarach, 16:18:19)
    7. JDenisco asks if we can update docs to be sure we don't need e.g. 20.01 related changes (DaveBarach, 16:19:25)
    8. ACTION: jdenisco, dwallace, ayourtch to meet briefly (DaveBarach, 16:19:55)

  5. Infra (Ed K) (DaveBarach, 16:20:55)
    1. a bunch of upgrades / OS update (DaveBarach, 16:21:48)
    2. may see the word "suspended", should make no fundamental difference (DaveBarach, 16:22:35)
    3. reducing to a single cluster, should improve stability (DaveBarach, 16:23:07)
    4. CentOS 8 trial job to be added, will revisit in January (DaveBarach, 16:23:56)

  6. New Project request (ping@intel, florin) (DaveBarach, 16:26:26)
    1. host-stack accelerated applications (DaveBarach, 16:26:41)
    2. start with nginx (DaveBarach, 16:26:52)
    3. may add envoy (DaveBarach, 16:26:57)
    4. discussion about how to package modified apps so we don't cause package conflicts (DaveBarach, 16:28:38)


Meeting ended at 16:32:29 UTC (full logs).

Action items

  1. jdenisco, dwallace, ayourtch to meet briefly


People present (lines said)

  1. DaveBarach (43)
  2. collabot` (3)


Generated by MeetBot 0.1.4.