#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 16:01:25 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 16:01:52)
    1. 20.01 report expected tomorrow or Thursday, maybe 1 day late (DaveBarach, 16:02:28)
    2. Report will include pkt latency graphs (DaveBarach, 16:02:54)
    3. microcode upgrades for Spectre / Meltdown has had bad effects on Skylake, Cascade Lake (DaveBarach, 16:03:32)
    4. Intel recommendation is to revert microcode (DaveBarach, 16:03:56)
    5. will include release note to describe why we're not releasing Cascade Lake / Skylake data (DaveBarach, 16:04:48)
    6. skylake 5% perf hit, cascade lake 30% perf hit (DaveBarach, 16:05:50)
    7. Intel has reproduced the ucode issues, reproduced across a range of hardware platforms (DaveBarach, 16:06:45)

  2. Host Stack (Florin reporting) (DaveBarach, 16:07:11)
    1. starting to add NUMA-aware fifo memory allocation (DaveBarach, 16:07:49)
    2. VCL udp support working well (DaveBarach, 16:08:08)
    3. also a number of misc fixes (DaveBarach, 16:08:24)
    4. major svm fifo refactor to reduce memory consumption. Patches published but not merged (DaveBarach, 16:08:54)
    5. plan to eventually support fifo-size autotuning (DaveBarach, 16:09:06)
    6. optimizing codebase for > 1M session scale cases (DaveBarach, 16:09:33)

  3. Release Management(Dave Wallace) (DaveBarach, 16:10:22)
    1. 20.01 released on schedule (DaveBarach, 16:10:29)
    2. next release will be 20.05 (DaveBarach, 16:10:43)
    3. ACTION: Andrew to publish plan, etc. by March meeting (DaveBarach, 16:11:03)
    4. 19.08.1 is current, we've deferred 19.08.2 until now. Plan to coordinate test w/ csit community so we have perf trending info (DaveBarach, 16:11:48)
    5. expect 19.08.2 in the next couple of weeks (DaveBarach, 16:12:11)

  4. Infra (Ed K reporting) (DaveBarach, 16:12:36)
    1. LF needs to schedule monthly updates, would like to do updates next week. Requires outages, etc. (DaveBarach, 16:13:26)
    2. Note LF infra support wiki page: (DaveBarach, 16:13:55)
    3. https://wiki.fd.io/view/Infrastructure_Support (DaveBarach, 16:14:05)
    4. packagecloud image release process, vpp already doing the right things, etc. (DaveBarach, 16:15:12)
    5. hicn project was accidentally filling the release directory with >10,000 images, etc. (DaveBarach, 16:16:30)
    6. Keyword "betacheck" will trigger Jenkins Ubuntu 20.04 / CentOS-8 jobs (DaveBarach, 16:19:01)

  5. Documentation (John D) (DaveBarach, 16:22:35)
    1. LFN marketing still working on a blog post vis a vis 20.01. (DaveBarach, 16:23:27)
    2. whitepaper on its way. John DeGiglio involved, LFN project descriptions (DaveBarach, 16:24:11)
    3. 19.08, 19.04 doc merge jobs currently failing, Dave W and John D to address (DaveBarach, 16:24:54)
    4. ACTION: Dave W / John D to address 19.08, 19.04 merge jobs (DaveBarach, 16:25:25)

  6. aarch64 Juraj cross-compilation topic (DaveBarach, 16:26:33)
    1. ACTION: dbarach to ask LF about a coverity license (TSC Thursday) (DaveBarach, 16:44:10)

  7. HQoS support in fd.io (Ray, Steven Byrne) (DaveBarach, 16:48:28)
    1. original implementation was bolted together (DaveBarach, 16:49:08)
    2. want to do a 2.0 integration now (DaveBarach, 16:49:18)
    3. with actual maintenance, ownership (DaveBarach, 16:49:28)
    4. looking to have a next-stage technical / design (DaveBarach, 16:50:48)
    5. ACTION: Steve Byrne to setup tech deep dive on hqos (DaveBarach, 16:59:22)


Meeting ended at 16:59:52 UTC (full logs).

Action items

  1. Andrew to publish plan, etc. by March meeting
  2. Dave W / John D to address 19.08, 19.04 merge jobs
  3. dbarach to ask LF about a coverity license (TSC Thursday)
  4. Steve Byrne to setup tech deep dive on hqos


People present (lines said)

  1. DaveBarach (43)
  2. collabot` (3)


Generated by MeetBot 0.1.4.