#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:58:17 UTC (full logs).

Meeting summary

  1. CSIT (maciek reporting) (DaveBarach, 15:02:44)
    1. just pushed the 20.05 report out the door (DaveBarach, 15:02:56)
    2. Highlights - lots of work on infra, infra monitoring (DaveBarach, 15:03:29)
    3. report now tracking environment / csit / trex changes (DaveBarach, 15:03:51)
    4. vpp mainly performance progressions (DaveBarach, 15:04:23)
    5. acls improved due to api changes (DaveBarach, 15:04:45)
    6. counter-intuitive, but confirmed by bisection (DaveBarach, 15:05:22)
    7. new data structures related to API changes appears to be responsible (DaveBarach, 15:06:22)
    8. ACTION: Maciek to send commit ID for developer community analysis (DaveBarach, 15:06:51)
    9. ip6 scale test improved 15-20% (DaveBarach, 15:07:13)
    10. appears related to bihash tunes from DaveB, Damjan (DaveBarach, 15:08:43)
    11. no substantial regressions on vpp side (DaveBarach, 15:09:08)
    12. Ray asks: why aren't all tests being done on Denverton? (DaveBarach, 15:11:10)
    13. Maciek: test set in a config file (DaveBarach, 15:11:58)
    14. ACTION: Maciek and Ray will work the Denverton list offline (DaveBarach, 15:12:12)
    15. will beef up nat44 tests for next release (DaveBarach, 15:12:36)

  2. Release Management (Andrew Y, Dave W) (DaveBarach, 15:13:41)
    1. 20.05.01 will ship soon (this week) (DaveBarach, 15:14:02)
    2. shoot for Weds/Thurs. (DaveBarach, 15:14:15)
    3. 19.08 host doing automatic cherrypicks issues (DaveBarach, 15:14:54)
    4. Roughly 2/3rds of patches merge automatically (DaveBarach, 15:15:13)
    5. 20.09 kickoff beginning of August (DaveBarach, 15:15:57)
    6. Day 1 issue w/ artifact naming - RC2 builds have been inaccessible (DaveBarach, 15:16:43)
    7. To fix, add explicit commit ID's to artifact names (DaveBarach, 15:17:18)
    8. ACTION: Andrew to send mail to vpp-dev describing artifact naming change (DaveBarach, 15:17:51)
    9. API change process - so far, reasonably smooth sailing. 3-4 exceptions detected so far (DaveBarach, 15:18:24)
    10. several API downgrades in progress (DaveBarach, 15:19:02)

  3. Variable Naming Transition (DaveBarach, 15:32:56)
    1. AGREED: follow API name change process for APIs with names in need of harmonization (DaveBarach, 15:33:57)

  4. Infra Status (Dave W) (DaveBarach, 15:34:27)
    1. things have been fairly stable in terms of production (DaveBarach, 15:34:45)
    2. continuing to wrestle with Vexxhost to keep the wheels from falling off (DaveBarach, 15:35:03)
    3. process to rebuild Docker images has been delayed by the above (DaveBarach, 15:35:44)
    4. Docker image update process: need to update more than once a year,e tc. (DaveBarach, 15:35:59)
    5. goal to hit 20.09 timeframe (DaveBarach, 15:36:09)
    6. Zoom just dropped offline... (DaveBarach, 15:40:13)
    7. ACTION: DaveB to work out who to ask about relicensing code written by former Panthone employees (DaveBarach, 15:49:48)


Meeting ended at 15:50:10 UTC (full logs).

Action items

  1. Maciek to send commit ID for developer community analysis
  2. Maciek and Ray will work the Denverton list offline
  3. Andrew to send mail to vpp-dev describing artifact naming change
  4. DaveB to work out who to ask about relicensing code written by former Panthone employees


People present (lines said)

  1. DaveBarach (40)
  2. collab-meetbot (3)


Generated by MeetBot 0.1.4.