#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 14:57:03 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:02:28)
    1. Continuing to focus on stateful tests, calls-per-second and throughput transactions-per-second tests. Initial target is VPP NAT44-ED 5-tuple tests for CSIT-2009. (mackonstan, 15:02:47)
    2. New hardware, adding AMD EPYC zen2 performance testbed. (mackonstan, 15:03:57)
    3. Trending pages updated, extended historical data coverage from 3mths to 6mths to fully cover release cycle. (mackonstan, 15:04:17)
    4. Lots of other housekeeping work. (mackonstan, 15:04:49)

  2. Host Stack (Florin) (DaveBarach, 15:05:15)
    1. tracking pending timers due to timer pacing algorithm (DaveBarach, 15:05:52)
    2. network simulator now supports network reordering (DaveBarach, 15:07:13)
    3. 163.com working on a vcl patch to enable multi-threaded apps w/ workers (DaveBarach, 15:07:51)
    4. goal: to enable envoy to work with vcl / ld_preload. 30% latency reduction reported (DaveBarach, 15:08:13)

  3. Documentation (John D) (DaveBarach, 15:08:39)
    1. expect to add infographic from the marketing team over the next week or so (DaveBarach, 15:08:57)
    2. 20.05 release notes avaliable on the websit (DaveBarach, 15:09:08)

  4. Release Management (Andrew, DaveW) (DaveBarach, 15:11:12)
    1. 20.09 API freeze in about 4 weeks (DaveBarach, 15:11:22)
    2. deprecation tagging included in the API freeze, please make a note of it (DaveBarach, 15:11:57)
    3. 280 patches in master heading into 19.08 (DaveBarach, 15:12:32)
    4. found out that bursts of more than 20 cherry-picks causes serious issues w/ jenkins (DaveBarach, 15:13:14)
    5. Andrew figured out how to dribble cherry-picks into 19.08 (DaveBarach, 15:13:38)
    6. 20.05.1 is complete (DaveBarach, 15:13:46)
    7. Do we actually need to produce CSIT reports for 20.05.1? (DaveBarach, 15:14:12)
    8. resource limitation argue for not going there. (DaveBarach, 15:14:35)
    9. AGREED: we will not create CSIT reports for point releases, specifically 20.05.1 (DaveBarach, 15:15:36)
    10. artifact naming changes waiting for Damjan to return from PTO (DaveBarach, 15:16:17)
    11. coverity warnings (a number of false positive) 7 remain (DaveBarach, 15:17:07)
    12. please clean up (DaveBarach, 15:17:16)
    13. sonarcloud seems to catch real bugs in .py code (DaveBarach, 15:17:57)
    14. ACTION: Andrew to dig into sonarcloud defects (DaveBarach, 15:18:19)

  5. Infrastructure (DaveBarach, 15:19:24)
    1. nomad machines all running 18.04, installed by ansible (DaveBarach, 15:19:41)
    2. struggling with LF inability to understand / monitor their own infra (DaveBarach, 15:20:24)
    3. Havent seen Vexxhost timeouts recently (DaveBarach, 15:21:01)
    4. have somewhat better visibility on vm performance through DataDog (DaveBarach, 15:21:22)
    5. "git checkout" timeouts when 100 Jenkins jobs are trying at the same time (DaveBarach, 15:22:24)
    6. Probably no need to upload artifacts on verify job successes (DaveBarach, 15:28:05)


Meeting ended at 15:30:35 UTC (full logs).

Action items

  1. Andrew to dig into sonarcloud defects


People present (lines said)

  1. DaveBarach (34)
  2. mackonstan (4)
  3. collab-meetbot (3)


Generated by MeetBot 0.1.4.