#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:00:48 UTC (full logs).

Meeting summary

  1. CSIT (Maciek reporting) (DaveBarach, 15:01:44)
    1. Maciek K. (mackonstan, 15:01:46)
    2. New / updated tests: lots of focus on nat44: (mackonstan, 15:01:59)
    3. i) nat44-deterministic throughput (TRex stateless, bi-dir), ii)nat44-endpoint-dependent throughput (TRex stateless, uni-dir), iii)nat44-ed CPS and throughput (TRex stateful, bi-dir). (mackonstan, 15:02:45)
    4. All nat44 tests at varying scale 64k to 16M UDP sessions. TCP to follow. (mackonstan, 15:02:59)
    5. Test framework, environment: TRex stateless and stateful calibration work, TRex multi-thread "tuning" for higher speeds to fill MLX / 100GE. (mackonstan, 15:03:23)
    6. CSIT-2009: f1 milestone on Wed, branch pull, dry run tests of VPP rc1. (mackonstan, 15:04:08)

  2. Host stack (Florin reporting) (DaveBarach, 15:04:43)
    1. TCP tracks reordering w/ SACKs (DaveBarach, 15:05:09)
    2. network simulator plugin now supports packet reordering (DaveBarach, 15:05:52)
    3. LDP / vcl added support for multiple workers working with multiple app workers (DaveBarach, 15:07:05)
    4. small fixes in vcl, session layer for cut-through sessions (DaveBarach, 15:07:22)

  3. Docs (John D, Ray) (DaveBarach, 15:07:56)
    1. new infographic from Marketing, need tech review (DaveBarach, 15:08:15)

  4. Release management (Andrew, DaveW) (DaveBarach, 15:08:56)
    1. 20.09 RC1 throttle pull tomorrow (DaveBarach, 15:09:09)
    2. Production APIs are effectively frozen all of the time (DaveBarach, 15:09:54)
    3. 2 weeks post-RC2, to see if we can avoid an immediate point release. (DaveBarach, 15:11:11)

  5. 20.05.01 released over a month ago (DaveBarach, 15:12:09)
    1. 19.08.3 csit report deferred until 20.09 report is released (DaveBarach, 15:13:51)
    2. DaveBarach back... (DaveBarach, 15:17:39)

  6. Infra (Dave W) (DaveBarach, 15:18:43)
    1. at least 3 unscheduled Jenkins restarts due to Vexxhost work, mistakes, etc. (DaveBarach, 15:19:24)
    2. network between 2 data centers simply not reliable (DaveBarach, 15:19:47)
    3. hope to relocate Nomad servers to the same DC. Budget input to LFN in progress (DaveBarach, 15:20:28)
    4. requesting larger VM instances for Jenkins; currently only 8g (DaveBarach, 15:20:55)
    5. still running on ancient Docker instances, working on automation for creating new instances (DaveBarach, 15:23:22)
    6. next week, will push new instances as documented in gerrit 28022 (DaveBarach, 15:23:46)
    7. will deploy 20.04, centos8 and debian9 executors (DaveBarach, 15:26:55)
    8. ACTION: Andrew to chase down static analysis nits (DaveBarach, 15:27:43)

  7. Discussion of AMD Epyc performance (DaveBarach, 15:36:46)
    1. competitive with similar Intel h/w, ddio clearly counts for a good deal (DaveBarach, 15:37:31)
    2. AMD has testbeds going into CSIT, being onboarded now (DaveBarach, 15:43:54)
    3. expect to update 20.09 csit report w/ AMD perf numbers (DaveBarach, 15:44:23)


Meeting ended at 15:46:13 UTC (full logs).

Action items

  1. Andrew to chase down static analysis nits


People present (lines said)

  1. DaveBarach (31)
  2. mackonstan (6)
  3. collab-meetbot (3)


Generated by MeetBot 0.1.4.