#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:57:24 UTC (full logs).

Meeting summary

  1. CSIT (Maciek Reporting) (DaveBarach, 16:02:35)
    1. Complete set of nat44 results published in maintenance version of CSIT-2009 report last week (mackonstan, 16:02:45)
    2. Includes stateless benchmarks: Det BiDir, ED UniDir (mackonstan, 16:03:03)
    3. Includes stateful benchmarks: ED UDP CPS, ED UDP PPS, ED TCP CPS, ED TCP PPS (mackonstan, 16:03:10)
    4. Methodology description see link below (mackonstan, 16:04:57)
    5. https://docs.fd.io/csit/rls2009/report/introduction/methodology_nat44.html (mackonstan, 16:05:03)
    6. Benchmark graphs see link below (mackonstan, 16:05:10)
    7. https://docs.fd.io/csit/rls2009/report/vpp_performance_tests/packet_throughput_graphs/nat44.html (mackonstan, 16:05:15)
    8. Finally, will be publishing first experimental set of AMD zen2 benchmarks tomorrow/day after (mackonstan, 16:06:50)
    9. Preview of AMD data in the draft report version in master, see link below (mackonstan, 16:07:00)
    10. https://docs.fd.io/csit/master/report/vpp_performance_tests/packet_throughput_graphs/ip4.html (mackonstan, 16:07:09)
    11. Note that rls2009 report will only publish base frequency data, no turbo numbers, as that how it is done for all other platforms (mackonstan, 16:07:21)
    12. Many other things updates and goodies coming in 2101, see CSIT 2101 wiki for details as they are being filled in (mackonstan, 16:08:06)

  2. (Host Stack, Florin) (DaveBarach, 16:09:34)
    1. small updates (DaveBarach, 16:09:40)
    2. https://wiki.fd.io/view/CSIT/csit2101_plan (mackonstan, 16:09:49)
    3. session layer removed support for binary API connections (DaveBarach, 16:09:58)
    4. over shared memory. (DaveBarach, 16:10:07)
    5. scheduler improvements, to coalesce pkts (per session) (DaveBarach, 16:10:40)
    6. TCP improvements to segment pushing (DaveBarach, 16:10:55)
    7. Codenomicon tests run pre-release: 70-80 "failures" out of 1.2M (DaveBarach, 16:11:46)
    8. ssvm merged some mutex improvements (DaveBarach, 16:12:10)
    9. DTLS draft work, will publish after 21.01 (DaveBarach, 16:12:51)
    10. DTLS = "tls for UDP" (DaveBarach, 16:13:20)

  3. (Documentation, Ole) (DaveBarach, 16:18:03)
    1. no updates, ole driving, try not to hit phone pole! (DaveBarach, 16:18:33)

  4. Release Management (Andrew) (DaveBarach, 16:19:01)
    1. tomorrow is F0 for 21.01 (DaveBarach, 16:19:14)
    2. hold off risky commits until we pull the release branch (DaveBarach, 16:19:41)
    3. RC1 pull in one week (DaveBarach, 16:20:01)
    4. AGREED: let's not bother with F0 anymore (DaveBarach, 16:20:20)
    5. give the API change process, F0 isn't useful anymore (DaveBarach, 16:21:00)
    6. no updates for 20.09, 19.08 (DaveBarach, 16:21:46)
    7. plan to remove the 19.08 CI jobs in January. (DaveBarach, 16:22:09)
    8. Note that the release after 21.01 will be 21.06 (DaveBarach, 16:22:57)

  5. (Infra, Dave Wallace) (DaveBarach, 16:23:04)
    1. "Jenkins sucks" (DaveBarach, 16:23:10)
    2. restarted Jenkins yesterday to unconstipate it (DaveBarach, 16:23:35)
    3. list of 20+ plugins which arent doing anything, to remove (DaveBarach, 16:24:18)
    4. another Jenkins restart later today (DaveBarach, 16:24:28)
    5. another patch in flight to fix CentOS issues. "PowerTools" repo name changed to "powertools." (DaveBarach, 16:25:06)
    6. Added non-voting address sanitizer job (DaveBarach, 16:26:51)
    7. improved capture / placement of failed unittest logs (DaveBarach, 16:28:29)
    8. (from Ray) Red Hat plans to EOL CentOS as it is, replace with something like Red Hat REL (DaveBarach, 16:29:47)
    9. Debian 9 status: proposal to remove from 21.01 release (DaveBarach, 16:30:41)
    10. Cisco internal customer apparently needs to move to Debian 10. (DaveBarach, 16:31:17)
    11. patch in progress to make vppctl statically-linked (DaveBarach, 16:32:35)
    12. Plan to move to Ubuntu 20.04 as our primary test distro. Csit runs on 18.04, so some effort required (DaveBarach, 16:35:41)
    13. can start as soon as the 21.01 release throttle is pulled (DaveBarach, 16:36:02)

  6. Issues (DaveBarach, 16:38:35)
    1. Coverity Cleanup next week (DaveBarach, 16:39:20)
    2. Chris H: frame-queue fixes please review patch (DaveBarach, 16:40:29)
    3. https://gerrit.fd.io/r/c/vpp/+/28980 (chopps, 16:40:44)
    4. https://gerrit.fd.io/r/c/vpp/+/28980 (dwallacelf, 16:41:38)
    5. ACTION: Dave B to review 28980 (DaveBarach, 16:42:48)
    6. new native asm crypto w/ QAT supposedly 30% faster than dpdk ipsec code (DaveBarach, 16:48:10)


Meeting ended at 16:50:12 UTC (full logs).

Action items

  1. Dave B to review 28980


People present (lines said)

  1. DaveBarach (43)
  2. mackonstan (13)
  3. collab-meetbot (3)
  4. chopps (1)
  5. dwallacelf (1)


Generated by MeetBot 0.1.4.