#fdio-vpp: fdio-vpp

Meeting started by DaveBarach at 15:58:21 UTC (full logs).

Meeting summary

  1. agenda bashing (DaveBarach, 16:02:39)
    1. +coverity discussion (DaveBarach, 16:03:00)
    2. +API CRC (DaveBarach, 16:04:21)

  2. CSIT (Maciek reporting) (DaveBarach, 16:05:40)
    1. csit-2101 rls: Report published, last week added GSO benchmarks (mackonstan, 16:06:24)
    2. One known open items is async crypto benchmarks for fat tunnels - test logs and measurements are under review (mackonstan, 16:06:47)
    3. Other updates: move to Ubuntu 20.04 in progress, (mackonstan, 16:07:13)
    4. Vexxhost DC move of FD.io Nomad and CSIT testbed servers/HW: MTL2 (1 rack) move to YUL1 complete, MTL1 (4 racks) move to YUL1 to be scheduled (mackonstan, 16:07:47)
    5. Big thanks to Peter Mikus, Andrew Yourtchenko and Dave Wallace for assisting with the move, and working with Vexxhost to iron out some "teething issues" (mackonstan, 16:08:23)
    6. Major work areas: support AWS c5n environment, enhancing Linux&VPP telemetry, redesigning data backend, MLRsearch improvements, faster PAPI, tuning/adding tests. (mackonstan, 16:09:42)

  3. host stack (Florin reporting) (DaveBarach, 16:10:07)
    1. UDP fixes / enhancements over the past month (DaveBarach, 16:10:23)
    2. fix fifo segment leaks due to worker migration (DaveBarach, 16:10:36)
    3. remove rx spinlocks from udp sessions for connected sessions (DaveBarach, 16:11:04)

  4. Documentation (report readout from Ole) (DaveBarach, 16:11:28)
    1. no updates (DaveBarach, 16:11:38)

  5. 21.01 release (Andrew / DaveW) (DaveBarach, 16:11:49)
    1. holding off next point release until data center move complete (DaveBarach, 16:12:04)
    2. 21.06 release plan published (DaveBarach, 16:12:17)
    3. API process changes reflected in lack of API freeze milestone (DaveBarach, 16:12:58)
    4. continue with the extended milestone cadence (DaveBarach, 16:13:27)
    5. + "release gate" milestone (DaveBarach, 16:13:59)
    6. deadlines set to noon UTC so the LF folks are still online (DaveBarach, 16:14:34)

  6. API status changes (Andrew) (DaveBarach, 16:15:09)
    1. daily reports added to github (DaveBarach, 16:15:20)
    2. api status ends up in .json files (DaveBarach, 16:17:47)
    3. https://github.com/vpp-dev/vpp-release-notes (dmarion, 16:18:50)

  7. Coverity(Andrew) (DaveBarach, 16:19:54)
    1. https://github.com/vpp-dev/vpp-coverity-report (dmarion, 16:20:02)
    2. Coverity report also on github (DaveBarach, 16:20:11)
    3. 19.08 maintenance release not yet scheduled (DaveBarach, 16:25:43)
    4. plan to defer until data center move complete (DaveBarach, 16:26:02)

  8. Infra Status (DaveW) (DaveBarach, 16:26:49)
    1. move phase 1 went reasonably well (DaveBarach, 16:27:04)
    2. More reliable connections between two DC's than we've ever had (DaveBarach, 16:27:36)
    3. Need to finish retiring Nexus (DaveBarach, 16:27:51)
    4. Auto-abandon expect Ole to have script next week (DaveBarach, 16:28:43)
    5. probably pick 180 days as a threshold to start with (DaveBarach, 16:29:06)

  9. Multicore Make Test (Andrew) (DaveBarach, 16:29:39)
    1. running now, non-voting (DaveBarach, 16:30:10)
    2. Damjan (kidding): Perhaps generate another report? (DaveBarach, 16:30:55)
    3. DaveW: deploying multi-core tests, log upload of core-file backtraces (DaveBarach, 16:31:44)
    4. Dave W: send failure cause analysis suggestions to Dave W (DaveBarach, 16:32:38)

  10. API CRC issue (Ole email) (DaveBarach, 16:33:33)
    1. crc issue in compiler, will yield an API crc flag day (DaveBarach, 16:34:15)
    2. AndrewL matter of coordination (e.g. w/ CSIT), might as well push the button (DaveBarach, 16:35:31)
    3. Andrew: timing probably best sooner vs. later (DaveBarach, 16:36:01)
    4. Andrew: maybe give people a months' notice (DaveBarach, 16:36:26)
    5. ACTION: Ole to put together a (date) proposal and communicate it (DaveBarach, 16:37:45)

  11. Snort plugin + DAQ (Damjan) (DaveBarach, 16:38:12)
    1. zero-copy interface (DaveBarach, 16:38:43)
    2. sharing buffers w/ read-only memory map with snort (DaveBarach, 16:39:52)


Meeting ended at 16:58:08 UTC (full logs).

Action items

  1. Ole to put together a (date) proposal and communicate it


People present (lines said)

  1. DaveBarach (46)
  2. mackonstan (6)
  3. collab-meetbot (3)
  4. dmarion (2)


Generated by MeetBot 0.1.4.