#onap-int: Integration weekly meeting 27/03/2019

Meeting started by morgan_orange at 13:00:51 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 13:01:00)
    1. Yang Xu (morgan_orange, 13:01:27)
    2. andrew (morgan_orange, 13:01:31)
    3. Eric Moore (morgan_orange, 13:01:34)
    4. gary Wu (morgan_orange, 13:01:39)
    5. Kenny Paul (morgan_orange, 13:01:45)
    6. Marco Platania (morgan_orange, 13:01:52)
    7. Marcin Przybysz (morgan_orange, 13:02:04)
    8. Mariusz Wagner (morgan_orange, 13:02:12)
    9. Narae Kim (morgan_orange, 13:02:16)

  2. Quick review of last week work (morgan_orange, 13:02:27)
    1. windriver lab is cleaned (old VMs removed) (morgan_orange, 13:02:38)
    2. 1 Go RAM free (morgan_orange, 13:02:59)
    3. 5 ONAP instances curently running (morgan_orange, 13:03:18)
    4. discussions on Casablabanca 3.0.2 (new maintenance release) to address security issues (expiration of certificates) (morgan_orange, 13:04:05)
    5. need to test the use case dealing with the dmaap data router (use case 5G) (morgan_orange, 13:04:45)
    6. no code change must be accepted for SR, only certificate update => any code change is risky (morgan_orange, 13:07:36)
    7. only security fixes are acceptable (morgan_orange, 13:08:25)
    8. ACTION: Yang check with policy project patch / security patch (morgan_orange, 13:08:34)
    9. M4 date + 1 week (morgan_orange, 13:09:58)
    10. M4 now planned for April 14th (morgan_orange, 13:10:11)

  3. Dublin Release Integration Test Blocking Issues (morgan_orange, 13:10:49)
    1. https://wiki.onap.org/display/DW/Dublin+Release+Integration+Test+Blocking+Issues (morgan_orange, 13:10:59)
    2. serious perfo issues on windriver integration lab (CPU heating on Rancher and k8s nodes) (morgan_orange, 13:11:24)
    3. root cause not clearly defined => increase of VM capabilities (new components seem perf demanding) (morgan_orange, 13:11:56)
    4. issue on model distribution (A&AI and SO OK but issue on SDNC) (morgan_orange, 13:12:53)
    5. Marco mentions that several components are down with staging version (morgan_orange, 13:13:16)
    6. meeting with SO contributors planned today (morgan_orange, 13:14:08)
    7. discussion on heartbeating used in cassandra (morgan_orange, 13:16:17)
    8. some concerns regarding cassandra integration (morgan_orange, 13:16:38)
    9. goal would be to use a "shared" cassandra (morgan_orange, 13:18:28)
    10. pushed by OOM team (morgan_orange, 13:18:41)
    11. in order to reduce the number instances (morgan_orange, 13:20:37)
    12. ACTION: morgan_orange send a mail to OOM for cassandra (+ cassandra expert cassandra operator under dev in Orange for another purpose) (morgan_orange, 13:22:23)

  4. rke (morgan_orange, 13:23:06)
    1. kubernetes used with rancher (morgan_orange, 13:23:17)
    2. version is a bit old (morgan_orange, 13:23:30)
    3. OOM working on moving to a more recent version Rancher Kubernetes Engine (morgan_orange, 13:24:51)
    4. https://github.com/rancher/rke (morgan_orange, 13:24:57)
    5. Gary tested RKE on Integration lab (morgan_orange, 13:25:47)
    6. other test in progress: use instead of 12 VM x 16 Go => 6 VM x 32 Go of memory (morgan_orange, 13:26:45)
    7. high CPU was blocking the deployments, seem better now (morgan_orange, 13:27:05)
    8. evolution to RKE should allow to get rid off the traditionnal rancher node (morgan_orange, 13:28:05)
    9. no more rancher dashboard (morgan_orange, 13:28:18)
    10. kubernetes version is different , helm is unchanged + also new ubuntu, new docker (morgan_orange, 13:29:30)
    11. see sb01 for more details (morgan_orange, 13:31:33)

  5. Casablanca 3.0.2 testing plan (morgan_orange, 13:31:59)
    1. needs to run vFW on Casa maintenance release to be sure (morgan_orange, 13:35:16)
    2. ACTION: morgan_orange send a mail on the status for Casablanca on Orange lab (morgan_orange, 13:35:29)

  6. ONAP F2F presentation planning (morgan_orange, 13:35:59)
    1. Yang booked a 1h slot for integration meeting - Yang planned to provide some training to indicate how we perform tests in the integration lab + how to automate tests with Robot (<< brian) (morgan_orange, 13:37:00)
    2. Yang, gary, Marco, Brian will attend ONS next week (morgan_orange, 13:38:26)
    3. slot on Tuesday (morgan_orange, 13:39:49)

  7. Question about progress on Orange/LF image build (versioning, process, meeting time, etc) (morgan_orange, 13:40:07)
    1. activity mainly on gating today => no progress on docker build strategy to extend gating to other candidates (morgan_orange, 13:46:12)
    2. yang mentions that SO would be a good candidate as it is central and changing frequently (breaking the gate) (morgan_orange, 13:46:38)
    3. as SO gating includes compilation / docker creation ...it is not as easy as OOM (clone repo + overwritte with patchset) (morgan_orange, 13:47:29)

  8. AoB (morgan_orange, 13:48:15)
    1. discussions on PNF test case + simulator (morgan_orange, 13:48:49)
    2. ACTION: Krysztof: plan presentation on PNF/simulator for El Alto (status) in 2 weeks (morgan_orange, 13:51:20)


Meeting ended at 13:51:29 UTC (full logs).

Action items

  1. Yang check with policy project patch / security patch
  2. morgan_orange send a mail to OOM for cassandra (+ cassandra expert cassandra operator under dev in Orange for another purpose)
  3. morgan_orange send a mail on the status for Casablanca on Orange lab
  4. Krysztof: plan presentation on PNF/simulator for El Alto (status) in 2 weeks


Action items, by person

  1. morgan_orange
    1. morgan_orange send a mail to OOM for cassandra (+ cassandra expert cassandra operator under dev in Orange for another purpose)
    2. morgan_orange send a mail on the status for Casablanca on Orange lab
  2. UNASSIGNED
    1. Yang check with policy project patch / security patch
    2. Krysztof: plan presentation on PNF/simulator for El Alto (status) in 2 weeks


People present (lines said)

  1. morgan_orange (64)
  2. collabot (4)


Generated by MeetBot 0.1.4.