#onap-int: integration weekly meeting 19/06/2019

Meeting started by morgan_orange at 13:00:12 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 13:00:18)
    1. Yang Xu (morgan_orange, 13:00:29)
    2. Gary Wu (morgan_orange, 13:00:34)
    3. Marek Pondel (morgan_orange, 13:00:41)
    4. Morgan Richomme (morgan_orange, 13:00:47)
    5. Marcin Przybysz (morgan_orange, 13:01:00)
    6. Brian (morgan_orange, 13:01:58)
    7. Kenny Paul (morgan_orange, 13:02:04)
    8. Prabhu (morgan_orange, 13:02:09)
    9. Lasse Kaihlavirta (morgan_orange, 13:02:38)
    10. Eric Moore (morgan_orange, 13:04:06)
    11. afenner (morgan_orange, 13:04:09)

  2. introduction (morgan_orange, 13:04:20)
    1. we have never been so closed to the Dublin release (morgan_orange, 13:04:33)
    2. last week: finalization of use cases + S3P test preparation (morgan_orange, 13:05:14)
    3. S3P in progress (morgan_orange, 13:05:19)
    4. feedback from the DDF: lots of sessions, good discussions with testers/developers (morgan_orange, 13:05:53)
    5. good discussion on El Alto priorities (morgan_orange, 13:06:21)
    6. good session on OOM, considering extending gating to SO (morgan_orange, 13:06:50)
    7. session on offline installers: apparently less problem than with online installer (dependency with gerrit/jenkins/...) => Orange lab daily Dublin will migrate to offline installer (morgan_orange, 13:09:36)
    8. session on Robot: small crowd but good feedback (morgan_orange, 13:09:51)

  3. Documentation (morgan_orange, 13:14:37)
    1. we need to finish the documentation and upgrade the wiki asap (today) (morgan_orange, 13:15:23)
    2. ACTION: Brian refresh use case videos (morgan_orange, 13:16:03)
    3. morgan_orange asks if gating shall be documented => right place is the wiki, figures can be added to give an overview of gating for Dublin (morgan_orange, 13:21:25)
    4. section on postman (available in official repo) can be added (morgan_orange, 13:21:39)
    5. ACTION: morgan add a section to indicate postman collection (morgan_orange, 13:21:51)

  4. Dublin Release Integration Testing Status (morgan_orange, 13:22:12)
    1. https://wiki.onap.org/display/DW/Dublin+Release+Integration+Testing+Status (morgan_orange, 13:22:13)
    2. dicusssion on percentatage coverage of Health checks for running pods => calculation in progress to elaboarate on robot healthcheck coverage (morgan_orange, 13:23:42)
    3. we have 61 healthcheck robots but more than 240 pods => some pods are not covered, we need to better identify which code is not covered and aks the team to develop robot healthcheck if needed (morgan_orange, 13:26:09)
    4. S3P tests initiated on Monday night (morgan_orange, 13:26:35)
    5. 2 tests (morgan_orange, 13:27:16)
    6. 1) vFW closed LOOP running (check every 1h that it is still running): OK so far (morgan_orange, 13:27:27)
    7. 2) onbaord/installation looping => issue with SDC / Cassandra timeout (morgan_orange, 13:27:53)
    8. results getting better- observing the evolution of the results (morgan_orange, 13:28:39)
    9. issues in the lab: packet loss, slowliness (morgan_orange, 13:29:07)
    10. SDC-2375; SDC-2374 (morgan_orange, 13:29:31)
    11. http://onapci.org/jenkins/job/windriver-sb01-stability72hr/ (morgan_orange, 13:30:11)
    12. Yang asks if we shoudl revert config changes due to network issues on windriver lab (morgan_orange, 13:32:36)
    13. Garry suggests to not change anything during the current tests (morgan_orange, 13:32:52)
    14. Brian also experienced very low bandwidth (download stuff for ever...) (morgan_orange, 13:34:03)
    15. weird network issues with hieratic packet loss experienced.. (morgan_orange, 13:34:43)
    16. 72h test best ETA tomorrow morning / needed for the release (morgan_orange, 13:38:35)
    17. discussion on the deployment of a new instance => risk for the stability of the existing platform? (morgan_orange, 13:41:38)
    18. new instance could be used to test 3 nodes cluster for the appc. on SP02 => error on AAF, could be use for reliability tests (morgan_orange, 13:46:20)
    19. discussion on how to improve lab usage to be planned (question of resources / issues / ..) (morgan_orange, 13:49:40)
    20. morgan_orange indicates that Orange does not use integration installer, installation of k8s is based on kubespray https://gitlab.forge.orange-labs.fr/opnfv/kubespray_automatic_installation (morgan_orange, 13:50:40)

  5. AoB (morgan_orange, 13:50:57)
    1. DCAE CSCIT test in review (Lasse) => ask how to integrate it in CI/CD (morgan_orange, 13:51:28)
    2. https://gerrit.onap.org/r/c/integration/csit/+/89806 (morgan_orange, 13:54:16)
    3. new jenkins job shall be created to tun the CSIT test (morgan_orange, 13:55:20)
    4. question on how to move CSIT to daily, Gary indicates that Portal team has already done this (morgan_orange, 13:56:22)
    5. test code is not the same for CSIT and daily (morgan_orange, 13:56:50)
    6. onapci seems only accessible from US (hosted by Huawei), an option would be to migrate the server to windriver lab (tooling tenant) (morgan_orange, 14:00:41)
    7. wiki page on restrictions on CI would be useful (morgan_orange, 14:05:19)
    8. top 3 priority for El Alto (morgan_orange, 14:05:34)
    9. ACTION: Yang initiate discussion/wiki page for CI/CD evolution (morgan_orange, 14:07:31)


Meeting ended at 14:07:43 UTC (full logs).

Action items

  1. Brian refresh use case videos
  2. morgan add a section to indicate postman collection
  3. Yang initiate discussion/wiki page for CI/CD evolution


People present (lines said)

  1. morgan_orange (61)
  2. collabot` (3)


Generated by MeetBot 0.1.4.