#onap-int: onap integration weekly meeting 21/08/2019

Meeting started by morgan_orange at 13:01:04 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 13:01:09)
    1. Daniel Rose (morgan_orange, 13:01:11)
    2. Brian (morgan_orange, 13:01:21)
    3. Marcin (morgan_orange, 13:01:25)
    4. Morgan (morgan_orange, 13:01:31)
    5. Lasse (morgan_orange, 13:01:34)
    6. Marco (morgan_orange, 13:03:24)
    7. Ruoyu (morgan_orange, 13:03:29)
    8. Michal (morgan_orange, 13:04:00)
    9. https://wiki.onap.org/pages/viewpage.action?pageId=6593670 (morgan_orange, 13:04:12)

  2. Review El Alto Recent Fixes and Manual work arounds (morgan_orange, 13:06:53)
    1. complex troubleshooting on dmapp / zookeeper issues (morgan_orange, 13:07:29)
    2. when dmaap unstable => snowball effect on lots of components (morgan_orange, 13:07:49)
    3. additionnaly 1.5.0 of SO has a new dependency towards SDC (morgan_orange, 13:08:09)
    4. https://jira.onap.org/browse/SDNC-855 (morgan_orange, 13:08:51)
    5. SO has been reverted to Dublin version (morgan_orange, 13:09:02)
    6. in order to save disc space for long duration test, a change had been done on the heat template => a side effect of this issue was hieratic problems on cassandra (morgan_orange, 13:09:56)
    7. this change has been reverted as well => use local discs => back to decent Dublin performances (morgan_orange, 13:10:30)
    8. zookeeper reverted from alpine to ubuntu version (morgan_orange, 13:10:59)
    9. with these 3 reverted configurations, labs look re-usable (onboarding/distribution/instantiation) (morgan_orange, 13:11:26)
    10. list of associated JIRA: (morgan_orange, 13:12:01)
    11. https://jira.onap.org/browse/SDNC-85 (morgan_orange, 13:12:13)
    12. https://jira.onap.org/browse/DMAAP-1272 (morgan_orange, 13:12:23)
    13. https://jira.onap.org/browse/SO-2229 (morgan_orange, 13:12:30)
    14. https://jira.onap.org/browse/SO-2228 (morgan_orange, 13:12:37)

  3. El Alto Early Drop Recommendation to TSC (morgan_orange, 13:12:52)
    1. https://wiki.onap.org/display/DW/El+Alto+Early+Drop+Integration+Testing+Status (morgan_orange, 13:13:29)
    2. good progress (morgan_orange, 13:13:37)
    3. http://onapci.org/jenkins/ reachable through the windriver lab (morgan_orange, 13:14:20)
    4. ACTION: Brian clarify access to http://onapci.org/jenkins/ (morgan_orange, 13:14:45)
    5. jenkins jobs have been moved from a private github to integration (morgan_orange, 13:15:11)
    6. https://gerrit.onap.org/r/c/integration/+/93992/ (morgan_orange, 13:15:21)
    7. repo has been forked, casablancla could be cleaned later (morgan_orange, 13:16:35)
    8. recommendation to focus on CI => zookeeper move would have been identified with gating if it would have been up as it is breaking the gate... (morgan_orange, 13:18:07)

  4. Environment Review (morgan_orange, 13:18:32)
    1. SB00 has been installed: El Alto branch refreshed once a week (morgan_orange, 13:18:51)
    2. SB04: could be used if SB00 is not enough (morgan_orange, 13:19:17)
    3. main focus for this week testing integration-release-daily and SB00 (morgan_orange, 13:20:04)
    4. question on the access to the lab => create a JIRA ticket (morgan_orange, 13:21:53)
    5. https://wiki.onap.org/pages/viewpage.action?pageId=29787070 (morgan_orange, 13:21:56)
    6. also possible to ask for an access on Orange lab (morgan_orange, 13:22:10)
    7. https://wiki.onap.org/display/DW/Orange+OpenLab (morgan_orange, 13:22:21)

  5. demo test infra (morgan_orange, 13:23:30)
    1. demo of infra tests performed in Orange lab (morgan_orange, 13:47:29)
    2. https://gitlab.com/Orange-OpenSource/lfn/onap/xtesting-onap/pipelines/77458711 (morgan_orange, 13:47:47)
    3. https://gitlab.com/Orange-OpenSource/lfn/onap/xtesting-onap/-/jobs/276610934 (morgan_orange, 13:47:55)
    4. see artifact part to get the public web page (morgan_orange, 13:48:20)
    5. http://orange-opensource.gitlab.io/lfn/tools/results_ts_view/ (morgan_orange, 13:48:23)
    6. https://orange-opensource.gitlab.io/lfn/onap/xtesting-onap-view/index.html (morgan_orange, 13:48:31)
    7. https://orange-opensource.gitlab.io/lfn/onap/xtesting-onap-view/results/91572-1/index.html (morgan_orange, 13:48:40)
    8. https://wiki.opnfv.org/pages/viewpage.action?pageId=13211751 (morgan_orange, 13:48:46)
    9. infra testing planned to be reused for CNTT (morgan_orange, 13:48:57)
    10. already shared in ONS LA, ONS Amsterdam (morgan_orange, 13:49:10)
    11. infra test performed done weekly (morgan_orange, 13:49:41)
    12. first test done on windriver lab (nfs SB00) (morgan_orange, 13:49:51)
    13. should be done in a dedicated infra small VM (just need kubectl + openstack creds) (morgan_orange, 13:50:17)
    14. https://wiki.onap.org/pages/viewpage.action?pageId=6593670&preview=%2F6593670%2F54722733%2Fonap_tests.pdf (morgan_orange, 13:53:40)

  6. round table (morgan_orange, 13:53:44)
    1. release 2 weeks late (not official) (morgan_orange, 13:55:30)
    2. should be done with most refactoring for El Alto - 1.5.1 is latest (morgan_orange, 13:56:05)
    3. Michale working on vcpe => some issues, VNF did not change since beijing (morgan_orange, 13:56:26)
    4. ACTION: brian intall integration-release-daily for vcpe testing (morgan_orange, 13:56:47)
    5. Morgan plan to setup infra test on windriver, gating back, discussions in progress with LF to get extra cloud resources for the gating (morgan_orange, 13:57:36)
    6. Marco vFW needs to wait for appc for closedloop. Scale out dependent on CDS => potential VID issue. (morgan_orange, 13:59:00)
    7. lasse: samsung team hardening security of sdc (morgan_orange, 13:59:48)
    8. lasse portal removed csit tests because they do not deal with AAF (morgan_orange, 14:00:32)
    9. ACTION: lasse: suggest recommendation on csit evolution (morgan_orange, 14:01:54)
    10. grooming existing jobs to continue PTL discussion (morgan_orange, 14:02:32)
    11. jobs that are failing continously should be removed (morgan_orange, 14:04:17)
    12. plan a longer discussion on a csit next week (morgan_orange, 14:09:39)


Meeting ended at 14:09:50 UTC (full logs).

Action items

  1. Brian clarify access to http://onapci.org/jenkins/
  2. brian intall integration-release-daily for vcpe testing
  3. lasse: suggest recommendation on csit evolution


People present (lines said)

  1. morgan_orange (72)
  2. collabot` (3)


Generated by MeetBot 0.1.4.