#onap-int: integration weekly meeting 11/12/2019

Meeting started by morgan_orange at 13:58:39 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 14:02:25)
    1. AP1 Marco try to reinstall SB00 (morgan_orange, 14:02:26)
    2. done, lab was reinstalled => when kicking the installation in SB00, the jenkins was using the current master helm chart to install el alto (morgan_orange, 14:03:12)
    3. so at the moment SB00 is on Master (morgan_orange, 14:03:26)
    4. Manual Error fixed in VID chart (morgan_orange, 14:03:50)
    5. also some issues with policy => investigating if it is due to the use of master healm charts (morgan_orange, 14:04:08)
    6. but the docker versions are Ok => so it is really an El Alto (morgan_orange, 14:04:36)
    7. AP2: morgan_orange submit request to coordinator/TSC for Marcin promotion (morgan_orange, 14:05:17)
    8. done, coordinator OK for the 3 new committers (morgan_orange, 14:05:25)
    9. AP3: morgan_orange contact modeling team to get a status on the test (morgan_orange, 14:05:39)
    10. last tests were OK (morgan_orange, 14:06:02)
    11. AP4: Brian merge/review vCPE patchset from Bartek (morgan_orange, 14:06:13)
    12. done (morgan_orange, 14:06:25)

  2. Admin (morgan_orange, 14:06:51)
    1. lab status (morgan_orange, 14:06:57)
    2. windriver lab is back (morgan_orange, 14:08:03)
    3. DT lab added to integration page (morgan_orange, 14:08:12)
    4. http://testresults.opnfv.org/onap-integration/ (morgan_orange, 14:08:16)
    5. Daily runs on DT now (All VNFs run yesterday) (morgan_orange, 14:09:07)
    6. alias created for gerrit => integration-committer (will put all the integration project committers in revew) (morgan_orange, 14:13:21)
    7. 3 new committers officially approved: Marcin, Bartek and Eric (morgan_orange, 14:13:26)
    8. one committers officially stepping down: Marius Wagner (mail received) (morgan_orange, 14:13:29)

  3. Introduction to a new testing framework OTF (morgan_orange, 14:14:01)
    1. Open Test Framework (OTF) (morgan_orange, 14:14:19)
    2. framework to support patterns for automated E2E Service testing and fault isolation support (morgan_orange, 14:14:45)
    3. OTF can be used for Certification Test, Lifecycle Test and Monitoring and troublesooting (morgan_orange, 14:15:31)
    4. OTF provide simulators/emulators (morgan_orange, 14:15:57)

  4. El Alto Status (morgan_orange, 15:10:59)
    1. nothing new (morgan_orange, 15:11:03)
    2. graphgraph issue moved to highest (problem identified => docker not released) (morgan_orange, 15:11:20)

  5. Frankfurt (morgan_orange, 15:11:25)
    1. Discussion on Portal/Selenium test update (morgan_orange, 15:11:30)
    2. based on previous version feedback, we should have an automatic way to detect regression on portal (morgan_orange, 15:11:53)
    3. Brian updated existing portal robot tests (morgan_orange, 15:12:12)
    4. ACTION: morgan test new portal test and see if it is easy to integrate in healthcheck suites (morgan_orange, 15:12:29)
    5. update on xtesting (morgan_orange, 15:12:37)
    6. Dockerfile transfered from gitlab.com to ONAP repo in progress (morgan_orange, 15:12:40)
    7. https://gerrit.onap.org/r/c/integration/xtesting/+/99385 (morgan_orange, 15:12:47)
    8. ACTION: morgan create jjb to manage docker images (build and push to Nexus) (morgan_orange, 15:12:53)
    9. meanwhile gitlab.com built-in registry images are used in CI chains (morgan_orange, 15:12:56)
    10. https://gitlab.com/Orange-OpenSource/lfn/onap/xtesting-onap/pipelines/102162898 (morgan_orange, 15:13:00)
    11. note a new project has been created in the DB (integration projects), testsuites have been created for this project (morgan_orange, 15:13:05)
    12. http://testresults.opnfv.org/onap/api/v1/projects/integration/cases (morgan_orange, 15:13:09)
    13. new Daily dashboard (only enabled on gating) (morgan_orange, 15:13:15)
    14. https://orange-opensource.gitlab.io/lfn/onap/xtesting-onap-view/results/99452-1/index.html (morgan_orange, 15:13:19)
    15. ACTION: Andreas & Andrew move to new integration dockers on DT and E// labs (Daily dashboard will be updated as gating) (morgan_orange, 15:13:23)


Meeting ended at 15:13:36 UTC (full logs).

Action items

  1. morgan test new portal test and see if it is easy to integrate in healthcheck suites
  2. morgan create jjb to manage docker images (build and push to Nexus)
  3. Andreas & Andrew move to new integration dockers on DT and E// labs (Daily dashboard will be updated as gating)


People present (lines said)

  1. morgan_orange (48)
  2. collabot` (3)


Generated by MeetBot 0.1.4.