#onap-int: Integration weekly meeting 3/06/2020

Meeting started by morgan_orange at 14:23:57 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 14:24:16)
    1. AP1: pawel merge this patch for 1.6.2 release (morgan_orange, 14:24:27)
    2. done (morgan_orange, 14:24:28)
    3. AP2: morgan_orange create OOM patch su submit 1.6.2 in Master / Frankfurt (morgan_orange, 14:24:41)
    4. done (morgan_orange, 14:24:43)
    5. AP3: morgan_orange suggest a requirement to create ondemand lab for use case (isolate), could be based on chained-ci if pythonsdk issue fixed in windriver (morgan_orange, 14:24:51)
    6. done (morgan_orange, 14:24:53)
    7. AP4: morgan_orange invite Stephen good to integration weekly meeting (morgan_orange, 14:25:09)
    8. done (morgan_orange, 14:25:11)
    9. AP5: morgan_orange integrate stability test info in the release note (morgan_orange, 14:25:19)
    10. done (morgan_orange, 14:25:21)
    11. AP6: morgan_orange create requirement for G release on stability tests (morgan_orange, 14:25:31)
    12. done (morgan_orange, 14:25:33)
    13. note: for the requirements, release manager reports that they were too broad and need to be precised => to be done once Frankfurt is ready (morgan_orange, 14:27:55)

  2. Admin (morgan_orange, 14:28:07)
    1. testsuite 1.6.3 ready => need merge to produce in nexus and submit patch in OOM (morgan_orange, 14:28:21)
    2. https://gerrit.onap.org/r/c/testsuite/oom/+/108672 (morgan_orange, 14:28:39)
    3. delta between 1.6.2 and 1.6.3 limited to robot changes for hvves and 5gbulkpm (morgan_orange, 14:29:40)
    4. changes already taken into account in CI (as xtesting is recompiling docker everyday based on Master) (morgan_orange, 14:30:05)
    5. all integration branches have been cut on Friday, for frankfurt related changes do not forget to cherry pick (morgan_orange, 14:30:18)
    6. pythonsdk-tests repository available (morgan_orange, 14:33:19)
    7. jjb and linters added (morgan_orange, 14:33:24)
    8. https://git.onap.org/testsuite/pythonsdk-tests/ (morgan_orange, 14:34:02)

  3. windriver lab (morgan_orange, 14:49:17)
    1. discussions on the status (morgan_orange, 14:49:23)
    2. https://wiki.onap.org/display/DW/%5Bintegration%5D+ONAP+2%2C+Wed+UTC+13%3A00?preview=/6593670/84651195/windriver_status_03062020.pdf (morgan_orange, 14:49:26)
    3. ACTION: morgan_orange share presentation with windriver lab then onap-discuss , plan cleaning (morgan_orange, 14:50:15)

  4. frankfurt (morgan_orange, 14:50:22)
    1. readiness board: waiting for AAF, SO and testsuite :) (morgan_orange, 14:50:49)
    2. https://wiki.onap.org/display/DW/Frankfurt+Readiness+dashboard (morgan_orange, 14:51:30)
    3. UC indicator = 100% all the use cases completed.. (morgan_orange, 14:52:27)
    4. even if vCPE Tosca is hard to replay on daily frankfurt (morgan_orange, 14:58:45)
    5. BBS (last one) is OK since today (morgan_orange, 14:59:05)
    6. frankfurt CI not bad (morgan_orange, 15:00:24)
    7. https://gating-results.onap.eu/results/onap_daily_pod4_frankfurt-578289627-06-03-2020_02-06/ (morgan_orange, 15:01:23)
    8. regression on security, message-router-kafka exposed publically, mail sent to dmaap + SECCOM (morgan_orange, 15:01:47)
    9. message router was already in the xfail list (morgan_orange, 15:01:58)
    10. but not message-router-kafka on another port (morgan_orange, 15:02:15)
    11. error occured on daily-frankfurt and daily-master (morgan_orange, 15:02:27)
    12. and was not there yesterday (morgan_orange, 15:02:39)
    13. review of the sheet tracking the pod versions based on the daily run (morgan_orange, 15:04:14)
    14. https://docs.google.com/spreadsheets/d/1t3GNRtabdkVxG4ZAxqBJ-X7OO-Zv6xRwd8KrR52V9zU/edit#gid=1893816488 (morgan_orange, 15:04:32)
    15. it allows to track the version from one run to another and identify the changes (morgan_orange, 15:04:51)
    16. the RC2 is definied as target and we can observer how far we are from it based on daily results (morgan_orange, 15:05:10)
    17. next update planned tomorrow morning (morgan_orange, 15:05:23)
    18. it should be more automated.... (morgan_orange, 15:05:34)
    19. Blocking points (morgan_orange, 16:03:47)
    20. https://wiki.onap.org/display/DW/1%3A+Frankfurt+Release+Integration+Test+Blocking+Issues (morgan_orange, 16:03:53)
    21. currently no critical errors without workaround (morgan_orange, 16:04:15)
    22. JIRA: if still pending JIRA for frankfurt, it is now time to close them (if done) or move them to Guilin (for Frankfurt we will not do that much now..) (morgan_orange, 16:04:25)
    23. cleaning already initiated (morgan_orange, 16:04:38)
    24. note there is another repo TEST which references some issues (morgan_orange, 16:05:00)
    25. ACTION: morgan_orange study articulation TEST / INT on jira (morgan_orange, 16:05:12)
    26. next test planned for CI integration: preonboarding, CDS (morgan_orange, 16:05:28)
    27. documentaiton update needed (for 1.6.3)) (morgan_orange, 16:05:38)
    28. K reported some strange issues detected with pnf-registrate got unexpected 404 on some resources (morgan_orange, 16:06:19)
    29. morgan_orangeindictaes that a similar issue is also preventing vCPE Tosca to be integrated + 500 on MSB side.. (morgan_orange, 16:06:43)

  5. Guilin (morgan_orange, 16:06:52)
    1. presentation on robot utils postponed ot next week (morgan_orange, 16:07:09)
    2. a presentation is also planned for the vF2F as well as a presentation on pythonSDk (morgan_orange, 16:07:23)
    3. ACTION: morgan_orangeinitiate the request for repository creation (morgan_orange, 16:07:38)
    4. Master branch CI ststaus not bad (morgan_orange, 16:07:52)
    5. https://gating-results.onap.eu/results/onap_daily_pod4_master-578514947-06-03-2020_06-06/ (morgan_orange, 16:08:05)
    6. note that an ingress master chain is also running to include non legacy feature (morgan_orange, 16:08:26)
    7. discussion on pythonsdk-tests structure (morgan_orange, 16:08:47)
    8. thierry share a prototype (hosted on gtilab but target will be on ONAP) (morgan_orange, 16:09:06)
    9. https://gitlab.com/Orange-OpenSource/lfn/onap/pythonsdk-tests (morgan_orange, 16:09:36)
    10. approach similar than onap-tests, a yaml file is used to defined the inputs (morgan_orange, 16:09:51)
    11. https://gitlab.com/Orange-OpenSource/lfn/onap/pythonsdk-tests (morgan_orange, 16:10:12)
    12. goal is to replace all the vm_ tests in Guiling by scenarios coming from pythonsdk_tests leveraging onap pythonsdk (morgan_orange, 16:11:01)

  6. AoB (morgan_orange, 16:11:08)
    1. Integration commiter can have access to Orange daily platform for troubleshooting (morgan_orange, 16:11:24)
    2. please follow the procedure to get openlab access (morgan_orange, 16:11:36)
    3. https://wiki.onap.org/display/DW/Orange+OpenLab (morgan_orange, 16:11:53)
    4. thenk key will be propagated to the daily (morgan_orange, 16:12:04)
    5. daily-frankfurt ~ 8 PM UTC, daily-master 1 AmMUTC (morgan_orange, 16:12:28)


Meeting ended at 16:12:31 UTC (full logs).

Action items

  1. morgan_orange share presentation with windriver lab then onap-discuss , plan cleaning
  2. morgan_orange study articulation TEST / INT on jira
  3. morgan_orangeinitiate the request for repository creation


Action items, by person

  1. morgan_orange
    1. morgan_orange share presentation with windriver lab then onap-discuss , plan cleaning
    2. morgan_orange study articulation TEST / INT on jira


People present (lines said)

  1. morgan_orange (84)
  2. collab-meetbot (6)


Generated by MeetBot 0.1.4.