#onap-int: Integration weekly meeting 10/06/2020

Meeting started by morgan_orange at 14:17:55 UTC (full logs).

Meeting summary

  1. Action point follow-up (morgan_orange, 14:18:04)
    1. http://ircbot.wl.linuxfoundation.org/meetings/onap-int/2020/onap-int.2020-06-03-14.23.html (morgan_orange, 14:18:16)
    2. AP1 morgan_orange share presentation with windriver lab then onap-discuss , plan cleaning (morgan_orange, 14:18:27)
    3. done, mal sent + wiki page created, goal end of June, see next topic (morgan_orange, 14:18:41)
    4. AP2 morgan_orange study articulation TEST / INT on jira (morgan_orange, 14:18:51)
    5. TEST (testsuite) and INT (intégration) are 2 different JIRA projects. So far I was mainly considering INT for everything (Epic, task,..). TEST could be used for test case (robot, pythonsdk, bash,..) associated with Integration (morgan_orange, 14:20:06)
    6. only concern could be to miss JIRA (with 1 project, it is easier to track) but it makes sense and conforts the ideas that there are several projects in Integration :) (morgan_orange, 14:20:47)
    7. AP3 morgan_orange initiate the request for repository creation (morgan_orange, 14:21:05)
    8. mail thread with Daniel and Marek, see next topic on Robot util wrapper (morgan_orange, 14:21:26)

  2. Admin (morgan_orange, 14:21:35)
    1. windrevier cleaning operation planned end of June (morgan_orange, 14:21:47)
    2. wiki page created to track the resources used on wondriver lab (morgan_orange, 14:22:01)
    3. https://wiki.onap.org/display/DW/Windriver+lab+Frankfurt+cleaning+campaign (morgan_orange, 14:22:09)
    4. surprisingly it seems that APPC was the project consuming the more resources over the last 6 months (stats done from El Alto Release on the 24th of October) (morgan_orange, 14:22:42)
    5. lots of projects identified only by their uuid (morgan_orange, 14:22:57)
    6. first projects already indicated they want to keep some resources (morgan_orange, 14:23:23)
    7. ACTION: morgan_orange give a status to PTL during PTL meeting (morgan_orange, 14:23:35)
    8. vF2F event (morgan_orange, 14:23:42)
    9. several interesting topics for people dealing with Integration (morgan_orange, 14:23:53)
    10. presentation on pythonsdk, robot, automation in CI, Integration priorities, vFW use case, CDS,... (morgan_orange, 14:24:18)
    11. https://wiki.lfnetworking.org/pages/viewpage.action?pageId=34606297 (morgan_orange, 14:24:30)
    12. ACTION: morgan_orange add Marcin + Krzysztof as co speaker for from robot to CI session (morgan_orange, 14:27:41)
    13. add also S.Goosh for windriver talk (morgan_orange, 14:33:44)
    14. daily logs can now be pushed to LF (morgan_orange, 14:34:19)
    15. https://logs.onap.org/onap-integration/ (morgan_orange, 14:34:23)
    16. results of SB-00 lab status reinstallation of yesterday pushed to https://logs.onap.org/onap-integration/windriver-SB00/2020-06-09/ (morgan_orange, 14:35:01)

  3. frankfurt (morgan_orange, 14:35:11)
    1. RC2 blocked by issue detected on Mnday on AAF-SMS/OOF, hardcoded AAF-SMS certificate expired on the 3rd of June leading to OOF init errors (morgan_orange, 14:36:01)
    2. error was reported by Master and Frankfurt daily chains (morgan_orange, 14:36:14)
    3. Jira created => https://jira.onap.org/browse/AAF-1159 (morgan_orange, 14:36:47)
    4. this hardcoded certificate was fixed by OOM team, but another was detected (quorum) - fix needed (SECCOM no go) (morgan_orange, 14:37:44)
    5. new gating will be attempt to see if OOF start issue is systematically reproducible or not (morgan_orange, 14:38:02)
    6. meanwhile SB-00 has been reinstalled on windriver/Intel Lab (OOF issues) (morgan_orange, 14:38:21)
    7. the RC2 dockers have been provided by all the projects, so it is possible to perform regression tests with RC2 (morgan_orange, 14:38:52)
    8. mail sent to the use case owner to perform verification and get feedback on RC2 column of https://wiki.onap.org/display/DW/2%3A+Frankfurt+Release+Integration+Testing+Status (morgan_orange, 14:39:21)
    9. note that during the reinstallation, it was detected that the kubernetes and helm versions were no more correct in SB-0x installation scripts (morgan_orange, 14:39:51)
    10. Brian provided a fix to consider right recommended versions (new versions needed to leverage new kubernetes functions) (morgan_orange, 14:40:46)
    11. note has been added to S3P documentation to explain that the test has been performed on an old infrastructure (El Alto) even if the dockers were the frankfurt one. (morgan_orange, 14:41:22)
    12. https://gerrit.onap.org/r/c/integration/+/108969 (morgan_orange, 14:50:26)
    13. remaining work: 1) RC2 regression tests (except OOF) (morgan_orange, 14:51:04)
    14. remaining work: 2) reinstallation of dockers with OOF fix (morgan_orange, 14:51:23)
    15. remaining work: 3) regression test for OOM test (morgan_orange, 14:51:44)
    16. remaingin work 4) update of the documentation (morgan_orange, 14:51:53)
    17. note on documentation minor updates added in the patch for S3P update (morgan_orange, 14:52:21)
    18. gerrit voting -1 because one link in CCVPN doc (Amsterdam) is broken (morgan_orange, 14:52:37)
    19. ACTION: morgan_orange contact CCVPn team to see if the link can be fixed (part of procedure so hard to remove) (morgan_orange, 14:52:58)

  4. Guilin (morgan_orange, 14:53:03)
    1. python sdk update planned for next week (morgan_orange, 14:53:11)
    2. https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk (morgan_orange, 14:53:55)
    3. discussion on the possible scenation to be created in https://git.onap.org/testsuite/pythonsdk-tests/ (morgan_orange, 14:54:15)
    4. basic_vm, clearwater_vim, freeradius_nbi => to replace existing tests (morgan_orange, 14:54:34)
    5. to be included basic_cnf, basic policy, basic_network, basic_cds, basic_closedloop, vfw_closedloop,... (morgan_orange, 14:55:03)
    6. ACTION: all brainstorm on all the basic tests we need to ensure a better coverage ONAP by dedicated tests (not by use cases) (morgan_orange, 14:55:53)
    7. presentation robot-util to leverage pythonsdk by marek (morgan_orange, 14:56:12)
    8. Bell contributors interested to join the effort (morgan_orange, 14:56:22)
    9. ACTION: morgan_orange initiate the request to create a new repository testsuite/robot-utils (morgan_orange, 14:56:44)
    10. goal is to simplify the usage of pythonsdk for robot use case (morgan_orange, 14:57:08)
    11. Marek interested also to work on a Test developer guide, to help newcommers to create tests (morgan_orange, 14:57:24)
    12. currently few info (morgan_orange, 14:57:28)
    13. there is a page for robot end users (morgan_orange, 14:57:37)
    14. https://docs.onap.org/en/frankfurt/submodules/integration.git/docs/docs_robot.html?highlight=robot (morgan_orange, 14:57:57)
    15. and some Q&A but nothing really structured (morgan_orange, 14:58:08)
    16. ACTION: morgan_orange create an Guilin Epic for this new doc and assign Marec to it (morgan_orange, 14:58:30)
    17. presentation vnfsdk by Krrzysztof (morgan_orange, 14:58:46)
    18. VNFSDK allows to verify tosca/zip packages, implementation done in SDC by E/// and on vnfsdk by Nokia following SOL-000 and SOl-004 ETSI reco (morgan_orange, 14:59:42)
    19. a use case is available pnf preonboarding (morgan_orange, 14:59:56)
    20. robot tag is available (morgan_orange, 15:00:01)
    21. ACTION: morgan_orange krzysztof integrate this use case in CI Master (morgan_orange, 15:00:18)
    22. currently runnable in robot pod + bash script (to generate and push scripts) (morgan_orange, 15:00:40)
    23. shall be possible to re-use hvves approach to execute it as precondition in a xtesting docker (morgan_orange, 15:01:11)
    24. https://docs.onap.org/en/latest/submodules/integration.git/docs/docs_pnf_onboarding_preonboarding.html?highlight=pre%20onboarding (morgan_orange, 15:01:22)
    25. work started in Casablanca and most of the dev done for Dublin (morgan_orange, 15:01:41)


Meeting ended at 15:01:44 UTC (full logs).

Action items

  1. morgan_orange give a status to PTL during PTL meeting
  2. morgan_orange add Marcin + Krzysztof as co speaker for from robot to CI session
  3. morgan_orange contact CCVPn team to see if the link can be fixed (part of procedure so hard to remove)
  4. all brainstorm on all the basic tests we need to ensure a better coverage ONAP by dedicated tests (not by use cases)
  5. morgan_orange initiate the request to create a new repository testsuite/robot-utils
  6. morgan_orange create an Guilin Epic for this new doc and assign Marec to it
  7. morgan_orange krzysztof integrate this use case in CI Master


Action items, by person

  1. morgan_orange
    1. morgan_orange give a status to PTL during PTL meeting
    2. morgan_orange add Marcin + Krzysztof as co speaker for from robot to CI session
    3. morgan_orange contact CCVPn team to see if the link can be fixed (part of procedure so hard to remove)
    4. morgan_orange initiate the request to create a new repository testsuite/robot-utils
    5. morgan_orange create an Guilin Epic for this new doc and assign Marec to it
    6. morgan_orange krzysztof integrate this use case in CI Master


People present (lines said)

  1. morgan_orange (79)
  2. collab-meetbot (4)


Generated by MeetBot 0.1.4.