#onap-int: Integration weekly meeting 17/06/2020

Meeting started by morgan_orange at 05:26:00 UTC (full logs).

Meeting summary

  1. action point follow-up (morgan_orange, 05:26:14)
    1. AP1 morgan_orange give a status on windriver lab to PTL during PTL meeting (morgan_orange, 05:26:36)
    2. done (morgan_orange, 05:26:39)
    3. AP2 morgan_orange add Marcin + Krzysztof as co speaker for from robot to CI session (morgan_orange, 05:26:49)
    4. done, first draft of the slide deck planned for today (morgan_orange, 05:27:03)
    5. AP3 morgan_orange contact CCVPn team to see if the link can be fixed (part of procedure so hard to remove) (morgan_orange, 05:27:14)
    6. done, the section has been removed from the doc + mail exchange with CCVPN use case owner for a depper update in G version (morgan_orange, 05:28:00)
    7. AP4 all brainstorm on all the basic tests we need to ensure a better coverage ONAP by dedicated tests (not by use cases) (morgan_orange, 05:28:10)
    8. see next section (morgan_orange, 05:28:14)
    9. AP5 morgan_orange initiate the request to create a new repository testsuite/robot-utils (morgan_orange, 05:28:28)
    10. green light from TSC, procedure of self creation tried but missing rights. problem reported to Jessica, if not possible, usual way will be used (morgan_orange, 05:29:28)
    11. AP6 morgan_orange create an Guilin Epic for this new doc and assign Marec to it (morgan_orange, 05:29:40)
    12. done (morgan_orange, 05:29:43)
    13. https://jira.onap.org/browse/TEST-236 (morgan_orange, 05:30:05)
    14. AP7 morgan_orange krzysztof integrate this use case in CI Master (morgan_orange, 05:30:21)
    15. not done yet (morgan_orange, 05:30:31)
    16. ACTION: morgan_orange krzysztof integrate preonboarding use case in CI Master (morgan_orange, 05:30:46)

  2. admin (morgan_orange, 05:30:56)
    1. Windriver/Intel lab: cleaning operation planned for end of June (morgan_orange, 05:31:26)
    2. https://wiki.onap.org/display/DW/Windriver+lab+Frankfurt+cleaning+campaign (morgan_orange, 05:31:36)
    3. presentation done during PTL meeting on Monday (morgan_orange, 05:31:53)
    4. https://wiki.onap.org/display/DW/PTL+2020-06-15?preview=/84647587/84653034/Certificates_PTLmeeting_15062020.pdf (morgan_orange, 05:32:57)
    5. discussion on the resources needed for integration (morgan_orange, 05:33:44)
    6. proposal shared with integration team (morgan_orange, 05:33:59)
    7. no objection for refactoring (morgan_orange, 05:34:12)
    8. Andreas aggrees that it will be clearer (morgan_orange, 05:34:28)
    9. morgan_orange indicates that an approval is needed from Marco and Brian (morgan_orange, 05:34:45)
    10. ACTION: morgan_orange contact Marco & Brian to get their feedback on Windriver/Intel Integration resources (morgan_orange, 05:35:12)
    11. new request for resources for terraform based installation (morgan_orange, 05:35:19)
    12. https://jira.onap.org/browse/OOM-2425 (morgan_orange, 05:36:04)
    13. ACTION: morgan_orange create new project Integration-Terraform (morgan_orange, 05:36:17)
    14. patchset on oparent/cia repository but no activity on this repo since 2 years (morgan_orange, 05:36:56)
    15. proposal to archive oparent/cia (morgan_orange, 05:37:34)
    16. AGREED: (morgan_orange, 05:37:37)

  3. Frankfurt (morgan_orange, 05:38:04)
    1. CI status good since the AAF-SMS patch merge, CI criteria are OK, see Daily frankfurt reports (morgan_orange, 05:39:22)
    2. demo artifact published yesterday (morgan_orange, 05:39:33)
    3. https://nexus.onap.org/content/repositories/releases/org/onap/demo/vnf/ (morgan_orange, 05:40:28)
    4. issues with some use cases (dealing with CDS), Lukasz working on workaround (morgan_orange, 05:41:28)
    5. Lukasz reports that use case was OK for RC0 and RC1, bug fix on SO heatbridge leads to regression (morgan_orange, 05:41:56)
    6. SO heatbridge does less than the robot heatbridge and requires adaptations in the tests (morgan_orange, 05:42:29)
    7. it shows a process issue, heatbridge code has been introduced after M4 (not a simple bug fix) (morgan_orange, 05:44:13)
    8. Lukasz would have liked to have more time after RC2 (RC2 and sign-off merged) but as RC0 and RC1 were OK, no such regression was expected (morgan_orange, 05:45:51)

  4. Guilin (morgan_orange, 05:46:02)
    1. update on onapsdk by Michal (morgan_orange, 05:46:11)
    2. a presentation is planned next week during the vF2F (morgan_orange, 05:46:23)
    3. https://gitlab.com/Orange-OpenSource/lfn/onap/python-onapsdk (morgan_orange, 05:46:35)
    4. new test scenarios leveraging this SDK can be hosted in https://git.onap.org/testsuite/pythonsdk-tests/ (morgan_orange, 05:47:10)
    5. open discussion on the scenarios (morgan_orange, 05:47:32)
    6. https://etherpad.opnfv.org/p/onap_integration_onapsdk_scenarios (morgan_orange, 05:47:35)
    7. ACTION: all complete the etherpad to list possible scenarios (morgan_orange, 05:47:52)
    8. new Guilin Jira board created (morgan_orange, 05:48:18)
    9. https://jira.onap.org/secure/RapidBoard.jspa?rapidView=221&selectedIssue=INT-1268 (morgan_orange, 05:48:25)
    10. no specific filters for this board (as for frankfurt) but if needed I can recreate some filters (morgan_orange, 05:48:51)
    11. new robot pod architecture (morgan_orange, 05:49:03)
    12. testsuite/oom helm chart to be moved back to OOM (morgan_orange, 05:49:11)
    13. leveraging on new architecture proposed by Daniel Rose (3 pods: 1 robot, 1 DB, 1 web server) (morgan_orange, 05:49:18)
    14. resources needed to implement this new version of the ropot pod => proposal to keep old (testsuite/oom) and new system (oom) in // before removing the legacy one (morgan_orange, 05:50:58)
    15. new use cases (morgan_orange, 05:51:11)
    16. first try on check certificates (+ pres done for PTL) (morgan_orange, 05:51:21)
    17. https://gerrit.onap.org/r/c/integration/+/109207/2 (morgan_orange, 05:51:28)
    18. we can already see that some certificates are already no more valid, dgbuilder expired 280 days ago, refrep in 3 days and so-vnfm in 31 days (morgan_orange, 05:52:02)
    19. preonboarding, vcpe_tosca still in the loop (morgan_orange, 05:52:16)
    20. Upstream cds tests are coming (morgan_orange, 05:52:24)
    21. ACTION: trevor provide the Bell upstream suite (need to select the place and check legal issues first) (morgan_orange, 05:52:45)
    22. security test: cleaning of the xfail lists on master? (morgan_orange, 05:53:04)
    23. http enpoint => update: switch to nonssl? (morgan_orange, 05:53:16)
    24. ACTION: Pawel W confirm we can swich from http endpoint to nonsslendpoint use case (morgan_orange, 05:53:41)
    25. success criteria for the pod limit test to be defined (morgan_orange, 05:54:02)
    26. check version according to SECCOM recommentations => ask SECCOm to move their list through a file in their repo to get a gerrit reference rather than a wiki page? (morgan_orange, 05:54:13)

  5. AoB (morgan_orange, 05:54:51)
    1. ACTION: thierry/Andreas discuss onapsdk scenario structure and push first scenario in ONAP repo (morgan_orange, 05:55:23)
    2. discussion on SO/Multicloud scenario in CI chain (morgan_orange, 05:55:48)
    3. 2 options: 2 chains or reconfiguration during one chain (morgan_orange, 05:55:58)
    4. config change can be done by a modification in a configmap (no deep dive into Database needed) (morgan_orange, 05:56:11)
    5. morgan_orange precises that it is possible to create 2 stages smoke_config_so then smoke_config_multicloud in the CI chain to cover the 2 configurations (morgan_orange, 05:56:50)
    6. question on the need of an El Alto CI chain (morgan_orange, 05:57:25)
    7. morgan_orange indicates that keeping the 2 last Stable chains in CI should be the target. In Orange, El Alto was disabled to be replaced by daily frankfurt by lack of resources. (morgan_orange, 05:58:13)
    8. presentation in TSC will report such lack of resources (morgan_orange, 05:58:33)
    9. ACTION: morgan_orange contacts OOM to precise that it would be great to keep last 2 stable versions in CI (morgan_orange, 05:59:17)


Meeting ended at 05:59:21 UTC (full logs).

Action items

  1. morgan_orange krzysztof integrate preonboarding use case in CI Master
  2. morgan_orange contact Marco & Brian to get their feedback on Windriver/Intel Integration resources
  3. morgan_orange create new project Integration-Terraform
  4. all complete the etherpad to list possible scenarios
  5. trevor provide the Bell upstream suite (need to select the place and check legal issues first)
  6. Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
  7. thierry/Andreas discuss onapsdk scenario structure and push first scenario in ONAP repo
  8. morgan_orange contacts OOM to precise that it would be great to keep last 2 stable versions in CI


Action items, by person

  1. morgan_orange
    1. morgan_orange krzysztof integrate preonboarding use case in CI Master
    2. morgan_orange contact Marco & Brian to get their feedback on Windriver/Intel Integration resources
    3. morgan_orange create new project Integration-Terraform
    4. morgan_orange contacts OOM to precise that it would be great to keep last 2 stable versions in CI
  2. UNASSIGNED
    1. all complete the etherpad to list possible scenarios
    2. trevor provide the Bell upstream suite (need to select the place and check legal issues first)
    3. Pawel W confirm we can swich from http endpoint to nonsslendpoint use case
    4. thierry/Andreas discuss onapsdk scenario structure and push first scenario in ONAP repo


People present (lines said)

  1. morgan_orange (86)
  2. collab-meetbot` (4)


Generated by MeetBot 0.1.4.