#onap-meeting: ONAP F2F

Meeting started by CaseyODL at 01:38:23 UTC (full logs).

Meeting summary

  1. Release Planning (phrobb, 01:50:37)
    1. Gildas is presenting the Release Plan, and the Release Planning template (phrobb, 01:57:11)
    2. ACTION: TSC to determine if there will be a unit test code coverage for quality assurance for Release 1 (phrobb, 02:03:43)
    3. the amount of unit testing coverage is a topic of debate in the room based on our goal of Nov 2nd for a first release (phrobb, 02:05:20)
    4. Helen Chen notes that Integration will build a Template and framework for how to build tests more simply by project. Having a test coverage of 30 or 50 percent might be reassonable. Integration will also build a "bootstrap" material for new developer resources and ecnourages all projects to do the same (phrobb, 02:08:10)
    5. Chris Donley notes 3 levers for the release - Date, Scope, and quality. Date seems fixed. Scope can only go as low as "Min. viable product", so that leaves Quality to play with. We'll need to find that compromise (phrobb, 02:09:18)
    6. Gildas notes that the TSC may want to oversee that committs have an associated Jira ID, and/or specs for quality of documentation on the commit. (phrobb, 02:11:37)
    7. currently the system allows self commits (ie the contributor commit the code). (phrobb, 02:12:19)
    8. Oliver suggests that self-commits be not-allowed (phrobb, 02:12:38)
    9. the question of using checkstyle and what we make manditory for code form (phrobb, 02:14:43)

  2. Use case review (kennypaul, 02:38:07)
    1. Chris Donley, Huawei (cdonley, 02:38:21)
    2. vCPE (kennypaul, 02:39:16)
    3. Stephen Terrill, Ericsson (SteveT, 02:39:19)
    4. TSC Members please #info in as you are able to join the IRC channel. We will want to know who is online and participating so that we know we have quorum (phrobb, 02:40:01)
    5. Huabing Zhao, ZTE, speak on behalf of Zhaoxing Meng (Huabing_Zhao, 02:40:05)
    6. Xiaojun Xie, China Telecom (Xiaojun, 02:40:27)
    7. Questions from Helen Chen. We need VNFs as soon as possible to test. (phrobb, 02:46:49)
    8. there are VNF vendors that may be interested outside the ONAP community. how do we interact with them? (phrobb, 02:49:47)
    9. Oliver Spatscheck, AT&T (spatsch17, 02:59:54)
    10. https://wiki.onap.org/pages/viewpage.action?pageId=3246140 <-- V0LTE Use case wiki page (phrobb, 03:05:38)
    11. We currently have 5 TSC members on IRC. We need 10 to be able to vote here. All TSC members please #info in so that we know you are here (phrobb, 03:06:54)
    12. Lingli presented vVoLTE use cases. (SteveT, 03:08:06)
    13. Ranny Haiby, Nokia (RannyHaiby, 03:08:08)
    14. noted that open to vendors still (SteveT, 03:08:17)
    15. question from Oliver. What does approval of the use case mean. Does it mean its is gating the release. (SteveT, 03:08:42)
    16. the answer is that this was not considered as a gating, but to show that it can handle work. (SteveT, 03:09:27)
    17. someone might have problem logging in IRC. (Huabing_Zhao, 03:10:18)
    18. Gating will be more related to the what we need to put into the integration, and be availble to all developers. Need to have both. (SteveT, 03:10:42)
    19. Call from brian on the next level of detail, e.g. heat guidelines, tosca templates. How to demonstrate both (SteveT, 03:11:23)
    20. modelling project is expecting to use both. (SteveT, 03:11:56)
    21. Amir Levy GigaSpaces (amir_levy, 03:14:26)
    22. David Sauvageau Bell Canada (Dsauvageau, 03:14:45)
    23. Eric presented the vEPC proposal (which is also in the vVoLTE wiki (SteveT, 03:18:52)
    24. approach is looking to looking to use APP-C where the first presentation was using VF-C. (SteveT, 03:21:22)
    25. this use case is both the APP-C approach and the PNFs (SteveT, 03:29:23)
    26. Question is also do we group the use cases as one, or seperate. Do we allow vote on vVoLTE now and allow the vEPC to mature (SteveT, 03:31:31)
    27. Oliver, Catherine, Helen, Bryan, Erik, Lingli Stephen to create the integration project proposal (SteveT, 03:34:39)
    28. ACTION: Helen, lead the discussion to create the proposal for what we need to bring into integration (SteveT, 03:35:30)
    29. Rajesh Gadiyar (RajeshGadiyarInt, 03:36:14)
    30. are you confortable to vote on the vVoLTE use case (to TSC memebers). Yes 13 (SteveT, 03:37:31)
    31. votequestion "Shall the TSC approve the vVoLTE use case as presnefor Release 1 as presente d by lingli" (SteveT, 03:38:29)
    32. Rajesh Gadiyar intel (RajeshGadiyar, 03:42:16)
    33. vote results. 13 hands were raised in the room. plus the votes on IRC (SteveT, 03:45:04)
    34. the vote was approved (SteveT, 03:45:09)
    35. stephen requested a TSC memember to support Helen in the definition of the integration use cases that everyone can have access to, where it consideres the needs described by the demo use cases (SteveT, 03:45:58)
    36. lingli volenteered for that (SteveT, 03:46:07)
    37. TSC Members present at the Face to Face include Roberto Klung, Oliver Spatscheck (proxy for Mazin Gilbert) Alla Goldner, Stephen Terrill, Lingli Deng, Bruce Thompson (proxy for Ed Warnicke), Amir Levy, Jason Hunt, Rajesh Gadiyar, Zhaoxing Meng, Xiaojun Xie, Xinhui Li (phrobb, 03:57:25)

  3. Architecture discussion. Chris Donley provided an update on the initial formation of the architecture committee and the initial funct arch. diagram that is under discussion. He emphasizes that no firm architectural suggestions are being made yet as the group has not been together enough. (phrobb, 04:05:32)
    1. chris presented the architecture and architecture committee . It is advaisary and not a blocking issue for projects, but help to keep things together (SteveT, 04:08:39)
    2. now going through the project reviews. (SteveT, 06:06:30)

  4. CLAMP Review (CaseyODL, 06:09:28)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=4719898 (CaseyODL, 06:09:32)
    2. CLAMP will have no new APIs (JasonHunt, 06:12:32)
    3. no seen overlap between SNIRO and CLAMP (JasonHunt, 06:13:40)
    4. policies will be defined in the policy framework, and then CLAMP can pull those policy definitions to create a closed-loop (JasonHunt, 06:18:43)
    5. there are 8 TSC members in the room that vote to approve the CLAMP project (phrobb, 06:21:09)
    6. AGREED: the TSC has approved the CLAMP project as an incubation project within ONAP (phrobb, 06:21:40)
    7. VOTE: Voted on "Shall the TSC approve the CLAMP Project as an incubation project within ONAP?" Results are, +1: 5 (CaseyODL, 06:21:52)
    8. AGREED: the TSC has approved the CLAMP project as an incubation project within ONAP (CaseyODL, 06:22:11)

  5. VF-C (kennypaul, 06:22:26)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246989 (kennypaul, 06:22:32)
    2. request to add a note to clarify that that the "S-VNFM drivers"/"plugins" are not part of the VF-C project deliverables. (SteveT, 06:35:15)
    3. discussion about differences in lifecycle management when using APP-C vs VF-C. (JasonHunt, 06:41:47)
    4. proposal to provisionally approve pending on architecture committee (SteveT, 06:42:31)
    5. if doing a provisional approval, the provisional approval has to be very clear. and it means that act as if approval was required. (SteveT, 06:47:42)
    6. proposal in this case was that the provisional approval is "provisional on the conclusions of the architecture discussion do not change the scope of the VF-C" (SteveT, 06:49:03)
    7. VOTE: Voted on "Shall the TSC approve the VF-C Project as an incubation project within ONAP provisional on alignment with the overall architecture if such dependencies are identified?" Results are, 0: 1, +1: 2 (phrobb, 06:50:47)
    8. vote approved 14 TSC members also approved (SteveT, 06:51:30)

  6. ONAP Operations Manager (kennypaul, 06:52:20)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246809 (kennypaul, 06:52:27)
    2. question whether this also depoloys onap as a single node; the answer was yes (SteveT, 07:04:01)
    3. there is release code available (SteveT, 07:04:23)
    4. VOTE: Voted on "Shall the TSC approve the Operations Manager project as an Incubation project within ONAP?" Results are, +1: 4 (phrobb, 07:10:15)
    5. according to the vote in the room, the vote is passed (SteveT, 07:10:35)
    6. 10 TSC members voted in favor in the room (JasonHunt, 07:10:53)
    7. https://wiki.onap.org/display/DW/VNF+SDK (kennypaul, 07:11:26)
    8. clarified that "VNF validation" means just the first level of validation (JasonHunt, 07:16:55)
    9. will work with the modeling project to handle the packaging (ala CSAR file, etc.) (JasonHunt, 07:17:57)
    10. clarifying that this project is a test framework with code from Open-O and ICE (AT&T), but logo validation criteria are not in scope for this project. (JasonHunt, 07:21:53)
    11. 12 TSC members voted in favor in the room (JasonHunt, 07:23:02)
    12. VOTE: Voted on "Shall the TSC approve the VNF-SDK project as an incubation project within ONAP?" Results are, +1: 2 (phrobb, 07:23:08)
    13. https://wiki.onap.org/pages/viewpage.action?pageId=3247262 (kennypaul, 07:23:49)
    14. Question: is this for more than different variants of openstack. The answer is yes, but over time (SteveT, 07:35:32)
    15. 11 TSC members in the room voted in favor (JasonHunt, 07:43:24)
    16. VOTE: Voted on "Shall the TSC approve the MultiVIM/Cloud Project as an incubation project within ONAP?" Results are, +1: 2 (phrobb, 07:46:35)
    17. https://wiki.onap.org/pages/viewpage.action?pageId=3246935 (kennypaul, 07:47:08)
    18. 12 TSC members in the room voted in favor (JasonHunt, 07:54:23)
    19. VOTE: Voted on "Shall the TSC approve the SDC project as an incubation project within ONAP?" Results are, +1: 1 (phrobb, 07:54:23)
    20. https://wiki.onap.org/pages/viewpage.action?pageId=3246982 (kennypaul, 07:54:46)
    21. voted in room 10 +1 (kennypaul, 08:14:10)
    22. voted in room 10 +1 (kennypaul, 08:15:00)
    23. AGREED: the TSC approved the MSB project as an incubation project within ONAP (kennypaul, 08:15:49)

  7. VID (kennypaul, 08:16:50)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=5735532 (kennypaul, 08:17:03)
    2. voted in room 12 +1 (kennypaul, 08:39:22)
    3. VOTE: Voted on "Shall the TSC approve the VID project as an incubation project within ONAP?" Results are, +1: 1 (phrobb, 08:39:32)
    4. AGREED: the TSC approves the VID project as an incubation project within ONAP (kennypaul, 08:40:03)

  8. External System Register (kennypaul, 08:40:19)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=5734948 (kennypaul, 08:40:38)
    2. proposal to have ESR as a subproject of A&AI. (kennypaul, 08:50:31)
    3. swapping A&AI review timeslot with the Integration project to provide additional time to discuss. (kennypaul, 08:52:48)

  9. ONAP CLI (kennypaul, 08:57:17)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246889 (kennypaul, 08:57:20)
    2. ESR vote is deferred until after ESR and A&AI have a chance to discuss their relationship, and deliverables resolving overlaps. (phrobb, 08:59:26)
    3. voted in room 12 +1 (kennypaul, 09:10:16)
    4. VOTE: Voted on "Shall the TSC approve the ONAP CLI project as an incubation project within ONAP?" Results are (phrobb, 09:10:25)
    5. AGREED: the TSC approves the ONAP CLI project as an incubation project within ONAP (kennypaul, 09:11:03)

  10. ONAP Usecase UI (kennypaul, 09:11:21)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3247207 (kennypaul, 09:11:43)
    2. voted in room 11 + (kennypaul, 09:28:26)
    3. VOTE: Voted on "Shall the TSC approve the Usecase UI project as an incubation project within ONAP?" Results are (phrobb, 09:28:27)
    4. that was 11 +1 (kennypaul, 09:28:50)
    5. AGREED: the TSC approves the Usecase UI project as an incubation project within ONAP (kennypaul, 09:29:20)

  11. Holmes (kennypaul, 09:29:32)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=5734499 (kennypaul, 09:29:43)
    2. vote one Holmes deferred pending more discussion. (kennypaul, 09:55:14)

  12. portal platform (kennypaul, 09:55:28)
    1. (kennypaul, 09:55:31)
    2. https://wiki.onap.org/pages/viewpage.action?pageId=3247211 (kennypaul, 09:55:37)
    3. voted in room 13 +1 (kennypaul, 10:08:48)
    4. VOTE: Voted on "Shall the TSC approve the Portal Platform project as an incubation project within ONAP?" Results are (phrobb, 10:08:57)
    5. AGREED: the TSC approves the Portal Platform project as an incubation project within ONAP (kennypaul, 10:09:26)

  13. Policy framework (kennypaul, 10:09:58)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=3246903 (kennypaul, 10:10:04)
    2. policy project was approved, 10 votes in teh room (SteveT, 10:40:28)
    3. VOTE: Voted on "Shall the TSC approve the Policy Framework project as an incubation project within ONAP?" Results are (phrobb, 10:41:03)

  14. Integration Project (kennypaul, 10:52:14)
    1. https://wiki.onap.org/pages/viewpage.action?pageId=4718718 (kennypaul, 10:52:39)
    2. voted in room 11+1 (kennypaul, 11:02:18)
    3. AGREED: the TSC approves the Integration Project as an incubation project within ONAP conditional on revisiting the scope along with the Open Lab discussion and clarification of the end to end testing (kennypaul, 11:05:43)
    4. VOTE: Voted on "Shall the TSC approve the Integration Project as an incubation project within ONAP conditional on revisiting the scope along with the Open Lab discussion and clarification of the end to end testing?" Results are (phrobb, 11:08:50)


Meeting ended at 11:08:58 UTC (full logs).

Action items

  1. TSC to determine if there will be a unit test code coverage for quality assurance for Release 1
  2. Helen, lead the discussion to create the proposal for what we need to bring into integration


People present (lines said)

  1. collabot` (54)
  2. kennypaul (53)
  3. phrobb (52)
  4. SteveT (45)
  5. JasonHunt (35)
  6. Dsauvageau (12)
  7. CaseyODL (8)
  8. Huabing_Zhao (4)
  9. amir_levy (4)
  10. RajeshGadiyarInt (3)
  11. RajeshGadiyar (3)
  12. RannyHaiby (2)
  13. cdonley (2)
  14. spatsch17 (2)
  15. Xiaojun (2)
  16. bhedstrom (1)
  17. RichB (1)
  18. xinhuili_ (1)


Generated by MeetBot 0.1.4.