#onap-meeting: Amsterdam M1 Review #2

Meeting started by kennypaul at 13:50:38 UTC (full logs).

Meeting summary

    1. Ranny Haiby, Nokia (RannyHaiby, 14:01:01)
    2. Jason Hunt, IBM (JasonHunt, 14:01:17)
    3. Xiaojun Xie, China Telecom (Xiaojun, 14:01:47)
    4. Huabing Zhao on behalf of Zhaoxing Meng, ZTE (Huabing_Zhao, 14:02:22)
    5. stephen terrill, Ericsson (SteveT, 14:02:36)
    6. Alla Goldner, Amdocs (alla, 14:03:57)
    7. Lingli Deng, China Mobile (Lingli_Deng, 14:05:09)
    8. Chris Donley, Huawei (cdonley, 14:05:10)
    9. Xinhui Li, VMware (xinhuili, 14:05:59)
    10. simple voice vote (kennypaul, 14:07:44)
    11. approval considered to be granted if no objections (kennypaul, 14:08:14)

  1. modeling (kennypaul, 14:08:28)
    1. Sonu covering for Rajesh from Intel (Sonu, 14:09:30)
    2. concerns over the number of committers (kennypaul, 14:11:34)
    3. if a committer is also a code contributor that person's name should be in both locations (kennypaul, 14:13:22)
    4. a committer should not be committing their own code. (kennypaul, 14:14:01)
    5. the code for this is already very mature (kennypaul, 14:14:40)
    6. Deng recommends waiting until code freeze to lock down committers (kennypaul, 14:17:33)
    7. discussion over "parser" definition (kennypaul, 14:19:48)
    8. AGREED: w/ contingency of clarification of committers and resource allocation updates (kennypaul, 14:22:58)

  2. Service Orchestrator (kennypaul, 14:23:23)
    1. (JasonHunt) "The risk with committers signing up on their own is that they have the power to commit code. Typically, you have to demonstrate your technical credentials and contributions before being named a committer. If I were a project lead, that would concern me." (kennypaul, 14:24:05)
    2. (Jamil) "Committer should deliver code" (kennypaul, 14:24:40)
    3. (Seshu) TBDs in the checklist are pending a meeting- not concerned with ability to complete (kennypaul, 14:28:23)
    4. (Helen) A committer should be a contributor, plus a committer has right to review other's code. (helenychen, 14:28:46)
    5. same contingency on resource allocation (kennypaul, 14:30:05)
    6. discussion of proposals w/ architecture committee (kennypaul, 14:30:48)
    7. AGREED: review approved w/ contingency (kennypaul, 14:31:16)

  3. Multi VIM/Cloud (kennypaul, 14:31:58)
    1. ACTION: in PTL meeting need to follow up on API risks (kennypaul, 14:37:36)
    2. team has agreement w/ APPC but not with DCAE yet (kennypaul, 14:38:04)
    3. potential misunderstandings can be made worse with many committers (kennypaul, 14:40:36)
    4. ACTION: add risk section to checklist (kennypaul, 14:42:13)
    5. in addition to weekly PTL meeting suggest assigning roles for xfunc coordination (kennypaul, 14:44:11)
    6. AGREED: with contingency on resource allocation and action of risk section (kennypaul, 14:45:11)

  4. CLI (kennypaul, 14:46:01)
    1. need updates to inbound APIs (kennypaul, 14:46:22)
    2. ACTION: -gildas review commit/code review best practices at the PTL meeting (kennypaul, 14:51:40)
    3. AGREED: Review approved (kennypaul, 14:51:52)

  5. Integration (kennypaul, 14:52:25)
    1. need to clarify what testing is covered in Amsterdam (kennypaul, 14:54:42)
    2. testing for vCPE and VoLTE use cases but not Demos (kennypaul, 14:56:29)
    3. discussion over responsibility for owning the Demos. (kennypaul, 14:57:06)
    4. would like updates on progress of automation (kennypaul, 15:00:40)
    5. Helen would like to see better defined committer criteria from TSC (kennypaul, 15:03:27)
    6. ACTION: gildas take issue of Demos to TSC (kennypaul, 15:03:49)
    7. AGREED: Review Approved (kennypaul, 15:04:08)

  6. CCSKD (kennypaul, 15:04:40)
    1. docker can be removed from the list of API dependenies (kennypaul, 15:06:16)
    2. AGREED: Review Approved (kennypaul, 15:07:04)

  7. Documentation (kennypaul, 15:08:19)
    1. using 3 repos versus an umbrella project approach (kennypaul, 15:15:48)
    2. (Lingli) need to formalize the self-committer policy (kennypaul, 15:18:57)
    3. AGREED: Review approved (kennypaul, 15:19:06)

  8. External API Framework (kennypaul, 15:19:48)
    1. https://wiki.onap.org/display/DW/Committer+Best+Practices (kennypaul, 15:22:28)
    2. above related to committer best practices (kennypaul, 15:22:51)
    3. AGREED: Review approved (kennypaul, 15:23:06)

  9. ONAP Operations Manager (kennypaul, 15:24:18)
    1. Release Deliverables - defined, but not linked to the page yet. (kennypaul, 15:25:42)
    2. need better understanding of roll back capabilities (kennypaul, 15:27:48)
    3. ACTION: PTL fill in check list. (kennypaul, 15:29:01)
    4. roll back will need joint testing (kennypaul, 15:30:51)
    5. AGREED: Review Approved w/ contingency on resource allocation and checklist (kennypaul, 15:31:58)

  10. follow up reviews from last review (kennypaul, 15:35:27)
    1. (Hui Deng) concerns over violations to charter by paring down committer list. (kennypaul, 15:37:49)
    2. (Chris D) PTL should ask committers to voluntarily step down (kennypaul, 15:38:30)
    3. (Helen C) if no one steps down, then what? (kennypaul, 15:39:10)
    4. (Chris D) can take a vote among committers once there is experience w/ the team (kennypaul, 15:40:38)

  11. Project Review of Network Function Change Management proposal (kennypaul, 15:43:53)
    1. this would be an end-to-end across all projects- more logical as a Subcommittee (kennypaul, 15:44:40)
    2. OR as a usecase for Beijing release (kennypaul, 15:45:33)
    3. project proposal will be withdrawn (kennypaul, 15:48:13)


Meeting ended at 15:48:44 UTC (full logs).

Action items

  1. in PTL meeting need to follow up on API risks
  2. add risk section to checklist
  3. -gildas review commit/code review best practices at the PTL meeting
  4. gildas take issue of Demos to TSC
  5. PTL fill in check list.


People present (lines said)

  1. kennypaul (74)
  2. collabot` (9)
  3. Jamil (2)
  4. alla (2)
  5. JasonHunt (2)
  6. Sonu (2)
  7. Xiaojun (1)
  8. Huabing_Zhao (1)
  9. xinhuili (1)
  10. SteveT (1)
  11. cdonley (1)
  12. helenychen (1)
  13. RannyHaiby (1)
  14. Lingli_Deng (1)
  15. phrobb (0)
  16. gildaslanilis (0)
  17. CaseyODL (0)


Generated by MeetBot 0.1.4.