#onap-meeting: Amsterdam M4 Review

Meeting started by phrobb at 08:18:48 UTC (full logs).

Meeting summary

  1. Roll Call (phrobb, 08:19:06)
    1. TSC Members Please #info In (phrobb, 08:19:35)
    2. VFC passes the M4 review (phrobb, 08:22:41)
    3. AGREED: the VFC project has passed the M4 Milestone (phrobb, 08:23:06)

  2. UI (phrobb, 08:25:42)
  3. Use Case UI (phrobb, 08:28:01)
    1. from zoom chat: From shentao to All panelists: (10:36 AM) (kennypaul, 08:41:57)
    2. A vote was held asking Shall the TSC approve to remove any non-gating Project contingent on the Release Manager not being able to validate that all M4 requirements have been met by Monday 5:00pm PDT Oct. 2nd (phrobb, 08:50:25)
    3. the vote passed with 11 votes (phrobb, 08:50:41)
    4. AGREED: by consensus that Use Case UI has not passed M4 (phrobb, 08:51:14)
    5. AGREED: the CLI project has passed M4 (phrobb, 08:52:24)
    6. AGREED: the CLAMP project has passed M4 (phrobb, 08:52:52)
    7. A&AI - A gating project (phrobb, 08:53:19)
    8. AGREED: A&AI passes M4 under the condition that the outstanding CSIT tests are fixed by RC0 (phrobb, 08:54:20)
    9. CCSDK (phrobb, 08:54:59)
    10. CCSDK passes M4 (phrobb, 08:58:42)
    11. AGREED: CCSDK passes M4 under the condition that the project has ReadTheDoc structure by Monday and 30% code coverage by 5pm PDT Monday Oct. 2 (phrobb, 09:02:58)
    12. to reiterate, non gating projects that don't pass M4 by 5pm Monday PDT will be dropped. Gating project that don't pass by then will be closely evaluated to determine the best course for the Amsterdam project (phrobb, 09:05:17)
    13. SDNC (phrobb, 09:07:00)
    14. AGREED: SDNC passes M4 under condition that all their M4 deliverables are met by Monday 5pm PDT (phrobb, 09:09:12)
    15. AGREED: DCAE passes M4 (phrobb, 09:11:22)
    16. Logging Enhancements (phrobb, 09:11:43)
    17. AGREED: Logging Enhancement passes M4 under the condition that they meet all M4 requirements by Monday at 5pm PDT (phrobb, 09:15:35)
    18. SO (phrobb, 09:15:42)
    19. SO had a large code drop from MSO 2 week ago with reduced their sonar code coverage from 25% to 12%. The code coverage needs to be 30% as per M4 requirements (phrobb, 09:21:20)
    20. AGREED: SO does not pass M4 (phrobb, 09:27:00)
    21. Policy (phrobb, 09:27:34)
    22. AGREED: SO passes conditional on having all M4 deliverables completed by Monday 5pm PDT (phrobb, 09:30:02)
    23. Integration (phrobb, 09:30:58)
    24. AGREED: the Integration project passes M4 (phrobb, 09:31:42)
    25. MultiVIMCloud (phrobb, 10:36:28)
    26. AGREED: MultiVIM Cloud passes M4 (phrobb, 10:37:53)
    27. SDC (phrobb, 10:41:15)
    28. AGREED: SDC passes M4 conditional on their ReadTheDocs being in place by Monday 5pm PDT (phrobb, 10:42:02)
    29. MSB (phrobb, 10:43:33)
    30. MSB passes M4 conditional on sufficient code coverage verified by 5pm Monday PDT (phrobb, 10:47:03)
    31. VVP (phrobb, 10:47:46)
    32. The project has been behind. It recently brought seed code forward and is awaiting inbound activities from the Linux Foundation. (phrobb, 10:56:31)
    33. VVP is independent from the rest of the ONAP release (phrobb, 10:56:55)
    34. AGREED: that VVP is dropped from the Amsterdam release but the TSC will continue to monitor progress to understand when they will be distributing (phrobb, 10:57:41)
    35. APPC (phrobb, 10:58:00)
    36. AGREED: APPC passes M4 (phrobb, 10:58:34)
    37. VNF Requirements (phrobb, 10:59:30)
    38. AGREED: VNF Requirements passes M4 - It also is not directly tied to the rest of the ONAP Amsterdam release (phrobb, 11:06:45)
    39. Portal (phrobb, 11:06:56)
    40. Portal passes M4 conditional on ReadTheDocs being in place and Sonar updated by 5pm PDT Monday (phrobb, 11:11:15)
    41. OOM (phrobb, 11:11:23)
    42. The OOM Project passes M4 (phrobb, 11:33:59)
    43. much discussion on releasing OOM based on the limited testing the project will recieve in integration. We may need to mark OOM as "experimental" or "developer only" type of release so it can be accessible but clearly indicated as not fully tested (phrobb, 11:35:31)
    44. DMAAP (phrobb, 11:35:41)
    45. project is short on code coverage and estimates they will be at 30% on Oct. 5th. (phrobb, 11:37:27)
    46. DMAPP passes M4 conditional on having code coverage to 30% by Monday 5pm PDT - if not met, status to be provided (phrobb, 11:41:34)
    47. AAF (phrobb, 11:41:39)
    48. AAF does not pass M4 and needs to provide code coverage by Monday at 5pm PDT or the project will be dropped from the release (phrobb, 11:42:32)
    49. Modelling (phrobb, 11:42:40)
    50. Modelling project is depended upon by VFC (phrobb, 11:49:32)
    51. hence the Modelling project is proposed as an MVP project (phrobb, 11:50:31)
    52. we also learned there are 4 tosca parsers being used in Amsterdam. (phrobb, 11:52:57)
    53. ACTION: Chris Donley volunteered to facilitate a discussion across the projects to consolidate their tosca parser usage (phrobb, 11:53:30)
    54. Modelling is now identified as an MVP project (phrobb, 11:53:50)
    55. VID (phrobb, 11:54:03)
    56. Modelling passes M4 conditional on their satisfying the M4 criteria by Monday 5PM (phrobb, 11:54:47)
    57. VID (phrobb, 11:54:55)
    58. VID does not yet pass M4., They need to satisfy test code coverage and docs requirements by Monday 5pm or they will need to be monitored closely until M4 complete' (phrobb, 11:56:15)
    59. Doc Project (phrobb, 11:56:27)
    60. Doc project passes M4 (phrobb, 11:56:54)
    61. Homes (phrobb, 11:57:09)
    62. AGREED: Holmes passes M4 (phrobb, 11:57:44)
    63. API (phrobb, 11:57:56)
    64. External API project will only deliver documentation for Amsterdam (phrobb, 12:00:42)
    65. AGREED: External API project passes M4 with a doc only deliverab le (phrobb, 12:01:10)
    66. VNF SDK (phrobb, 12:01:18)
    67. AGREED: VNF SDK passes M4 (phrobb, 12:01:53)


Meeting ended at 14:43:46 UTC (full logs).

Action items

  1. Chris Donley volunteered to facilitate a discussion across the projects to consolidate their tosca parser usage


People present (lines said)

  1. phrobb (77)
  2. collabot` (5)
  3. kennypaul (4)
  4. rajeshgadiyar (2)
  5. SteveT (0)


Generated by MeetBot 0.1.4.