#onap-meeting: tsc 2017-01-11

Meeting started by kennypaul at 13:55:21 UTC (full logs).

Meeting summary

  1. rollcall (kennypaul, 13:55:41)
    1. Alla Goldner, Amdocs (alla_, 13:58:05)
    2. Frank Brockners (frankbrockners, 14:00:24)
    3. Amir Levy Cloudify (amir_levy, 14:00:28)
    4. Chris Donley Huawei (cdonley, 14:00:48)
    5. Ranny Haiby, Nokia (RannyHaiby, 14:00:49)
    6. Rajesh Gadiyar Intel (rajeshgadiyar, 14:01:21)
    7. jamil for Orange (jamil, 14:02:40)
    8. xinhui li, VMware (xinhuili, 14:02:42)
    9. Jason Hunt, IBM (JasonHunt, 14:02:43)
    10. Ning So, Reliance Jio (ningso, 14:03:08)
    11. mazin (gilbert, 14:03:54)
    12. Lingli Deng, CMCC (kennypaul, 14:03:58)
    13. Zhaoxing Meng, ZTE (Zhaoxing, 14:04:12)
    14. Stephen Terrill, Ericsson (SteveT, 14:06:07)

  2. Security recommendations (kennypaul, 14:09:05)
  3. Security Subcommittee Readout (phrobb, 14:09:07)
    1. SteveT explains the static scanning and the build-time dependency scanning that is possible (phrobb, 14:10:37)
    2. 2 proposals for each of these types of scanning (phrobb, 14:11:04)
    3. for Static scanning, the committee recommends Coverity. It looks to be good enough to begin with for the project. The recommendation is to have a weekly scan via Coverity and the result will be provided to the PTLs (phrobb, 14:12:11)
    4. the committee needs help from LF to deliver scan reports to PTLs (phrobb, 14:12:53)
    5. Dhananjay Pavgi, Tech Mahindra (DhananjayPavgi, 14:14:05)
    6. New release cycle requirements - M3 No high level vulnterabilities and M4 No high or medium level vulnerabilities (phrobb, 14:14:06)
    7. discussion over whether to start scans w/ Amsterdam or Beijing (kennypaul, 14:21:57)
    8. request is also for LF to integrate coverity scan into ci/cd (kennypaul, 14:23:31)
    9. administration will be required on the part of the community (kennypaul, 14:24:01)
    10. Susana Sabater, Vodafone (Susana_, 14:24:28)
    11. ACTION: kennypaul submit ticket for coverity scanning (kennypaul, 14:24:44)
    12. request for nexus-iq scanning be made available to the PTLs (kennypaul, 14:25:56)
    13. LF ready to open the reports to PTLs (kennypaul, 14:26:47)
    14. AGREED: the requests outlined in the presentation materials will be adopted (kennypaul, 14:29:35)
    15. request the LF will check on the ability to open up nexus to community. (kennypaul, 14:33:46)
    16. request ability for community to make manual runs (kennypaul, 14:34:27)
    17. ACTION: Pam to submit a ticket, cc kenny and phil (kennypaul, 14:35:22)

  4. Release Status (kennypaul, 14:35:49)
    1. gildaslanilis reviewed his slides (kennypaul, 14:36:16)
    2. https://wiki.onap.org/display/DW/Beijing+Release+Platform+Maturity (kennypaul, 14:39:46)
    3. ACTION: PTLS for projects that have not updated above link must provide status by toimorrow. (kennypaul, 14:41:06)
    4. nagaraja sr, Infosys (nagu, 14:42:29)
    5. discussion of Music project (kennypaul, 14:46:09)
    6. does project proposal align with OOM. (kennypaul, 14:46:57)
    7. There is overlap w/ OOM (kennypaul, 14:48:03)
    8. key players on OOM are unavailable (kennypaul, 14:55:09)
    9. certificate and secret management agreed to be part of AAF (kennypaul, 14:59:16)
    10. integration team blocked by a couple of bugs (kennypaul, 14:59:39)
    11. ACTION: meeting w/ following people regarding music/oom (kennypaul, 15:01:20)
    12. m.a.choquette@bell.ca

david.sauvageau@bell.ca Roger.Maitland@amdocs.com

Mike.Elliott@amdocs.com Mandeep.Khinda@amdocs.com

frank.obrien@amdocs.com alla.goldner@amdocs.com

gildas.lanilis@huawei.com (kennypaul, 15:01:44)

  5. Functional Requirements (kennypaul, 15:03:26)
    1. Alla Goldner reviewed the slides (kennypaul, 15:03:50)
    2. (OOM/Music) Also jh245g@att.com for meeting (kennypaul, 15:05:28)
    3. HFA in best shape (kennypaul, 15:06:53)
    4. likely 3-4 will be ready by next week. (kennypaul, 15:11:07)
    5. focusing efforts on those (kennypaul, 15:11:30)
    6. likely requirements are HPA, Change Management, Auto scaling, Manul scaling, PNF (kennypaul, 15:13:56)

  6. integrtation (kennypaul, 15:14:40)
    1. bl;ocked as mentioned before (kennypaul, 15:14:54)

  7. Arch recommendations (kennypaul, 15:15:54)
    1. cdonley reviewed the slides (kennypaul, 15:16:37)
    2. #info asking teams to focus on documentation of apis (kennypaul, 15:18:33)
    3. standardise on swagger for api doc (kennypaul, 15:19:15)
    4. asking teams to standard on console for kv stores (kennypaul, 15:21:43)
    5. use common libs & services (kennypaul, 15:22:35)
    6. arch team will review progress @ M3 (kennypaul, 15:23:43)
    7. Meeting for OOM and Music is scheduled to meet on Jan 11 for 11 am PST zoom ID: 22 29 35 56 44 (gildaslanilis, 15:23:46)
    8. few outstanding components for containers, but all in containers is the goal (kennypaul, 15:25:03)
    9. chris is expecting teams will have a few jira tickets opened as part of M1 delivery. (kennypaul, 15:26:55)
    10. M1 template will be modified going forward. (kennypaul, 15:27:49)

  8. upcoming meetings (kennypaul, 15:31:39)
    1. next week's meeting till be 2 hrs to accomodate M1 reviews (kennypaul, 15:33:02)
    2. all PTLs or a proxy are required next week (kennypaul, 15:33:28)
    3. SteveT project scope to be moved to jan 25. (kennypaul, 15:34:13)


Meeting ended at 15:34:20 UTC (full logs).

Action items

  1. kennypaul submit ticket for coverity scanning
  2. Pam to submit a ticket, cc kenny and phil
  3. PTLS for projects that have not updated above link must provide status by toimorrow.
  4. meeting w/ following people regarding music/oom


Action items, by person

  1. kennypaul
    1. kennypaul submit ticket for coverity scanning
  2. UNASSIGNED
    1. Pam to submit a ticket, cc kenny and phil
    2. PTLS for projects that have not updated above link must provide status by toimorrow.
    3. meeting w/ following people regarding music/oom


People present (lines said)

  1. kennypaul (53)
  2. phrobb (6)
  3. frankbrockners (4)
  4. collabot (4)
  5. jamil (1)
  6. nagu (1)
  7. gildaslanilis (1)
  8. ningso (1)
  9. amir_levy (1)
  10. DhananjayPavgi (1)
  11. JasonHunt (1)
  12. xinhuili (1)
  13. SteveT (1)
  14. Susana_ (1)
  15. cdonley (1)
  16. rajeshgadiyar (1)
  17. gilbert (1)
  18. RannyHaiby (1)
  19. alla_ (1)
  20. Zhaoxing (1)


Generated by MeetBot 0.1.4.