#onap-meeting: tsc-2018-03-22
Meeting started by kennypaul at 13:43:12 UTC
(full logs).
Meeting summary
- rollcall (kennypaul, 13:43:51)
  - Stephen Terrill, Ericsson (SteveT,
    13:56:48)
 
  - Rajesh Gadiyar Intel (RajeshGadiyar,
    13:59:51)
 
  - Chris Donley, Huawei (cdonley,
    14:00:35)
 
  - Xinhui Li, VMware (xinhuili,
    14:01:05)
 
  - Susana Sabater, Vodafone (Susana,
    14:01:09)
 
  - Jason Hunt for IBM (unable to join the IRC
    session today) (phrobb,
    14:02:56)
 
  - Ildiko Vancsa, OpenStack Foundation
    (ildikov,
    14:03:10)
 
  - Lingli Deng, China Mobile (Lingli_Deng,
    14:03:19)
 
  - Ranny Haiby, Nokia (RannyHaiby,
    14:03:23)
 
  - Giles Heron, Cisco (proxy for Frank
    Brockners) (gilesheron,
    14:03:37)
 
 
- General Info (SteveT, 14:05:20)
  - ONAP recieved blackduck Open Source Rookie of
    the year. (SteveT,
    14:05:42)
 
  - proxy Sanchita Pathak, TechMahindra
    (Sanchita,
    14:05:54)
 
  - Trying to do one physical F2F a quater.
    (SteveT,
    14:06:20)
 
  - David Sauvageau, Bell (davidsauvageau,
    14:06:39)
 
  - Zhaoxing Meng, ZTE (Zhaoxing_Meng,
    14:09:14)
 
  - proxy Yoav Kluger (Amdocs) (kennypaul,
    14:09:16)
 
  - proxy Brian Freeman at&t (Brianfreeman,
    14:09:54)
 
  - discussion of aligning F2F to release
    calendar (kennypaul,
    14:12:50)
 
  - Discussion on whether to have a Virtual
    developers event.  Different views were expressed, however there was
    gravity towards aligning the meetings around project
    milestones. (SteveT,
    14:13:23)
 
  - Request to avoid having M4 around the
    F2F. (SteveT,
    14:13:56)
 
 
- Invitation for Cross Colloboration, Ildikó Váncsa, technical lead, open stack foundation. (SteveT, 14:15:29)
  - Ildiko presented some of the existing
    colloborations they had.  Special call out for testing, highlighting
    openstack and OPNFV XCI (testing while developing, not waiting for
    the stable release), and others.  Highlighted Interperability, HA
    and robustness testing. (SteveT,
    14:22:22)
 
  - suggested areas for colloboration as well
    around cloud edge computing. (SteveT,
    14:22:44)
 
  - Referred also to ETSI NFV collaboration as
    standards - Opensource collaboration (SteveT,
    14:27:27)
 
  - Ildikó is attending ONS next week and is open
    for any discussion. (SteveT,
    14:28:22)
 
  - There was a question whether there was a
    representation (graph) on the existing colloborations. (SteveT,
    14:34:00)
 
  - The slides will be on the TSC meeting agenda
    wiki for today. (SteveT,
    14:36:08)
 
 
- Release Status, Gildas Lanilis. (SteveT, 14:36:18)
  - M4 Review is next week.  Request to PTLs to
    have the M4 template filled in by Tuesday COB March 27 (SteveT,
    14:37:24)
 
  - Code coverage.  70+ repos reached 50% target.
    15 b/n 0-50%, but 13 reporting 0 testing linecoverage. (SteveT,
    14:38:41)
 
  - REquest to fill in the vulnerability Thread
    Report.  Note, also this will be used in the release note.  Request
    to use the latest component, and also do some pruning. (SteveT,
    14:42:43)
 
  - Preventing self commit is check restriction is
    now implemented. (SteveT,
    14:43:07)
 
  - If there are no critical security issues, no
    need to fill out the template. (SteveT,
    14:46:23)
 
  - ptl self-commit vote did not pass. (kennypaul,
    14:50:47)
 
  - Votes needed to pass: 10, Votes cast: 11, Votes
    in favor: 7, Votes against: 4, Abstentions: 8 (kennypaul,
    14:51:19)
 
  - Identified Risks.  CII Badging.  For beijing
    release, focus on Critical known vulnerabilities.  This may have the
    consequence of some projects not reaching 100% passing for CII
    passing, but 95%. (SteveT,
    14:51:45)
 
  - Risk 2, DM modelling implications on SDC. Risk
    is still there but progress is being made. (SteveT,
    14:54:47)
 
  - https://wiki.onap.org/display/DW/Beijing+Risks
    (kennypaul,
    14:55:10)
 
  - Risk 3, Risk of late delivery of Nitrogon.
    APP-C has nitrogen and is working with it.  Progressing, but still a
    risk. (SteveT,
    14:55:55)
 
  - Risk 4 late delivery of AAF.  APP-C has a early
    delivery this.  Risk is medium, PTL is confident though.
    (SteveT,
    14:56:45)
 
  - risk 5 Large code merge in SO.  The code merge
    is done, now working on code coverage.  PTL confident. (SteveT,
    14:57:41)
 
  - risk 7 A solution is proposed for secure
    communication, still need to see how integration has access to a
    CA (SteveT,
    15:01:23)
 
  - risk 8 OOM, large code drop and late commits
    comming at the end.  Expect that updates are to be required after
    code freeze. (SteveT,
    15:04:00)
 
  - Request to inform OOM of changes to container
    strategy to be taken into account at M3. (SteveT,
    15:07:40)
 
  - risk 9 OOM/Heat - docker image download
    throttling causing timeouts.  Suggestion to write up a best practice
    as a work-around. (SteveT,
    15:10:12)
 
  - risk 10  VNF requirements - Trying to identify
    what are testable, still open. (SteveT,
    15:13:50)
 
 
- Multi VIM/Cloud R2 delivery risk (SteveT, 15:15:01)
  - R2 muti VIM/Cloud deliver has been blocked by
    "-2" (SteveT,
    15:15:33)
 
  - Vote was held with majority pass; following the
    TSC charter.    The question is about removing the -2 in
    gerrit. (SteveT,
    15:17:45)
 
  - Technicality now on how to remove the -2.
    Request to see if the committer can remove the -2. (SteveT,
    15:22:07)
 
 
- Beijing Architecture (SteveT, 15:23:30)
  - https://wiki.onap.org/display/DW/Beijing+Architecture
    (kennypaul,
    15:23:57)
 
  - question was raised about the overlap between
    VID and the UC UI.   It was replied that this was required for short
    term, but the teams are talking.  It was said that this should now
    be put on the backlog of the architecture team. (SteveT,
    15:25:06)
 
  - phrobb votes +1 for Jason Hunt of IBM
    (phrobb,
    15:27:00)
 
  - my vote proxy for Yoav Kluger (Amdocs)
    (kennypaul,
    15:27:23)
 
  - VOTE: Voted on "Does
    the TSC approve the ONAP Beijing Architecture v2.0.3?" Results are,
    +1: 10 (kennypaul,
    15:28:36)
 
  - gildaslanilis votes +1 for Lingli Deng of China
    Mobile (phrobb,
    15:28:59)
 
  - AGREED: the TSC
    approves the ONAP Beijing Architecture v2.0.3 (kennypaul,
    15:29:34)
 
 
- New Seed Code (SteveT, 15:31:11)
  - SDC, monitoring design.  Minor impact on
    clamp. (SteveT,
    15:31:29)
 
  - not supporting any MVP features.  Planed to use
    it for the close loop. (SteveT,
    15:32:04)
 
  - The purpose is to make it available for people
    to understand the capabilities, and its a stretch code.  It is
    stated that it won't risk the other activities. (SteveT,
    15:34:19)
 
  - Requesting a new committer to come with
    it. (SteveT,
    15:34:53)
 
  - This discussion will move to the
    mail-list (SteveT,
    15:36:19)
 
 
- Casablanca branch (SteveT, 15:37:07)
  - Request to start branch for CAsablanca for
    RC0 (SteveT,
    15:37:35)
 
 
Meeting ended at 15:39:02 UTC
(full logs).
Action items
  - (none)
 
People present (lines said)
  - SteveT (45)
 
  - kennypaul (15)
 
  - collabot` (9)
 
  - phrobb (5)
 
  - gildaslanilis (3)
 
  - Susana (2)
 
  - jamil (2)
 
  - gilesheron (2)
 
  - Zhaoxing_Meng (2)
 
  - xinhuili (2)
 
  - cdonley (2)
 
  - davidsauvageau (1)
 
  - ningso (1)
 
  - Brianfreeman (1)
 
  - RajeshGadiyar (1)
 
  - RannyHaiby__ (1)
 
  - ildikov (1)
 
  - RannyHaiby (1)
 
  - Sanchita (1)
 
  - Lingli_Deng (1)
 
Generated by MeetBot 0.1.4.