#opendaylight-clustering: “clustering hackers"

Meeting started by moizr at 16:01:52 UTC (full logs).

Meeting summary

    1. talked briefly about Helium-2 bugs (moizr, 17:05:08)
    2. long discussion on reading data from a remote shard (moizr, 17:05:24)
    3. performance concerns with reading remote data (moizr, 17:05:43)
    4. rovarga proposes that when reading data we allow creation of transaction against a local shard replica if the local shard replica seems to be up-to-date (moizr, 17:06:48)
    5. moizr wants to understand if a change in api might be needed (moizr, 17:07:16)
    6. jmedved/colin talk about somehow co-locating apps and data to ensure high performance (moizr, 17:08:05)
    7. moizr concerned that colocating apps and data may result in us not being able to achieve scale (moizr, 17:08:53)
    8. keith brings up the point that maybe there we should be using a different sharding strategy for config/operational data (moizr, 17:10:32)
    9. rovarga thought this was available in clustered datastore (moizr, 17:11:02)
    10. moizr says this that sharding strategy is based on module and not datastore but we can change that for Lithium (moizr, 17:11:57)
    11. moizr proposes that we change or add an transaction creation API which restricts transactions to a single module (shard if possible) (moizr, 17:12:58)
    12. rovarga says that we could do that but then we could provide a different implementation of the databroker for the clustered data store. (moizr, 17:14:03)
    13. moizr wants to understand how applications could be written to work with both in-memory and clustered databroker if their APIs were different (moizr, 17:15:10)
    14. ttkacik wants discussion to move to mailing list (moizr, 17:15:27)
    15. ACTION: moizr to initiate discussions (moizr, 17:15:38)
    16. A lot of other words were said which I haven’t been able to capture in this transcript :) (moizr, 17:16:31)
    17. Next week : 30 mins of the Agenda will be used in talking about the 2-Node cluster (moizr, 17:17:02)


Meeting ended at 17:19:02 UTC (full logs).

Action items

  1. moizr to initiate discussions


Action items, by person

  1. moizr
    1. moizr to initiate discussions


People present (lines said)

  1. moizr (19)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.