#opendaylight-clustering: clustering_hackers

Meeting started by tbachman at 16:00:55 UTC (full logs).

Meeting summary

  1. agenda bashing and action items (tbachman, 16:01:08)
    1. https://meetings.opendaylight.org/opendaylight-clustering/2014/clustering_hackers/opendaylight-clustering-clustering_hackers.2014-11-25-16.02.html Minutes from last week’s meeting (tbachman, 16:01:14)
    2. topic: bug-review (tbachman, 16:06:06)
    3. topic: two-node clustering (tbachman, 16:06:11)
    4. topic: open issues (tbachman, 16:06:15)

  2. bug review (tbachman, 16:06:22)
    1. The unit tests that were failing in jenkins have been addressed (tbachman, 16:06:43)
    2. There was one issue brought up on the mailing list where the controller runs out of memory when connected to mininet. This bug should be fixed (tbachman, 16:07:12)
    3. moizr says the only bug out for review is a fix for a test, which as been merged to master but not yet stable/helium (tbachman, 16:08:13)
    4. There is a bug where ODL startup occasionally fails — this may be related to jolokia, so we may not be able to worry about it (tbachman, 16:08:39)
    5. The bug where there’s a log exception hasn’t been reproduced (tbachman, 16:08:50)
    6. moizr says there’s a bug where a remote RPC isn’t being invoked. This needs to be investigated (bug 2449) (tbachman, 16:09:18)
    7. ACTION: harman to look at bug 2449 (tbachman, 16:09:37)
    8. The stable/helium release date is soon (1/12?), so there’s not much time to address additional things (tbachman, 16:10:42)
    9. moizr is going to move all the performance improvements to lithium release (i.e. not stable/helium) (tbachman, 16:11:12)
    10. pantelis asks if these are integration, and are available to all (tbachman, 16:12:11)
    11. jmedved says that everything he runs has been committed (tbachman, 16:12:20)

  3. two-node clustering (tbachman, 16:12:30)
    1. mark says a new 2-node strategy was committed last week (tbachman, 16:12:47)
    2. half of the commit is comments explaining rationale, and a test case file laying out all the situations that will likely need testing (tbachman, 16:13:06)
    3. mark is working on a wiki page for 2-node based on the code, and will hold a meeting this thursday for those interested in the two-node design; interested parties should contact mark directly (tbachman, 16:13:48)

  4. open issues (tbachman, 16:14:01)
    1. jmedved says there’s still a memory leak somewhere. When he runs a lot of transactions, the oldgen still keeps growing and doesn’t get freed up (tbachman, 16:14:30)
    2. ACTION: jmedved to collect more information on the memory leak issue (tbachman, 16:14:48)
    3. moizr says there was a similar issue discovered by mirantis on the mailing list4 (tbachman, 16:15:01)
    4. moizr says it’s not just a memory leak, but there’s also just a lot of data in memory (tbachman, 16:15:28)
    5. jmedved says he sees the memory issues even after disconnecting mininet (tbachman, 16:15:44)


Meeting ended at 16:16:41 UTC (full logs).

Action items

  1. harman to look at bug 2449
  2. jmedved to collect more information on the memory leak issue


People present (lines said)

  1. tbachman (32)
  2. odl_meetbot (4)
  3. moizr (1)


Generated by MeetBot 0.1.4.