#opendaylight-coe: CoeWeekly-08/08/2018

Meeting started by Guest51984 at 15:21:18 UTC (full logs).

Meeting summary

  1. ONS COE demo (faseelak, 15:24:18)
    1. fkautz and faseelak are working on getting the kubernetes servcices work with kube-proxy model (faseelak, 15:24:48)
    2. aadam shares the coe kanban board (faseelak, 15:24:59)
    3. https://jira.opendaylight.org/secure/RapidBoard.jspa?rapidView=64&view=detail&selectedIssue=COE-1 (faseelak, 15:25:23)
    4. mohamed asks about the expectations for the ONS demo (faseelak, 15:26:21)
    5. fkautz explains we will keep a simple demo for ONS, and then expand it for Kubecon Seattle (faseelak, 15:26:44)
    6. an edge usecase is proposed, where multiple k8s clusters will be there, with openstack kuryr in the core, and the edge will run baremetal k8s clusters operated by ODL COE (faseelak, 15:27:29)
    7. https://docs.google.com/presentation/d/1R7qR8qiQ6uUgRPhE5bMZkagIFd2cE0OS8tfM8EYpPYk/edit?usp=sharing (faseelak, 15:32:12)
    8. when we are cross-connecting DCs, we can have either an l2 or l3 vpn (faseelak, 15:32:41)
    9. we prefer l3 for the demo, as l3 is less problematic (faseelak, 15:33:08)
    10. ACTION: fkautz to add a diagram to the presentation to describe the components of the demo (faseelak, 15:51:29)
    11. ACTION: faseelak to send the POC subtasks to aadam (faseelak, 15:51:45)
    12. ACTION: mohamed to send the tasks for odlKubeProxy to aadam (faseelak, 15:51:59)
    13. ACTION: faseelak to check the deadline for kubecon demo (faseelak, 15:52:15)
    14. ACTION: aadam to talk to kubernetes folks in redhat to see how the kubecon demo can be submitted (faseelak, 15:53:22)

  2. Patches for KubeProxy service implementation (faseelak, 15:53:49)
    1. mohamed asks why default namespace is hardcoded (faseelak, 15:53:59)
    2. fkautz explains there are a number of kubernetes systems that are spun up in a separate namespace (faseelak, 15:54:21)
    3. this makes it difficult for the communication for the current model (faseelak, 15:54:36)
    4. hence fkautz decided to flatten the namespaces to get the iptables mode working (faseelak, 15:54:53)
    5. mohamed asks why can't we use kubesystem namespace in all the pod yamls (faseelak, 15:55:51)
    6. so that things work till the ONS demo, and then we can fix it properly later (faseelak, 15:56:09)
    7. fkautz says he is a little bit concerened of reusing kubesystem namespace (faseelak, 15:56:30)
    8. hardcoding of default namespace looks a bit dangerous (faseelak, 15:57:05)


Meeting ended at 16:06:59 UTC (full logs).

Action items

  1. fkautz to add a diagram to the presentation to describe the components of the demo
  2. faseelak to send the POC subtasks to aadam
  3. mohamed to send the tasks for odlKubeProxy to aadam
  4. faseelak to check the deadline for kubecon demo
  5. aadam to talk to kubernetes folks in redhat to see how the kubecon demo can be submitted


Action items, by person

  1. aadam
    1. faseelak to send the POC subtasks to aadam
    2. mohamed to send the tasks for odlKubeProxy to aadam
    3. aadam to talk to kubernetes folks in redhat to see how the kubecon demo can be submitted
  2. faseelak
    1. faseelak to send the POC subtasks to aadam
    2. faseelak to check the deadline for kubecon demo
  3. fkautz
    1. fkautz to add a diagram to the presentation to describe the components of the demo


People present (lines said)

  1. faseelak (30)
  2. odl_meetbot (6)
  3. Guest51984 (2)
  4. fkautz (1)
  5. aadam (0)


Generated by MeetBot 0.1.4.