#opendaylight-coe: Weekly_Meeting_04_18

Meeting started by faseelak at 15:06:53 UTC (full logs).

Meeting summary

  1. building golang binaries (faseelak, 15:07:56)
    1. vthapar was asking whether there is a patch for splitting up java and golang builds (faseelak, 15:08:38)
    2. vthapar wants to do something similar in netvirt (faseelak, 15:08:54)
    3. https://git.opendaylight.org/gerrit/#/c/68911/ (faseelak, 15:09:52)

  2. service implementation (faseelak, 15:10:46)
    1. Mohamed was able to make some process on the odlKubeProxy (faseelak, 15:11:08)
    2. facing issues with netvirt build (faseelak, 15:11:16)
    3. fkautz to meet with openshift folks to discuss about standard kube proxy (faseelak, 15:12:00)
    4. fkautz to meet them in next week (faseelak, 15:12:12)
    5. standard kube proxy works with openshift and OVS.. (faseelak, 15:12:38)
    6. the same should work with ODL, and the redhat folks from openshift are willing to help (faseelak, 15:13:04)

  3. CSIT status (faseelak, 15:13:23)
    1. karthika almost done with the csit scipts (faseelak, 15:15:36)
    2. karthika is currently checking the ansible based automation of VMs written by fkautz to avoid any repitition (faseelak, 15:16:05)
    3. the current VagrantFile does not work for windows (faseelak, 15:16:48)
    4. we will need to follow https://gist.github.com/tknerr/291b765df23845e56a29 to make modifications to run the same on windows (faseelak, 15:17:07)
    5. ACTION: faseelak to try this out along with Karthika (faseelak, 15:17:27)
    6. fkautz mentions that Thanh was able to get the CSIT images with the ansible scripts (faseelak, 15:24:31)
    7. discussion around moving the ansible scripts under lfit (faseelak, 15:40:28)
    8. https://git.opendaylight.org/gerrit/#/c/68856/ (faseelak, 15:46:34)

  4. SFC integration (faseelak, 15:50:32)
    1. jaicaa was asking whether there is any component in k8s which can do service function chaining (faseelak, 15:50:55)
    2. fkautz asks to check out service-meshes (faseelak, 15:51:07)
    3. fkautz informs network service mesh currently in ligato (faseelak, 15:56:46)
    4. Martin presentation on SFC - http://events17.linuxfoundation.org/sites/events/files/slides/ContainerServiceChaining_MartinSunal.pdf (premsankar, 15:57:23)
    5. Network Service Mesh - https://docs.google.com/presentation/d/1C3r91ev0tWnFFUjiV4W84Hp965YGR1D9lChZo73Jwq0/edit#slide=id.g375263091c_1_0 (premsankar, 15:58:30)


Meeting ended at 15:59:20 UTC (full logs).

Action items

  1. faseelak to try this out along with Karthika


Action items, by person

  1. faseelak
    1. faseelak to try this out along with Karthika


People present (lines said)

  1. faseelak (26)
  2. odl_meetbot (3)
  3. premsankar (2)
  4. fkautz (1)


Generated by MeetBot 0.1.4.