#opendaylight-devforum5: Break apart the controller part 2

Meeting started by devinavery at 20:44:52 UTC (full logs).

Meeting summary

    1. Attendance is light.... but we will go on with some proposals (devinavery, 20:45:11)
    2. Use the karaf features as a dividing point - break out each feature to its own project (devinavery, 20:45:42)
    3. break the flow model out and put into open flow plugin (devinavery, 20:46:48)
    4. move stats manage, LLDP, etc to open flow plugin -- LLDP perhaps as a different bundle /feature but not part of open flow (devinavery, 20:47:34)
    5. move the topology discovery and LLDP out to possible new project (devinavery, 20:49:35)
    6. We need to identify who owns what and who is going to maintain this stuff going forward? (devinavery, 20:55:11)
    7. Suggestion - use git commit history as a first line to see who might be a good committer (devinavery, 20:57:48)
    8. just an example of a component map: https://wiki.opendaylight.org/view/BGP_LS_PCEP:Component_Map (rovarga, 20:59:53)
    9. Starting with: Step 1 (devinavery, 21:27:48)
    10. move the MD-SAL openflow components (models etc) out (devinavery, 21:28:03)
    11. Remove the sample code that is dead (devinavery, 21:28:11)
    12. remove the "old" osgi distribution ( and dependencies in other projects) (devinavery, 21:28:17)
    13. ACTION: Step 1: move the MD-SAL openflow components (models etc) out to open flow (devinavery, 21:28:39)
    14. ACTION: Step 2: Remove the sample code that is dead (devinavery, 21:28:51)
    15. ACTION: Step 3: remove the "old" osgi distribution ( and dependencies in other projects) (devinavery, 21:29:05)
    16. ACTION: start discussions on: A) remove the third party SSH, B)Start discussions on moving AD-SAL openflow to the AD-SAL plugin?, C) Start discussion on if we want to move samples to other projects?, D) Start discussion on Remove the openflowj 1.0 plugin from controller in TWS call (devinavery, 21:29:47)


Meeting ended at 21:29:54 UTC (full logs).

Action items

  1. Step 1: move the MD-SAL openflow components (models etc) out to open flow
  2. Step 2: Remove the sample code that is dead
  3. Step 3: remove the "old" osgi distribution ( and dependencies in other projects)
  4. start discussions on: A) remove the third party SSH, B)Start discussions on moving AD-SAL openflow to the AD-SAL plugin?, C) Start discussion on if we want to move samples to other projects?, D) Start discussion on Remove the openflowj 1.0 plugin from controller in TWS call


People present (lines said)

  1. devinavery (22)
  2. odl_meetbot (3)
  3. rovarga (1)


Generated by MeetBot 0.1.4.