#opendaylight-discovery: weekly discovery status

Meeting started by dbainbri at 17:59:12 UTC (full logs).

Meeting summary

    1. dbainbri (dbainbri, 17:59:23)
    2. nateharmon (nateharmon, 18:02:15)
    3. ACTION: make sure audio conference number is changed (dbainbri, 18:07:29)

  1. transition to a single project (dbainbri, 18:07:58)
    1. M2 milestone due thursday (dbainbri, 18:09:31)
    2. wiki set up (dbainbri, 18:10:33)
    3. will use this time slot for weekly meeint (dbainbri, 18:10:42)
    4. ACTION: dbainbri update weekly meeting invite (dbainbri, 18:10:50)
    5. have bugzilla account (dbainbri, 18:11:03)
    6. AGREED: use trello for stories, enhancements, tasks. bugzilla for defects (dbainbri, 18:13:38)
    7. AGREED: use ODL email list and IRC channel for communication (dbainbri, 18:14:28)
    8. Nathan used Ed Warnicke's MD-SAL archetype to check in initial structure of code (dbainbri, 18:16:22)
    9. Nate will look to push his changes in the archetype back to Ed (dbainbri, 18:21:45)
    10. Nate has been working on the identification module and node augmentation (dbainbri, 18:22:37)
    11. need to start thinking about requirements for integration tests (dbainbri, 18:24:07)
    12. will be using latest snapshot version in the master branch (dbainbri, 18:26:38)
    13. ACTION: dbainbri invite all committers to the the trello board (dbainbri, 18:27:39)
    14. need to work through use cases where OF flow modes and how drivers are invoked (dbainbri, 18:30:21)
    15. ACTION: dbainbri to take a look at the didm directory structure and get feedback back to uchau to more intent project to that same structure (dbainbri, 18:33:18)
    16. uchau (uchau, 18:33:27)
    17. AGREED: identification flow, new node added trapped by single identity module, if flow capable node that magic happens, if not, SNMP identification attempted, if identified type set and magic happens, if fails, type set to UNKNOWN and other plugins can trigger off that and if they can identify they set the type and magic happens, else it stays as UNKNOWN. (dbainbri, 18:41:47)
    18. AGREED: that augmentation for device type is inventory under operational tree. (dbainbri, 18:42:55)
    19. may want to also populate type to config for persistence as well (dbainbri, 18:43:10)
    20. IDEA: is augmentation in the same shared as inventory or do augmentations use a different sharding strategy (dbainbri, 18:45:17)
    21. ACTION: uchau checking with clustering team on sharding of augmentations (dbainbri, 18:46:01)


Meeting ended at 18:46:21 UTC (full logs).

Action items

  1. make sure audio conference number is changed
  2. dbainbri update weekly meeting invite
  3. dbainbri invite all committers to the the trello board
  4. dbainbri to take a look at the didm directory structure and get feedback back to uchau to more intent project to that same structure
  5. uchau checking with clustering team on sharding of augmentations


Action items, by person

  1. dbainbri
    1. dbainbri update weekly meeting invite
    2. dbainbri invite all committers to the the trello board
    3. dbainbri to take a look at the didm directory structure and get feedback back to uchau to more intent project to that same structure
  2. uchau
    1. dbainbri to take a look at the didm directory structure and get feedback back to uchau to more intent project to that same structure
    2. uchau checking with clustering team on sharding of augmentations


People present (lines said)

  1. dbainbri (27)
  2. odl_meetbot (3)
  3. uchau (1)
  4. nateharmon (1)


Generated by MeetBot 0.1.4.