#opendaylight-docs: docs

Meeting started by colindixon at 16:13:18 UTC (full logs).

Meeting summary

  1. maling list pages (colindixon, 16:13:24)
    1. https://wikistg.opendaylight.org/view/Main_Page/mailinglists (colindixon, 16:13:29)
    2. colindixon feels like we should really only have one -users list and it should be opendaylight-users (colindixon, 16:13:52)
    3. that's because users aren't given enought information to correctly route inquiries (colindixon, 16:14:13)
    4. -announce and security-announce are really good ones to be there (colindixon, 16:14:37)
    5. for dev lists, we need some rule as to what goes there and what doesn't (colindixon, 16:16:14)
    6. bugs should probably be removed from that list, it's machine only for sending and not clear that anyone actually wants to subscribe to it (colindixon, 16:17:01)
    7. controller-dev and dev are in-effect cross-project lists, odl-dev is an alias for dev (colindixon, 16:17:35)
    8. I like the grouping of lists in project-management, I'm not sure l like the title (colindixon, 16:18:16)
    9. should we add the security list (private for reporting things) here? (colindixon, 16:20:54)
    10. colindixon says he's not sure what we should do about our -dev lists, they servie two purposes: internal project collaboration/notification and handling development-oriented queires (colindixon, 16:24:23)
    11. they do a pretty poor job of the latter, e.g., I'm not even sure when I should sending things to controller-dev, mdsal-dev, netconf-dev, or yangtools-dev all of the time (colindixon, 16:25:11)

  2. main page items (colindixon, 16:26:48)
    1. https://wiki.opendaylight.org/view/GettingStarted:Pulling,_Hacking,_and_Pushing_All_the_Code_from_the_CLI that's the closest to a getting the code page (colindixon, 16:26:59)
    2. https://wiki.opendaylight.org/view/GettingStarted:Development_Environment_Setup this should maybe be folding into that page (and both renamed?) (colindixon, 16:29:52)
    3. odl-casey asks what we should do for making a new Main page which people can look at before it's updated (colindixon, 16:34:54)
    4. https://wiki.opendaylight.org/view/Main_Page_Candidate this was the one Ed had done (colindixon, 16:35:16)
    5. https://wiki.opendaylight.org/view/User:Dneary/Main_page this is the one Dave Neary had done (colindixon, 16:35:31)
    6. https://wiki.opendaylight.org/index.php?title=Special%3ASearch&profile=default&search=main+page&fulltext=Search (colindixon, 16:36:52)

  3. subpages not working the staging repo (colindixon, 16:42:55)
    1. colindixon says the subpages plugin isn't enable (colindixon, 16:43:03)
    2. for what it's worth dneary and colindixon feel like Mailing lists should likely be it's own top-level page (colindixon, 16:43:58)
    3. odl-casey asks about moving projects to subpages, colindixon says he thinks that this is just a matter of asking projects if they'll do it (or let you do them for it) (colindixon, 16:56:00)

  4. project categorization (colindixon, 16:56:08)
    1. colindixon says he thinks it's fine to c as long as (a) we get the categories right, (b) we let projects pick what categories they're listed in (within reason) (colindixon, 16:58:55)
    2. colindixon thinks about 5 categories: kernel, southbound plugins, services, applications, and metaprojects (colindixon, 16:59:27)
    3. colindixon says basically we just need to formally pick names for those categories, then encourages projects to add those categories to their main pages (colindixon, 17:00:26)
    4. ACTION: colindixon to bring this up at the TSC tomorrow along with the new wiki main page (colindixon, 17:01:17)


Meeting ended at 17:02:53 UTC (full logs).

Action items

  1. colindixon to bring this up at the TSC tomorrow along with the new wiki main page


Action items, by person

  1. colindixon
    1. colindixon to bring this up at the TSC tomorrow along with the new wiki main page


People present (lines said)

  1. colindixon (33)
  2. dneary (6)
  3. odl_meetbot (3)


Generated by MeetBot 0.1.4.