#opendaylight-docs: docs

Meeting started by colindixon at 16:22:33 UTC (full logs).

Meeting summary

  1. docs reviews (colindixon, 16:22:39)
    1. colindixon is way behind (colindixon, 16:22:43)
    2. colindixon says it's not just a no-op to review (colindixon, 16:22:50)
    3. colindixon notes that there are lots of things to look for, including: (colindixon, 16:23:15)
    4. 1) Don't say clone, compile, run distribution. (colindixon, 16:23:18)
    5. 2) Follow up as if somebody has readthe (colindixon, 16:23:18)
    6. 3) Incorrect info such as "ODL is a netconf controller". (colindixon, 16:23:20)
    7. 4) Grammar, spelling, (colindixon, 16:23:21)
    8. 5) format issues such as list, missing (colindixon, 16:23:23)
    9. 6) not capitalize NETCONF (colindixon, 16:23:24)
    10. 7) don't use "opendaylight controller" unless you really mean the controller project; use (colindixon, 16:23:26)
    11. 9) do not use ODL, use OpenDaylight, not Open Daylight, not OpenDayLight, not Open Day Light (colindixon, 16:23:27)
    12. 10) capitalize NETCONF, RESTCONF, (colindixon, 16:23:27)

  2. APIs (colindixon, 16:23:31)
    1. zxiiro says there's been no progress on javadoc and apidoc (colindixon, 16:23:39)
    2. colindixon says he doesn't think we'll get this until Beryllium-SR1 (colindixon, 16:23:47)

  3. meeting with NeXT (colindixon, 16:23:55)
    1. anipbu isn't getting responses (colindixon, 16:24:02)

  4. experimental features (colindixon, 16:24:06)
    1. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=879332351 prjojects are reporting experiemental feautres in Column J (colindixon, 16:24:41)

  5. action items from last time (colindixon, 16:26:48)
    1. ACTION: zxiiro to talk to yangtools about removing maven 3.1 support to get this merged and then find a second project that we could play with, likely mdsal (colindixon, 16:26:59)
    2. ACTION: colindixon to add being able to auto-generate YANG javadoc this as a requirement for Boron (colindixon, 16:27:28)
    3. ACTION: colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list (colindixon, 16:27:32)
    4. ACTION: https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this (colindixon, 16:27:36)
    5. ACTION: anipbu to set up a meeting with Denise, phrobb, CaseyODL, to get a demo from NEXT to figure out what's there and how to document it (colindixon, 16:27:56)
    6. ACTION: colindixon and phrobb to help Denise in updating the features table, there's an e-mail about this (colindixon, 16:28:21)
    7. ACTION: anipbu and colindixon to work on docs reviewing checklist using the above information (colindixon, 16:28:43)
    8. ACTION: colindixon and phrobb to review the getting started guide with Denise's updates (colindixon, 16:30:03)
    9. ACTION: colindixon to send a doodle poll about possible new docs times (colindixon, 16:43:55)


Meeting ended at 16:44:01 UTC (full logs).

Action items

  1. zxiiro to talk to yangtools about removing maven 3.1 support to get this merged and then find a second project that we could play with, likely mdsal
  2. colindixon to add being able to auto-generate YANG javadoc this as a requirement for Boron
  3. colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
  4. https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
  5. anipbu to set up a meeting with Denise, phrobb, CaseyODL, to get a demo from NEXT to figure out what's there and how to document it
  6. colindixon and phrobb to help Denise in updating the features table, there's an e-mail about this
  7. anipbu and colindixon to work on docs reviewing checklist using the above information
  8. colindixon and phrobb to review the getting started guide with Denise's updates
  9. colindixon to send a doodle poll about possible new docs times


Action items, by person

  1. anipbu
    1. anipbu to set up a meeting with Denise, phrobb, CaseyODL, to get a demo from NEXT to figure out what's there and how to document it
    2. anipbu and colindixon to work on docs reviewing checklist using the above information
  2. colindixon
    1. colindixon to add being able to auto-generate YANG javadoc this as a requirement for Boron
    2. colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
    3. https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
    4. colindixon and phrobb to help Denise in updating the features table, there's an e-mail about this
    5. anipbu and colindixon to work on docs reviewing checklist using the above information
    6. colindixon and phrobb to review the getting started guide with Denise's updates
    7. colindixon to send a doodle poll about possible new docs times


People present (lines said)

  1. colindixon (33)
  2. odl_meetbot (3)
  3. anipbu (1)


Generated by MeetBot 0.1.4.