#opendaylight-docs: docs

Meeting started by colindixon at 19:00:22 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 19:00:28)
    1. a few demos w.r.t. to read the docs from zxiiro (colindixon, 19:01:19)
    2. ACTION: colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list (colindixon, 19:03:48)
    3. ACTION: https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this (colindixon, 19:03:48)
    4. ACTION: colindixon and zxiiro to follow up with trying to get auto-generated RESTCONF API documentation for Boron (colindixon, 19:03:49)
    5. ACTION: colindixon to work with gbeauw to get a list of what he thinks should go at the end of the getting started guide (colindixon, 19:03:50)

  2. read the docs demo (colindixon, 19:05:41)
    1. zxiiro shows the readthedocs admin page (colindixon, 19:06:48)
    2. you can see the versions that are available (they're git tags and branches) (colindixon, 19:07:18)
    3. you can also force builds, but it should automatically be built whenever there are changes (colindixon, 19:07:36)
    4. you can set versions to be active or inactive (colindixon, 19:07:56)
    5. by default, old versions get big red flags at the top by default (colindixon, 19:09:46)
    6. at the bottom-rigth, you can get links to to other version, PDF, HTML, Epub, link to github (which presumably be to our gerrit, but we're not sure) (colindixon, 19:10:25)
    7. https://docs.djangoproject.com/en/1.9/intro/install/ (colindixon, 19:11:01)
    8. colindixon shows that there must be a way to get older (but suppoted version) to not throw up big red warnings and to get the development version to show a yellow warning (colindixon, 19:12:34)
    9. colindixon says he takes zxiiro at his word that we can make it work with jenkins (colindixon, 19:13:05)
    10. zxiiro notes that readthedocs has no notion of diferent docs, so we would either need to have mutiple readthedocs URLs or we'd need to have one big doc with first level headings being what our current manuals are (colindixon, 19:14:42)
    11. zxiiro corrects colindixon to say that we have one doc per git repository, so we'd need to have more than one docs repo if we wanted that (colindixon, 19:15:25)
    12. ACTION: zxiiro to createa a readthedocs topic branch in docs and set things up so that we can push to readthedocs from our actual docs repo (colindixon, 19:17:07)
    13. http://events.linuxfoundation.org/events/open-networking-summit/program/slides (colindixon, 19:21:57)


Meeting ended at 19:29:42 UTC (full logs).

Action items

  1. colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
  2. https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
  3. colindixon and zxiiro to follow up with trying to get auto-generated RESTCONF API documentation for Boron
  4. colindixon to work with gbeauw to get a list of what he thinks should go at the end of the getting started guide
  5. zxiiro to createa a readthedocs topic branch in docs and set things up so that we can push to readthedocs from our actual docs repo


Action items, by person

  1. colindixon
    1. colindixon to try to work on getting project categorization for this page https://wiki.opendaylight.org/view/Project_list
    2. https://wiki.opendaylight.org/view/Docucentral colindixon to work with casey to start to populate this
    3. colindixon and zxiiro to follow up with trying to get auto-generated RESTCONF API documentation for Boron
    4. colindixon to work with gbeauw to get a list of what he thinks should go at the end of the getting started guide


People present (lines said)

  1. colindixon (22)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.